FORUMS

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

Make Your Lockscreen More Productive With Widgets

Are you running Android Lollipop? Do you miss the ability to add widgets to your lock … more

[HOW-TO] Working MTP in Ubuntu

23 posts
Thanks Meter: 19
 
By kiwi_mat, Junior Member on 7th November 2012, 06:54 AM
Post Reply Subscribe to Thread Email Thread
I got ubuntu working with MTP on my Galaxy Nexus (and A500) using instructions for the Nexus 7. I have documented these at my website.

http://www.winters.org.nz/android-hi...-mtp-on-ubuntu

This setup is the only one I have managed to get working, I am using Ubuntu 12.10, and it should work for earlier versions.

Last edited by kiwi_mat; 11th November 2012 at 03:43 AM. Reason: Changed the URL
The Following 7 Users Say Thank You to kiwi_mat For This Useful Post: [ View ]
 
 
7th November 2012, 08:38 AM |#2  
j3r3myp's Avatar
Senior Member
Flag Paris area
Thanks Meter: 197
 
More
Thanks mate, I'll have a look. Also got Gnex, A501 and Ubuntu 12.10
8th November 2012, 01:09 AM |#3  
OP Junior Member
Flag Christchurch
Thanks Meter: 19
 
More
Quote:
Originally Posted by j3r3myp

Thanks mate, I'll have a look. Also got Gnex, A501 and Ubuntu 12.10

I found that connecting more than one device at a time didnt work - could be something in how the udev config is..

If you post the device ids for the 501 (i guess they are different), then I can add that to my page..

8th November 2012, 01:54 PM |#4  
dustrho's Avatar
Senior Member
Flag Oswego, IL
Thanks Meter: 58
 
More
I'll have to give this a try as well, as I've had no luck connecting my gnex to Windows XP, Windows 7, Ubuntu or Linux Mint. I'll be trying it out today on Ubuntu 12.10, and will report back later. Fingers crossed!

Sent from my Galaxy Nexus
9th November 2012, 12:26 AM |#5  
Dri94's Avatar
Senior Member
Flag Florida
Thanks Meter: 612
 
Donate to Me
More
Quote:
Originally Posted by dustrho

I'll have to give this a try as well, as I've had no luck connecting my gnex to Windows XP, Windows 7, Ubuntu or Linux Mint. I'll be trying it out today on Ubuntu 12.10, and will report back later. Fingers crossed!

Sent from my Galaxy Nexus

It automatically works in windows

Sent from my Galaxy Nexus using Tapatalk 2
9th November 2012, 12:33 AM |#6  
dustrho's Avatar
Senior Member
Flag Oswego, IL
Thanks Meter: 58
 
More
Quote:
Originally Posted by Dri94

It automatically works in windows

Well, it may work for you, but it has never worked for me in XP or 7. Others have experienced this as well.

Sent from my Galaxy Nexus
10th November 2012, 01:50 AM |#7  
Account currently disabled
Thanks Meter: 70
 
More
Use web based few manager...

Sent from my Galaxy Nexus using Tapatalk 2
10th November 2012, 02:27 AM |#8  
zac68's Avatar
Member
Flag Perth, WA
Thanks Meter: 21
 
More
This method works great on Ubuntu 12.04.
Works for me in Windows XP and Windows 7 as long as I turn off USB Debugging
10th November 2012, 02:01 PM |#9  
techie.raj's Avatar
Member
Flag Bangalore
Thanks Meter: 8
 
More
Quote:
Originally Posted by kiwi_mat

I got ubuntu working with MTP on my Galaxy Nexus (and A500) using instructions for the Nexus 7. I have documented these at my website.

http://www.winters.org.nz/android-ap...-mtp-on-ubuntu

This setup is the only one I have managed to get working, I am using Ubuntu 12.10, and it should work for earlier versions.


First of all thanks a lot for solving this long pending issue.

Everything worked for me mounting, data transfer through MTP, but while unmounting I am getting an error saying that "umount: /media/Nexus mount disagrees with the fstab"

I am using Ubuntu 12.04, Nexus 4.1.2
Last edited by techie.raj; 10th November 2012 at 02:05 PM.
10th November 2012, 05:04 PM |#10  
Account currently disabled
Thanks Meter: 70
 
More
use wifi explorer pro its web based....

https://play.google.com/store/apps/d...lorerPRO&hl=en
11th November 2012, 03:53 AM |#11  
OP Junior Member
Flag Christchurch
Thanks Meter: 19
 
More
Quote:
Originally Posted by techie.raj

First of all thanks a lot for solving this long pending issue.

Everything worked for me mounting, data transfer through MTP, but while unmounting I am getting an error saying that "umount: /media/Nexus mount disagrees with the fstab"

I am using Ubuntu 12.04, Nexus 4.1.2


when the nexus is connected issue the mount command in a terminal, you should see something like..
Code:
DeviceFs(Galaxy Nexu on /media/GalaxyNexus type fuse.DeviceFs(Galaxy Nexu (rw,nosuid,nodev,allow_other,user=username)
its possable your device name is different, so check the fstab line,
Code:
DeviceFs(Galaxy\040Nexu)    /media/GalaxyNexus    fuse.DeviceFs(Galaxy\040Nexu)    allow_other,rw,user,noauto    0    0
the DeviceFS (both) must match above except the space in the mount listing has to be replaced with \040 as space is the field separator in fstab..
The Following User Says Thank You to kiwi_mat For This Useful Post: [ View ]

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes