Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[HOW-TO] Working MTP in Ubuntu

OP kiwi_mat

11th November 2012, 04:53 AM   |  #11  
OP Junior Member
Flag Christchurch
Thanks Meter: 19
 
23 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by techie.raj

First of all thanks a lot for solving this long pending issue.

Everything worked for me mounting, data transfer through MTP, but while unmounting I am getting an error saying that "umount: /media/Nexus mount disagrees with the fstab"

I am using Ubuntu 12.04, Nexus 4.1.2


when the nexus is connected issue the mount command in a terminal, you should see something like..
Code:
DeviceFs(Galaxy Nexu on /media/GalaxyNexus type fuse.DeviceFs(Galaxy Nexu (rw,nosuid,nodev,allow_other,user=username)
its possable your device name is different, so check the fstab line,
Code:
DeviceFs(Galaxy\040Nexu)    /media/GalaxyNexus    fuse.DeviceFs(Galaxy\040Nexu)    allow_other,rw,user,noauto    0    0
the DeviceFS (both) must match above except the space in the mount listing has to be replaced with \040 as space is the field separator in fstab..
The Following User Says Thank You to kiwi_mat For This Useful Post: [ View ]
11th November 2012, 06:16 AM   |  #12  
dustrho's Avatar
Senior Member
Flag Oswego, IL
Thanks Meter: 58
 
879 posts
Join Date:Joined: Sep 2009
More
Quote:
Originally Posted by zac68

Works for me in Windows XP and Windows 7 as long as I turn off USB Debugging

Does USB Debugging have to be turned off in order for this to work in XP and 7? I haven't tried that before, so that's something else I'll have to try.
11th November 2012, 06:28 AM   |  #13  
zac68's Avatar
Member
Flag Perth, WA
Thanks Meter: 20
 
87 posts
Join Date:Joined: Jun 2007
More
Quote:
Originally Posted by dustrho

Does USB Debugging have to be turned off in order for this to work in XP and 7? I haven't tried that before, so that's something else I'll have to try.

In XP I have to do it. Windows 7 with Service Pack 1, from memory might not of be as fussy. I could be wrong though. I use Ubuntu these days.
11th November 2012, 12:22 PM   |  #14  
Junior Member
Thanks Meter: 2
 
8 posts
Join Date:Joined: Jul 2012
Am I misssing something here? It connects automatically with my Ubuntu 12.10 without having to configure anything. It does not in fastboot state though.

Sent from my Galaxy Nexus using Tapatalk 2
24th November 2012, 07:43 PM   |  #15  
PanzerGeist's Avatar
Junior Member
Flag Seattle, WA
Thanks Meter: 0
 
26 posts
Join Date:Joined: Feb 2010
More
Sucks... between myself and my room mate, we've tried this on three different systems (lubuntu, xubuntu, ubuntu - 12.10 in each case) and had no luck with it. Neither with the Nexus 7 or the G Nex.
25th November 2012, 03:23 AM   |  #16  
gnustomp's Avatar
Senior Member
Flag mount /dev/sda1 /home
Thanks Meter: 147
 
434 posts
Join Date:Joined: Nov 2012
More
Works perfectly -- EXCEPT when multiple devices are connected. Is it possible to make go-mtpfs recognise the devices and mount them correctly? Right now when there are multiple devices it just gives up.
26th November 2012, 05:34 AM   |  #17  
techie.raj's Avatar
Member
Flag Bangalore
Thanks Meter: 8
 
81 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by kiwi_mat

when the nexus is connected issue the mount command in a terminal, you should see something like..

Code:
DeviceFs(Galaxy Nexu on /media/GalaxyNexus type fuse.DeviceFs(Galaxy Nexu (rw,nosuid,nodev,allow_other,user=username)
its possable your device name is different, so check the fstab line,
Code:
DeviceFs(Galaxy\040Nexu)    /media/GalaxyNexus    fuse.DeviceFs(Galaxy\040Nexu)    allow_other,rw,user,noauto    0    0
the DeviceFS (both) must match above except the space in the mount listing has to be replaced with \040 as space is the field separator in fstab..


Hi Thanks for your reply. Sorry for the delay in replying....

Your suggestion couldn't solve my problem.

My fstab entry is as follows
Quote:

DeviceFs(Galaxy\040Nexu) /media/Nexus/ fuse.DeviceFs(Galaxy\040Nexu) allow_other,rw,user,noauto 0 0

and the mount command that I executed are (command and corresponding output are )

Quote:

DeviceFs(Galaxy Nexu on /media/Nexus type fuse.DeviceFs(Galaxy Nexu (rw,nosuid,nodev,allow_other,user=raj)
bash: syntax error near unexpected token `Galaxy'

Second attempt

Quote:

DeviceFs(Galaxy\040Nexu on /media/Nexus type fuse.DeviceFs(Galaxy\040Nexu (rw,nosuid,nodev,allow_other,user=raj)
bash: syntax error near unexpected token `Galaxy\040Nexu'

Could you understand where the problem lies.

Am I doing any thing wrong....

Thanks a lot for your efforts...
Last edited by techie.raj; 26th November 2012 at 05:36 AM. Reason: formatting was not correct.
27th December 2012, 04:03 PM   |  #18  
emmerich1234's Avatar
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Aug 2012
Error in /etc/fstab
1st: thanks for your work doing it for all

2nd: I use an Acer Iconia Tab A501 running Android 4.xy

I followed the instruction. I did the following line in my /etc/fstab

DeviceFs(A501) /media/A501 fuse.DeviceFs(A501) allow_other,rw,user,noauto 0 0

-----------> it comes an error message "/bin/sh: 1: DeviceFs(A501): not found"

(The id_modell=Acer_Iconia_Tab_A501. I tried, but the same error.)

------- snip ---(28.12.2012-thk)------> usb-devices:
T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 14 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0502 ProdID=3345 Rev=99.99
S: Manufacturer=Acer
S: Product=Acer Iconia Tab A501
S: SerialNumber=1234567890
C: #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=00 Driver=usbfs
------- snap ---------

Where is my fault?
Last edited by emmerich1234; 28th December 2012 at 11:07 AM. Reason: addition
29th December 2012, 10:06 AM   |  #19  
emmerich1234's Avatar
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Aug 2012
Next step
Quote:
Originally Posted by emmerich1234

1st: thanks for your work doing it for all

2nd: I use an Acer Iconia Tab A501 running Android 4.xy

I followed the instruction. I did the following line in my /etc/fstab

DeviceFs(A501) /media/A501 fuse.DeviceFs(A501) allow_other,rw,user,noauto 0 0

-----------> it comes an error message "/bin/sh: 1: DeviceFs(A501): not found"

(The id_modell=Acer_Iconia_Tab_A501. I tried, but the same error.)

------- snip ---(28.12.2012-thk)------> usb-devices:
T: Bus=01 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#= 14 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0502 ProdID=3345 Rev=99.99
S: Manufacturer=Acer
S: Product=Acer Iconia Tab A501
S: SerialNumber=1234567890
C: #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=00 Driver=usbfs
------- snap ---------

Where is my fault?

Try to understand the source code (go langualge) and may be append the A501?
29th December 2012, 06:33 PM   |  #20  
Recognized Developer
Thanks Meter: 4,329
 
8,061 posts
Join Date:Joined: Jan 2011
More
Has anyone had an issue accessing it?

Could not display "/media/GalaxyNexus".

Error: Error when getting information for file '/media/GalaxyNexus': Transport endpoint is not connected
Please select another viewer and try again.

I know the udev configuration looks fine and adb works fine and it tries to mount the device for MTP but I get the above error. I'm not using Ubuntu but my go-mtps install has been updated on git and I have the latest version of fuse and followed the instructions.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes