Post Reply

SMSC, PDU Encoder, I don't send mesage nexus 5

OP Kralumut

15th May 2014, 11:43 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: May 2014
Hello. I get the message, but I cannot send. The message center number: +905598008000 please help me. SMSC part of what is to be entered? Thanks. Country:Turkey avea
I've accomplished, how is that? ı have nexus 5
15th May 2014, 07:27 PM   |  #2  
seriousia's Avatar
Senior Member
Thanks Meter: 225
 
621 posts
Join Date:Joined: Jan 2011
Dial *#*#4636#*#* then go to Phone Information you can see the “SMSC: ” field.

Tip: DON’T PRESS UPDATE, PRESS “REFRESH” TO SEE THE CURRENT SETTING!!!

For example if actual SMSC number is: +447785016005, however inputting this into the field and hitting update just produces “update error”. The issue is that this needs to be translated into PDU format (Protocol Description Unit) and you can do that here:

http://www.twit88.com/home/utility/s...-encode-decode.

For the number above, this turns out to be 0791447758100650

For some people, entering the PDU number above into your SMSC field in the testing menu and pressing “update” will have the desired effect but for me, the “update” button won’t work unless you have a “+” in front of the number which is no use at all.

The solution? Take the SIM card out and stick it in a non-android phone , go to the messageing app, settings, message centre number and enter the real number, i.e. +447785016005.

Save, exit, power off, replace SIM into Android phone, job done.

Sent from my Galaxy Nexus using xda premium
Last edited by seriousia; 15th May 2014 at 07:32 PM.
The Following User Says Thank You to seriousia For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Galaxy Nexus General by ThreadRank