FORUMS

XDA Picks: Best Apps of the Week (May 15 – 30)

Apps are at the front and center of any smartphone experience, and with over a … more

Google No Longer Sending Calendar SMS Notifications

In a not entirely surprising move, Google announced that it’s putting an … more

Enable Multi-Window Mode on M Developer Preview

What was not mentioned in yeterday’s keynote was Android M’s multi-window … more

I/O Summary: Google Cardboard Virtual Reality

One year ago, Google introduced cardboard. Amazingly enough, that was all it took to fire … more

[TUTORIAL] Setting up and Compiling JB and ICS from AOSP

Thanks Meter: 1,305
 
By shenye, Retired Forum Moderator / Recognized Developer on 11th December 2011, 02:22 PM
Post Reply Subscribe to Thread Email Thread
14th December 2011, 02:17 PM |#11  
Member
Thanks Meter: 25
 
More
Perfect, ta muchly.
 
 
14th December 2011, 10:09 PM |#12  
beekay201's Avatar
Senior Member
Thanks Meter: 1,194
 
More
Quote:
Originally Posted by ljwnow

Why? It's great for people to learn.

Sent from my Galaxy Nexus using xda premium

If you didn't code it yourself, it doesn't belong in dev subforum. There's Q&A subforum for that.

/me sent this on a i9250 using tapatalk
15th December 2011, 06:49 AM |#13  
Romanbb's Avatar
Recognized Developer
Thanks Meter: 7,034
 
Donate to Me
More
Quote:
Originally Posted by dave_t321

Has anyone managed to build the android-4.0.1_r1.2 branch with Ubuntu 11.10?

I know it works on the master branch and the r1 branch supposedly didn't support it but have the build tools been updated this one?

Just wanted to check before commiting to a massive download!

Yeah -- there are a few fixes you need to do, here are a few main ones:

https://github.com/TeamKang/external...6535b5c5084b94

https://github.com/TeamKang/framewor...dbc791ff3a5d82

https://github.com/CyanogenMod/andro...72fa40af837376

I think there may be one or two more, just google the errors you get
20th December 2011, 06:41 PM |#14  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,666
 
More
Just a quick question...

I've just compiled a ROM using the guide, got the binaries, etc. etc. but the build.prop from the resulting ROM had LOADS of random entries in it for LTE phones? and it's all singray as opposed to maguro. Have I done something wrong?
20th December 2011, 06:43 PM |#15  
shenye's Avatar
OP Retired Forum Moderator / Recognized Developer
Flag London
Thanks Meter: 1,305
 
Donate to Me
More
Quote:
Originally Posted by EddyOS

Just a quick question...

I've just compiled a ROM using the guide, got the binaries, etc. etc. but the build.prop from the resulting ROM had LOADS of random entries in it for LTE phones? and it's all singray as opposed to maguro. Have I done something wrong?

Yeah you've compiled it for the wrong device. I forgot to update the lunch menu bit, cos they added the xoom and the nexus s onto the list. You want full eng maguro. I'll fix it now.
20th December 2011, 06:49 PM |#16  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,666
 
More
Just realised that, option 4 in the lunch menu isn't the GN - it's 8

Rebaking
21st December 2011, 07:39 AM |#17  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,666
 
More
OK, correct ROM built this time. Compiled it as .IMG files so I could then get it into the kitchen but once the ROM has been rooted, etc. it won't flash - I get a Status 7 error mentioning the boot.img

Any suggestions?

P.S. The 8 in your guide is smaller than the rest of the text
21st December 2011, 10:08 AM |#18  
shenye's Avatar
OP Retired Forum Moderator / Recognized Developer
Flag London
Thanks Meter: 1,305
 
Donate to Me
More
Probably a bad repack of the boot.img?
21st December 2011, 11:43 AM |#19  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,666
 
More
Not too sure, took the boot.img from a known working 4.0.3 ROM and still get the same error:

assert failed: write_raw_image("/tmp/boot.img". "/dev/block/platform/omap/omap_hsmc.0/by-name/boot")
E:Error in/sdcard/update.zip
(Status 7)
Installation aborted.
21st December 2011, 03:07 PM |#20  
EddyOS's Avatar
Recognized Contributor
Flag Liverpool, Merseyside
Thanks Meter: 3,666
 
More
Fixed, dsixda updated the kitchen to extract the boot.img before flashing (which is why it was failing before)
Post Reply Subscribe to Thread

Tags
compile ics maguro aosp
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes