Post Reply

3g data and wi-fi problem

22nd February 2013, 01:38 PM   |  #1  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Apr 2012
Hi guys!

I have got a problem with my samsung galaxy nexus stock version,
without root or unlocked bootloader.
The problem is about the 3g connection and wifi when I turn off the display.

3g: when I turn off the display, after a few minutes, the phone loses the data connection. It is like it goes in power saving mode because when I
turn on the display the signal icon turns grey and after a few instants blu. In fact mail, notifications, and whatsapp's messages are notified with
a 10-15 minutes delay.

wifi: same problem, when I turn off the display I lose the signal. When I turn on the display, the wifi icon disappear for an instant, become grey and then blue. Until it turns blue I don't get notifications.

I have already done several factory resets, disabled power saving settings
and I don't use any power management apps.
SMS and calls works fine.

help me please
22nd February 2013, 07:07 PM   |  #2  
M3drvr's Avatar
Senior Member
Flag Calgary, AB
Thanks Meter: 165
 
782 posts
Join Date:Joined: Jun 2011
More
Welcome to the club. I have the exact same issue and had a thread going about this. Nothing i've done has solved the problem. Even gone right to complete stock rom. Same problem. I noticed this started happening with 4.2. Before that i didn't have a problem. Mine only happens on Wi-Fi, no issue on mobile network connecitons. As well it happens no matter what router i'm connected to. This should be in the Q&A and troubleshooting section though...

With W-Fi make sure its set to always on in advanced Wi-Fi settings and that minimize power is unchecked as well as avoid poor connecitons. Might help for you.
23rd February 2013, 07:27 AM   |  #3  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by M3drvr

Welcome to the club. I have the exact same issue and had a thread going about this. Nothing i've done has solved the problem. Even gone right to complete stock rom. Same problem. I noticed this started happening with 4.2. Before that i didn't have a problem. Mine only happens on Wi-Fi, no issue on mobile network connecitons. As well it happens no matter what router i'm connected to. This should be in the Q&A and troubleshooting section though...

With W-Fi make sure its set to always on in advanced Wi-Fi settings and that minimize power is unchecked as well as avoid poor connecitons. Might help for you.

I think the problem started happening with 4.1

And I've all the settings you said
23rd February 2013, 09:05 AM   |  #4  
Senior Member
Thanks Meter: 75
 
702 posts
Join Date:Joined: Oct 2010
More
Re: 3g data and wi-fi problem
I've dealt with the issue since updating to all the 4.2.x Roms. Not sure what it is, but its here to stay.

Sent from my Galaxy Nexus using XDA Premium HD app
23rd February 2013, 10:50 AM   |  #5  
andQlimax's Avatar
Senior Member
Flag Rome
Thanks Meter: 854
 
2,365 posts
Join Date:Joined: Jul 2010
Donate to Me
More
R: 3g data and wi-fi problem
Same me..I think it started with 4.2

I have 2 WiFi routers and have disconnection problems while screem off with only one router ( I know this router is crap but it should not happen, android should handle it)

Inviato dal mio Galaxy Nexus con Tapatalk 2
23rd February 2013, 11:47 AM   |  #6  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Apr 2012
Quote:
Originally Posted by alexdemonumber3

I've dealt with the issue since updating to all the 4.2.x Roms. Not sure what it is, but its here to stay.

Sent from my Galaxy Nexus using XDA Premium HD app

Quote:
Originally Posted by andQlimax

Same me..I think it started with 4.2

I have 2 WiFi routers and have disconnection problems while screem off with only one router ( I know this router is crap but it should not happen, android should handle it)

Inviato dal mio Galaxy Nexus con Tapatalk 2

do you have problem with the 3g also?
23rd February 2013, 12:45 PM   |  #7  
andQlimax's Avatar
Senior Member
Flag Rome
Thanks Meter: 854
 
2,365 posts
Join Date:Joined: Jul 2010
Donate to Me
More
R: 3g data and wi-fi problem
Quote:
Originally Posted by diabolnik

do you have problem with the 3g also?

Nope..only with one WiFi router

Inviato dal mio Galaxy Nexus con Tapatalk 2
23rd February 2013, 04:58 PM   |  #8  
Senior Member
Thanks Meter: 75
 
702 posts
Join Date:Joined: Oct 2010
More
Re: 3g data and wi-fi problem
Quote:
Originally Posted by diabolnik

do you have problem with the 3g also?

No, fortunately. Only WiFi.

Sent from my Galaxy Nexus using XDA Premium HD app[COLOR="Silver"]
23rd February 2013, 07:07 PM   |  #9  
M3drvr's Avatar
Senior Member
Flag Calgary, AB
Thanks Meter: 165
 
782 posts
Join Date:Joined: Jun 2011
More
Yeah my problems aren't on 3G. Rarely have I had that drop out. It's happened, but that's once a month tops.

I've gone to the point of buying a high end router to exchange my old router. No difference. I had a Cisco e4200 and now an e6500. Also had a D-link Dir655. Happened on all of those. Happens at Starbucks and at work too on their routers.

It's software problem for sure. And it can be fixed. And complaints have been put up on Google code site. There are at least 5-600 posts on that topic with people suffering the same problem. Why don't they fix it? No idea.
24th February 2013, 09:43 AM   |  #10  
OP Junior Member
Thanks Meter: 1
 
7 posts
Join Date:Joined: Apr 2012
UPDATE

To let the wifi work, I have downloaded the app "wi-fi fixer" and using it I
fixed (just a workaround) the wifi issue!!

But what can I do about the3G connection?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes