Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Bluetooth won't enable after OTA 4.2 update

OP retro83

20th November 2012, 11:57 PM   |  #1  
retro83's Avatar
OP Member
Thanks Meter: 7
 
34 posts
Join Date:Joined: Aug 2010
Just done 4.2 update after I was offered it.
However my Bluetooth now will not enable. The notification bar Bluetooth icon highlights but goes back to grey, the on/off slider in settings immediately goes back to off and the power widget BT icon does nothing.

Any ideas? Searched the board but all i could find were people with stuttering issues, not complete failure to activate bluetooth.

Thanks
21st November 2012, 12:00 AM   |  #2  
Member
Flag Edmonton
Thanks Meter: 19
 
47 posts
Join Date:Joined: Nov 2012
More
Might be a stupid question, but have you tried rebooting the phone?

My phone ocassionally locks itself in "shutting off bluetooth" mode, but a reboot has always fixed it.
21st November 2012, 12:01 AM   |  #3  
retro83's Avatar
OP Member
Thanks Meter: 7
 
34 posts
Join Date:Joined: Aug 2010
How embarrassing. Looks like a fair amount of people have the same issue:
https://code.google.com/p/android/is...ummary%20Stars
http://forum.xda-developers.com/show....php?t=1988998


Edit: yes, forgot to say, have rebooted and powered off/removed battery - still no change.
Last edited by retro83; 21st November 2012 at 12:04 AM.
23rd November 2012, 12:57 PM   |  #4  
Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Nov 2012
Some solution?

Sent from my Galaxy Nexus using xda app-developers app
23rd November 2012, 01:03 PM   |  #5  
Senior Member
Flag Gothenburg
Thanks Meter: 42
 
234 posts
Join Date:Joined: Sep 2010
More
From what I've read the solution is to flash the factory image instead, or possibly just factory reset the phone.

But be aware that even with a cleanly flashed phone, BT has major issues in 4.2. Stuttering audio, disconnects, etc. Not everyone seems to be affected by this for whatever reason, but the new BT stack is definitely no hit.
23rd November 2012, 01:42 PM   |  #6  
JoeDoom's Avatar
Member
Los Angeles
Thanks Meter: 5
 
30 posts
Join Date:Joined: Oct 2012
More
Yeah, having the same exact issues. I'll wait for 4.2.1 before I flash any images.
28th November 2012, 11:49 PM   |  #7  
retro83's Avatar
OP Member
Thanks Meter: 7
 
34 posts
Join Date:Joined: Aug 2010
Don't bother, still broken in 4.2.1

Bug number again: 39688. Please star it if you have the issue.
24th February 2013, 06:16 AM   |  #8  
Senior Member
Thanks Meter: 13
 
293 posts
Join Date:Joined: Jul 2009
i know this thread hasnt been updated in a while but for anyone finding this thread through various searches, the fix to try if you are rooted is linked below. It appeared to be a simple permissions issue

http://forum.xda-developers.com/show....php?t=2065962

Post Reply Subscribe to Thread

Tags
4.2, bluetooth
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes