5,598,938 Members 30,941 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bluetooth won't enable after OTA 4.2 update

Tip us?
 
retro83
Old
#1  
retro83's Avatar
Member - OP
Thanks Meter 7
Posts: 34
Join Date: Aug 2010
Default [Q] Bluetooth won't enable after OTA 4.2 update

Just done 4.2 update after I was offered it.
However my Bluetooth now will not enable. The notification bar Bluetooth icon highlights but goes back to grey, the on/off slider in settings immediately goes back to off and the power widget BT icon does nothing.

Any ideas? Searched the board but all i could find were people with stuttering issues, not complete failure to activate bluetooth.

Thanks
 
meisanerd
Old
#2  
Member
Thanks Meter 18
Posts: 44
Join Date: Nov 2012
Location: Edmonton
Might be a stupid question, but have you tried rebooting the phone?

My phone ocassionally locks itself in "shutting off bluetooth" mode, but a reboot has always fixed it.
 
retro83
Old
(Last edited by retro83; 20th November 2012 at 11:04 PM.)
#3  
retro83's Avatar
Member - OP
Thanks Meter 7
Posts: 34
Join Date: Aug 2010
How embarrassing. Looks like a fair amount of people have the same issue:
https://code.google.com/p/android/is...ummary%20Stars
http://forum.xda-developers.com/show....php?t=1988998


Edit: yes, forgot to say, have rebooted and powered off/removed battery - still no change.
 
CAM1L
Old
#4  
Junior Member
Thanks Meter 0
Posts: 2
Join Date: Nov 2012
Some solution?

Sent from my Galaxy Nexus using xda app-developers app
 
RoadHazard
Old
#5  
Senior Member
Thanks Meter 37
Posts: 197
Join Date: Sep 2010
Location: Gothenburg
From what I've read the solution is to flash the factory image instead, or possibly just factory reset the phone.

But be aware that even with a cleanly flashed phone, BT has major issues in 4.2. Stuttering audio, disconnects, etc. Not everyone seems to be affected by this for whatever reason, but the new BT stack is definitely no hit.
SGS3 - CyanogenMod 10.2 nightly
 
JoeDoom
Old
#6  
JoeDoom's Avatar
Member
Thanks Meter 5
Posts: 30
Join Date: Oct 2012
Location: Los Angeles
Yeah, having the same exact issues. I'll wait for 4.2.1 before I flash any images.
 
retro83
Old
#7  
retro83's Avatar
Member - OP
Thanks Meter 7
Posts: 34
Join Date: Aug 2010
Don't bother, still broken in 4.2.1

Bug number again: 39688. Please star it if you have the issue.
 
jblade1000
Old
#8  
Senior Member
Thanks Meter 13
Posts: 287
Join Date: Jul 2009
i know this thread hasnt been updated in a while but for anyone finding this thread through various searches, the fix to try if you are rooted is linked below. It appeared to be a simple permissions issue

http://forum.xda-developers.com/show....php?t=2065962
Device History

Phones
Palm Treo 680 unlocked (long gone)|HTC TouchPro 2 (screen cracked) | Samsung Vibrant (fiancee's phone) Stock Froyo KA6 rooted + KB1 modem | Samsung Nexus S Stock JRO03E-rooted w/ClockWorkMod Touch (sold!) | Samsung Galaxy Nexus Stock JDQ39 rooted (Alt Phone with ATT sim)|Samsung Galaxy S4 (Verizon) Stock VRUAMDK+ Root and TWRP recovery
Tablets
Samsung Galaxy Tab 7.0 Plus 32 gig Stock Ice Cream Sandwich 4.0.4 rooted (used as the center piece of my in car entertainment)

Tags
4.2, bluetooth
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes