Default [Q] Boothang Problem Reverting Back To 4.3 After 4.4

So I've recently been having an issue with my phone that I haven't been able to fix through various standard fix methods. I've tried searching for this exact issue but the only thing that seems to work for other people (albeit they were on different devices when they had this problem) hasn't fixed my issue.

Long story short, I went from SlimROM 2.2 (and many other 4.3 based ROMS) to ForkMyLife 4.4.2 to try out KitKat, and I eventually wanted to go back to SlimROM.

I always full wipe (System/Data/Cache/Delvik) and then flash my ROM (in this case it was Slim), a reboot netted me a bootloop/boothang on the bootanimation. Wiping Cache+Delvik cache will get me to Optimizing Apps, but then it hangs at Starting Apps. At which point I can battery pull, restart, and it will restart just fine (typically, I did have one time where this didn't work). But I'd have to do this series of events every single time I reboot. I've tried multiple ROMs, multiple kernels, but everything ends up doing the same thing after a reboot. I've even done a full Stock 4.2.2 Image flashing (full SDCARD/DATA wipe an everything) using mskip's Toolkit, re-rooted and re-did my entire phone to Liquid 2.37 booted up the first time no problems, but the boothang was back on the very first reboot.

What is somewhat odd to me, is that I can run a 4.4 based ROM with no boot issues though. I ran FML 4.4.2 for a few days and numerous reboots, and the same for OmniMetal 4.4.2 to see if it would lead to any boothangs and I had no problems with either.


Any ideas or thoughts from anyone on why reverting back to 4.3 after a 4.4 ROM would cause so many issues?