Google Play Developer Distribution Agreement Due Tomorrow

Every once in a while, Google updates theGoogle PlayDeveloper Distribution … more

LG to Release Octa-Core “Nuclun” SoC in the LG G3 Screen

LG is set to follow the likes of Samsung and other manufacture its own … more

Lockdown Pro 2 Brings Material Design and Media Support

Back in March of this year, we took a look at a rather innovated security application … more

Mural Watchface Brings 500px to Android Wear

On a traditional watch, you can’t really do too much to change its appearance once … more
Post Reply

Galaxy Nexus lagging immensely.

OP Theshawty

11th April 2014, 12:03 PM   |  #1  
Theshawty's Avatar
OP Senior Member
Thanks Meter: 4,480
 
1010
15,431 posts
Join Date:Joined: Feb 2011
More
Hey guys. I borrowed my brother's old Galaxy Nexus while my HTC One is being repaired and I couldn't help noticing it lags. Immensely. I flashed SlimKat build 3 on it and before that I ran LiquidSmooth. I was under the impression that KitKat was supposed to be less resource hungry.

Is it because it's not "official" (from Google)? Would 4.3 run better, say in the form of CM10.2.1 stable?
11th April 2014, 04:49 PM   |  #2  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Mar 2013
Quote:
Originally Posted by Theshawty

Hey guys. I borrowed my brother's old Galaxy Nexus while my HTC One is being repaired and I couldn't help noticing it lags. Immensely. I flashed SlimKat build 3 on it and before that I ran LiquidSmooth. I was under the impression that KitKat was supposed to be less resource hungry.

Is it because it's not "official" (from Google)? Would 4.3 run better, say in the form of CM10.2.1 stable?

Try Deleting The (Google +) and if its Build in App try deleting it with Root Permission.
this Should Fix that Lag. It did For mine ^.^
11th April 2014, 05:33 PM   |  #3  
Senior Member
Flag Vancouver
Thanks Meter: 481
 
3,122 posts
Join Date:Joined: Jan 2010
More
The unfortunate reality is that most Galaxy Nexus units have sluggish internal storage, and any background processes that are trying to write to it while you interact with the phone can create lag in processing and the UI. It was such a relief to switch to the Nexus 5.
11th April 2014, 10:01 PM   |  #4  
mrgnex's Avatar
Senior Member
Flag Vlaardingen
Thanks Meter: 298
 
1,028 posts
Join Date:Joined: Jan 2013
More
Mine is not lagging but not fast too.. But with the right rom and kernel and some tweaking its pretty fast for its age

Sent from my Galaxy Nexus using xda app-developers app
11th April 2014, 10:47 PM   |  #5  
Theshawty's Avatar
OP Senior Member
Thanks Meter: 4,480
 
1010
15,431 posts
Join Date:Joined: Feb 2011
More
I flashed back to 4.3. CM10.2 stable and now it runs better but still lagging. Not as much, though.
12th April 2014, 05:17 PM   |  #6  
faisalrizal79's Avatar
Junior Member
Thanks Meter: 17
 
18 posts
Join Date:Joined: Apr 2014
lets try cm11 remix .....
12th April 2014, 10:16 PM   |  #7  
kingshads's Avatar
Member
Thanks Meter: 4
 
58 posts
Join Date:Joined: Aug 2011
Let me know how it is.running slimkat right now and I'm getting pretty much decent performance. We all have to remember this phone is older. I've been trying to justify getting the nexus 5. Will wait until the price comes down a little bit

Sent from the homie
14th April 2014, 01:06 AM   |  #8  
toknitup420's Avatar
Senior Member
Flag boston
Thanks Meter: 309
 
871 posts
Join Date:Joined: Jan 2011
More
Quote:
Originally Posted by Theshawty

Hey guys. I borrowed my brother's old Galaxy Nexus while my HTC One is being repaired and I couldn't help noticing it lags. Immensely. I flashed SlimKat build 3 on it and before that I ran LiquidSmooth. I was under the impression that KitKat was supposed to be less resource hungry.

Is it because it's not "official" (from Google)? Would 4.3 run better, say in the form of CM10.2.1 stable?

It's just the phone. My work phone is a gnex bone stock. And it lags horribly.
14th April 2014, 10:37 AM   |  #9  
Ed V's Avatar
Senior Member
Nexus Island
Thanks Meter: 117
 
293 posts
Join Date:Joined: Jan 2013
More
Mine is very fast, no lag at all, even after more than 1700 hours without rebooting
Vanir 4.3.1 (final version)


.
17th April 2014, 08:02 PM   |  #10  
Theshawty's Avatar
OP Senior Member
Thanks Meter: 4,480
 
1010
15,431 posts
Join Date:Joined: Feb 2011
More
This thread is active again. I thought I could get my One yesterday but Telecare messed up and sent me one that had even more tint than before, so I'm stuck with this until after May 9th because my carrier store closes for renovation between April 22nd and May 9th..

C'est la vie.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes