Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,805,313 Members 49,686 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [GNex] [GSM] No signal; radio failed startup looping?

Tip us?
 
mmoufarrij
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: May 2012
Exclamation [Q] [GNex] [GSM] No signal; radio failed startup looping?

Hello.
My problem is this: I have absolutely no signal on my GSM Galaxy Nexus. (There's a small grey x on the indicator).
  • Baseband and IMEI both show correct values (it's not an /efs issue).
  • I recently reverted the phone to 100% factory state (downloaded correct images from the Google Developers page and flashed them and re-locked bootloader). No luck.
  • Previously, I had flashed CWM and AOKP Milestone 5. The issue was present then.
  • I also restored a NANDROID backup that I made when I first got the phone; the issue persists.
  • Weirdest of all, there are random, short times where I get a signal. However they're far apart and very sporadic.

The problem seems to come from the following logcat output. It loops incessantly whenever the phone is on: (seems to be the radio trying to start up unsuccessfully)

Code:
D/        ( 1392): [CP BOOT] __boot_6260: START CP BOOT
D/        ( 1392): [CP BOOT] __boot_6260: CP POWER ON DONE
D/        ( 1392): [CP BOOT] mipi_xmit_atat: SENT ATAT 0
D/        ( 1392): [CP BOOT] mipi_xmit_atat: SENT ATAT 1
D/        ( 1392): [CP BOOT] __boot_6260: XIMT PSI DONE
D/        ( 1392): [CP BOOT] __boot_6260: XIMT EBL DONE
D/        ( 1392): [CP BOOT] __boot_6260: SET EBL DONE
D/        ( 1392): [CP BOOT] __boot_6260: REQSECSTART CMD DONE
D/        ( 1392): [CP BOOT] __boot_6260: XMIT MODEM_MAIN DONE
D/        ( 1392): [CP BOOT] __boot_6260: XMIT MODEM_NV DONE
D/        ( 1392): [CP BOOT] __boot_6260: READ MPS DATA DONE : ALB
D/        ( 1392): [CP BOOT] __boot_6260: SEND MPS DONE : ALB(0x61080000)
D/        ( 1392): [CP BOOT] __boot_6260: REQSECEND CMD DONE
D/        ( 1392): [CP BOOT] __boot_6260: REQFORCEHWRESET CMD DONE
D/        ( 1392): [CP BOOT] boot_6260_mipi: CP FLASHLESS ALL DONE
I'd appreciate any help or suggestions on this. Does anyone know what's wrong with my phone?
 
juliusspencer
Old
#2  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: May 2012
Hi,

Just thought I'd send a message to say "me too". In this case received a phone and managed to break the pins on the SIM slot (someone had put a micro SIM holder in - I should have figured a way of using some pins or something to get it out).

Anyhow, next I rooted the device.

Then I took it to a repair shop and now I get the loop. I suspect they've screwed something up, but I'm just wondering if you made any progress.

Cheers,
Julius.
 
msedek
Old
#3  
msedek's Avatar
Senior Member
Thanks Meter 646
Posts: 2,040
Join Date: Apr 2012
Location: Punto Fijo
Try flashing several other radios until problem fixed

http://forum.xda-developers.com/show...php?p=20568969


Galaxy Nexus AOKP m5 Franco kernel m3
The Following User Says Thank You to msedek For This Useful Post: [ Click to Expand ]
 
juliusspencer
Old
(Last edited by juliusspencer; 20th May 2012 at 10:51 AM.) Reason: Added UPP UC info
#4  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: May 2012
Hi msedek,

Thanks for the post. I have a baseband version ending xxla2. I looked at the link and tried the following two radios listed under xxla2 in the post:

radio-maguro-i9250xxla2.zip
cwm-radio-i9250-xxla2.zip



Code:
$ fastboot flash radio radio-maguro-i9250xxla2.img 
sending 'radio' (12288 KB)...
OKAY [  1.258s]
writing 'radio'...
OKAY [  2.507s]
finished. total time: 3.766s
Code:
$ fastboot flash radio radio.img 
sending 'radio' (12288 KB)...
OKAY [  1.249s]
writing 'radio'...
OKAY [  1.861s]
finished. total time: 3.111s
Unfortunately neither worked. Just wondering if there were other radio images I should try as you mentioned several radios.


I'm still getting the following debug messages repeating in logcat:
Code:
[CP BOOT] __boot_6260: START CP BOOT
[CP BOOT] __boot_6260: CP POWER ON DONE 
[CP BOOT] mipi_xmit_atat: SENT ATAT 0
[CP BOOT] mipi_xmit_atat: SENT ATAT 1
[CP BOOT] __boot_6260: XIMT PSI DONE
[CP BOOT] __boot_6260: XIMT EBL DONE
[CP BOOT] __boot_6260: SET EBL DONE
[CP BOOT] __boot_6260: REQSECSTART CMD DONE
[CP BOOT] __boot_6260: XMIT MODEM_MAIN DONE
[CP BOOT] __boot_6260: XMIT MODEM_NV DONE
[CP BOOT] __boot_6260: READ MPS DATA DONE : BOG
[CP BOOT] __boot_6260: SEND MPS DONE : BOG(0x61080000)
[CP BOOT] __boot_6260: REQSECEND CMD DONE
[CP BOOT] __boot_6260: REQFORCEHWRESET CMD DONE
[CP BOOT] boot_6260_mipi: CP FLASHLESS ALL DONE
Really appreciate any help / pointers.

Oh one other thing - I have been told:
"UPP IC is faulty"

I can't figure out what the UPP IC is. I assume IC is integrated circuit.

Thanks again.
 
thiagodark
Old
#5  
thiagodark's Avatar
Senior Member
Thanks Meter 51
Posts: 568
Join Date: Nov 2010
Location: Old City-ES
Where can i get a log like yours?
>fastboot flash comment xdathread.img
>adb push engrish /system/brain/

samsung galaxy nexus
rom: stock
kernel: stock
 
msedek
Old
(Last edited by msedek; 20th May 2012 at 08:00 PM.)
#6  
msedek's Avatar
Senior Member
Thanks Meter 646
Posts: 2,040
Join Date: Apr 2012
Location: Punto Fijo
Quote:
Originally Posted by juliusspencer View Post
Hi msedek,

Thanks for the post. I have a baseband version ending xxla2. I looked at the link and tried the following two radios listed under xxla2 in the post:

radio-maguro-i9250xxla2.zip
cwm-radio-i9250-xxla2.zip



Code:
$ fastboot flash radio radio-maguro-i9250xxla2.img 
sending 'radio' (12288 KB)...
OKAY [  1.258s]
writing 'radio'...
OKAY [  2.507s]
finished. total time: 3.766s
Code:
$ fastboot flash radio radio.img 
sending 'radio' (12288 KB)...
OKAY [  1.249s]
writing 'radio'...
OKAY [  1.861s]
finished. total time: 3.111s
Unfortunately neither worked. Just wondering if there were other radio images I should try as you mentioned several radios.


I'm still getting the following debug messages repeating in logcat:
Code:
[CP BOOT] __boot_6260: START CP BOOT
[CP BOOT] __boot_6260: CP POWER ON DONE 
[CP BOOT] mipi_xmit_atat: SENT ATAT 0
[CP BOOT] mipi_xmit_atat: SENT ATAT 1
[CP BOOT] __boot_6260: XIMT PSI DONE
[CP BOOT] __boot_6260: XIMT EBL DONE
[CP BOOT] __boot_6260: SET EBL DONE
[CP BOOT] __boot_6260: REQSECSTART CMD DONE
[CP BOOT] __boot_6260: XMIT MODEM_MAIN DONE
[CP BOOT] __boot_6260: XMIT MODEM_NV DONE
[CP BOOT] __boot_6260: READ MPS DATA DONE : BOG
[CP BOOT] __boot_6260: SEND MPS DONE : BOG(0x61080000)
[CP BOOT] __boot_6260: REQSECEND CMD DONE
[CP BOOT] __boot_6260: REQFORCEHWRESET CMD DONE
[CP BOOT] boot_6260_mipi: CP FLASHLESS ALL DONE
Really appreciate any help / pointers.

Oh one other thing - I have been told:
"UPP IC is faulty"

I can't figure out what the UPP IC is. I assume IC is integrated circuit.

Thanks again.
Dude in the link i provided its there like 20/30? Does not matter if it says for europe or usa or the moon, does not matter if its for yakju/takju/moonjuk try em all until 1 works..

In my case only xxkl1 works... Every other not


Try all basebands uglc1, xxkl1, xxkk6 etc etc etc so not get xxla2 since its proved as not working for you

Erm just Wondering which ICS verssion are you on?

Galaxy Nexus AOKP m5 Franco kernel m3
 
juliusspencer
Old
#7  
Junior Member
Thanks Meter 0
Posts: 3
Join Date: May 2012
Code:
number4:radio julius$ fastboot flash radio fastboot-m420-radio-krkl1.img 
sending 'radio' (12290 KB)...
OKAY [  1.298s]
writing 'radio'...
FAILED (remote: Write Fail)
finished. total time: 1.963s
number4:radio julius$ fastboot flash radio fastboot-radio-i9250t-dvkk6.img/
MD5.txt                       radio-maguro-i9250tdvkk6.img  
number4:radio julius$ fastboot flash radio fastboot-radio-i9250t-dvkk6.img/radio-maguro-i9250tdvkk6.img 
sending 'radio' (12288 KB)...
OKAY [  1.296s]
writing 'radio'...
OKAY [  1.955s]
finished. total time: 3.251s
number4:radio julius$ fastboot flash radio fastboot-radio-sc04d-sc04domla1.img/radio-SC04DOMLA1.
radio-SC04DOMLA1.img  radio-SC04DOMLA1.md5  
number4:radio julius$ fastboot flash radio fastboot-radio-sc04d-sc04domla1.img/radio-SC04DOMLA1.img 
sending 'radio' (12288 KB)...
OKAY [  1.298s]
writing 'radio'...
OKAY [  1.888s]
finished. total time: 3.187s
number4:radio julius$ fastboot flash radio radio-kkd.img 
sending 'radio' (12288 KB)...
OKAY [  1.297s]
writing 'radio'...
OKAY [  1.889s]
finished. total time: 3.187s
number4:radio julius$ fastboot flash radio radio-maguro-i9250uglc1.img 
sending 'radio' (12288 KB)...
OKAY [  1.300s]
writing 'radio'...
OKAY [  1.621s]
finished. total time: 2.921s
number4:radio julius$ fastboot flash radio radio-maguro-i9250xxkk1.img 
sending 'radio' (12288 KB)...
OKAY [  1.288s]
writing 'radio'...
OKAY [  1.864s]
finished. total time: 3.152s
number4:radio julius$ fastboot flash radio radio-maguro-i9250xxkk6.img 
sending 'radio' (12288 KB)...
OKAY [  1.299s]
writing 'radio'...
OKAY [  1.679s]
finished. total time: 2.979s
number4:radio julius$ fastboot flash radio radio-maguro-i9250xxkl1.img 
sending 'radio' (12288 KB)...
OKAY [  1.299s]
writing 'radio'...
OKAY [  1.650s]
finished. total time: 2.949s
number4:radio julius$ fastboot flash radio UGKK7_trimmed.img 
sending 'radio' (12288 KB)...
OKAY [  1.289s]
writing 'radio'...
OKAY [  1.902s]
finished. total time: 3.191s
number4:radio julius$ cd ../radio2
number4:radio2 julius$ fastboot flash radio fastboot-radio-sc04d-sc04domla1.img/radio-SC04DOMLA1.img
sending 'radio' (12288 KB)...
OKAY [  1.279s]
writing 'radio'...
OKAY [  1.782s]
finished. total time: 3.061s
number4:radio2 julius$ fastboot flash radio fastboot-radio-i9250t-dvkk6.img/
MD5.txt                       radio-maguro-i9250tdvkk6.img  
number4:radio2 julius$ fastboot flash radio fastboot-radio-i9250t-dvkk6.img/radio-maguro-i9250tdvkk6.img 
sending 'radio' (12288 KB)...
OKAY [  1.268s]
writing 'radio'...
OKAY [  1.671s]
finished. total time: 2.939s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250ugl
radio-maguro-i9250ugla4.img  radio-maguro-i9250uglc1.img  
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250uglc1.img 
sending 'radio' (12288 KB)...
OKAY [  1.287s]
writing 'radio'...
OKAY [  1.681s]
finished. total time: 2.968s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250xxla2.img 
sending 'radio' (12288 KB)...
OKAY [  1.290s]
writing 'radio'...
OKAY [  1.799s]
finished. total time: 3.090s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250ugla4.img 
sending 'radio' (12288 KB)...
OKAY [  1.304s]
writing 'radio'...
OKAY [  1.966s]
finished. total time: 3.270s
number4:radio2 julius$ fastboot flash radio fastboot-m420-radio-krkl1.img 
sending 'radio' (12290 KB)...
OKAY [  1.300s]
writing 'radio'...
FAILED (remote: Write Fail)
finished. total time: 1.968s
number4:radio2 julius$ fastboot flash radio fastboot-m420-radio-krkl1.img 
sending 'radio' (12290 KB)...
OKAY [  1.283s]
writing 'radio'...
FAILED (remote: Write Fail)
finished. total time: 1.952s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250xxkl1.img 
sending 'radio' (12288 KB)...
OKAY [  1.292s]
writing 'radio'...
OKAY [  2.361s]
finished. total time: 3.654s
number4:radio2 julius$ fastboot flash radio fastboot-radio-m420-sk-krkk7.img
sending 'radio' (12288 KB)...
OKAY [  1.301s]
writing 'radio'...
OKAY [  1.664s]
finished. total time: 2.965s
number4:radio2 julius$ fastboot flash radio radio.img 
sending 'radio' (12288 KB)...
OKAY [  1.304s]
writing 'radio'...
OKAY [  1.631s]
finished. total time: 2.935s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250ugkl1.img 
sending 'radio' (12288 KB)...
OKAY [  1.284s]
writing 'radio'...
OKAY [  1.639s]
finished. total time: 2.924s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250xxkk6.img 
sending 'radio' (12288 KB)...
OKAY [  1.299s]
writing 'radio'...
OKAY [  1.690s]
finished. total time: 2.990s
number4:radio2 julius$ fastboot flash radio UGKK7_trimmed.img 
sending 'radio' (12288 KB)...
OKAY [  1.309s]
writing 'radio'...
OKAY [  1.616s]
finished. total time: 2.925s
number4:radio2 julius$ fastboot flash radio radio-maguro-i9250xxkk1.img 
sending 'radio' (12288 KB)...
OKAY [  1.288s]
writing 'radio'...
OKAY [  1.677s]
finished. total time: 2.965s
I tried all of them and had one or two FAIL but otherwise none actually worked.

I'm just running the standard build of Android 4.04 IMM76I. I should have posted that.

Any other ideas?

Thank you again for your help.

(To get the log I'm using logcat with my phone plugged in)
 
thiagodark
Old
(Last edited by thiagodark; 21st May 2012 at 12:05 AM.)
#8  
thiagodark's Avatar
Senior Member
Thanks Meter 51
Posts: 568
Join Date: Nov 2010
Location: Old City-ES
well, my logcat is pretty much like yours and i can't figure out what the hell is going on... my thread is this: http://forum.xda-developers.com/show....php?t=1626593

the difference between my problem and your is that i can use my phone and avoid signal falling by using 2g network only. Have you tried to disable 3g network and see if signal still drops? because i can easily reproduce the problem actving 3g and trying to use the internet... and then, signal die!!

actually you can see the "airplane mode" going on and off (in the power menu) as the logcat pauses and starts again...

oh, and certainly is something wrong, whe my signal is okay, i got none of those outputs in logcat...

edit: i can even show what happens when i uncheck "2g only"

Code:
I/Use2GOnlyCheckBoxPreference(  386): get preferred network type=1
W/InputManagerService(  189): Starting input on non-focused client com.android.i
nternal.view.IInputMethodClient$Stub$Proxy@419aa028 (uid=1000 pid=1176)
I/ActivityManager(  189): Displayed com.android.phone/.Settings: +377ms
D/OpenGLRenderer( 1176): Flushing caches (mode 0)
I/Use2GOnlyCheckBoxPreference(  386): set preferred network type=0
W/BackupManagerService(  189): dataChanged but no participant pkg='com.android.p
roviders.settings' uid=1001
D/GsmUmtsOptions(  386): preferenceTreeClick: return true
D/ConnectivityService(  189): ConnectivityChange for mobile: DISCONNECTED/DISCON
NECTED
D/ConnectivityService(  189): Attempting to switch to wifi
D/ConnectivityService(  189): Attempting to switch to BLUETOOTH_TETHER
E/ConnectivityService(  189): Exception trying to remove a route: java.lang.Ille
galStateException: Unable to communicate with native dameon to add routes - com.
android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet
0 default 187.43.17.1 32 0.0.0.0} failed with code 400 : {Failed to remove route
 from default table (No such process)}
E/ConnectivityService(  189): Exception trying to remove a route: java.lang.Ille
galStateException: Unable to communicate with native dameon to add routes - com.
android.server.NativeDaemonConnectorException: Cmd {interface route remove rmnet
0 default 0.0.0.0 0 187.43.17.1} failed with code 400 : {Failed to remove route
from default table (No such process)}
D/NetUtils(  189): android_net_utils_resetConnections in env=0xaac5f8 clazz=0x5d
800001 iface=rmnet0 mask=0x3
D/ConnectivityService(  189): resetConnections(rmnet0, 3)
W/Smack/Packet(  317): notify conn break (IOEx), close connection
I/qtaguid (  317): Failed write_ctrl(u 76) res=-1 errno=22
I/qtaguid (  317): Untagging socket 76 failed errno=-22
W/NetworkManagementSocketTagger(  317): untagSocket(76) failed with errno -22
D/ConnectivityService(  189): handleInetConditionChange: no active default netwo
rk - ignore
I/Use2GOnlyCheckBoxPreference(  386): set preferred network type done
D/Tethering(  189): MasterInitialState.processMessage what=3
D/dalvikvm(  189): GC_EXPLICIT freed 801K, 13% free 17125K/19591K, paused 4ms+4m
s
I/MediaUploader( 1133): No need to wake up
D/PicasaSyncManager( 1149): active network: null
D/PicasaSyncManager( 1149): background data: true
D/ConnectivityService(  189): ConnectivityChange for mobile: CONNECTED/CONNECTED

D/NetworkPolicy(  189): applying policy NetworkPolicy[NetworkTemplate: matchRule
=MOBILE_ALL, subscriberId=valid]: cycleDay=20, warningBytes=2147483648, limitByt
es=-1, lastSnooze=-1 to ifaces [rmnet0]
I/GTalkService/c(  317): [AndroidEndpoint@1098361552] connect: acct=1000000, sta
te=CONNECTING
I/GTalkService/c(  317): [GTalkConnection@1098676600] connect: acct=1, state=CON
NECTING
D/Tethering(  189): MasterInitialState.processMessage what=3
I/MediaUploader( 1133): No need to wake up
D/PicasaSyncManager( 1149): active network: NetworkInfo: type: mobile[EDGE], sta
te: CONNECTED/CONNECTED, reason: dataAttached, extra: gprs.oi.com.br, roaming: f
alse, failover: false, isAvailable: true
D/PicasaSyncManager( 1149): background data: true
D/dalvikvm(  386): GC_CONCURRENT freed 373K, 4% free 13425K/13895K, paused 5ms+5
ms
D/dalvikvm(  317): GC_CONCURRENT freed 416K, 4% free 13644K/14151K, paused 6ms+4
ms
D/ConnectivityService(  189): handleInetConditionHoldEnd: net=0, condition=100,
published condition=0
D/ConnectivityService(  189): ConnectivityChange for mobile: DISCONNECTED/DISCON
NECTED
D/ConnectivityService(  189): Attempting to switch to wifi
D/ConnectivityService(  189): Attempting to switch to BLUETOOTH_TETHER
D/NetUtils(  189): android_net_utils_resetConnections in env=0xaac5f8 clazz=0x78
f00001 iface=rmnet0 mask=0x3
D/ConnectivityService(  189): resetConnections(rmnet0, 3)
D/dalvikvm(  262): GC_CONCURRENT freed 502K, 5% free 14355K/14983K, paused 5ms+2
ms
D/NetworkLocator(  317): null cell state delivered
W/Smack/Packet(  317): notify conn break (IOEx), close connection
D/NetworkLocator(  317): null cell state delivered
D/NetworkLocator(  317): null cell state delivered
D/        ( 1273): [CP BOOT] __boot_6260: START CP BOOT
D/        ( 1273): [CP BOOT] __boot_6260: CP POWER ON DONE
D/        ( 1273): [CP BOOT] mipi_xmit_atat: SENT ATAT 0
I/qtaguid (  317): Failed write_ctrl(u 76) res=-1 errno=22
I/qtaguid (  317): Untagging socket 76 failed errno=-22
W/NetworkManagementSocketTagger(  317): untagSocket(76) failed with errno -22
D/ConnectivityService(  189): handleInetConditionChange: no active default netwo
rk - ignore
D/        ( 1273): [CP BOOT] mipi_xmit_atat: SENT ATAT 1
D/        ( 1273): [CP BOOT] __boot_6260: XIMT PSI DONE
D/        ( 1273): [CP BOOT] __boot_6260: XIMT EBL DONE
D/        ( 1273): [CP BOOT] __boot_6260: SET EBL DONE
D/        ( 1273): [CP BOOT] __boot_6260: REQSECSTART CMD DONE
D/Tethering(  189): MasterInitialState.processMessage what=3
I/MediaUploader( 1133): No need to wake up
D/PicasaSyncManager( 1149): active network: null
D/PicasaSyncManager( 1149): background data: true
D/dalvikvm(  340): GC_CONCURRENT freed 321K, 4% free 12872K/13319K, paused 9ms+3
ms
D/        ( 1273): [CP BOOT] __boot_6260: XMIT MODEM_MAIN DONE
D/        ( 1273): [CP BOOT] __boot_6260: XMIT MODEM_NV DONE
D/        ( 1273): [CP BOOT] __boot_6260: READ MPS DATA DONE : XEF
D/        ( 1273): [CP BOOT] __boot_6260: SEND MPS DONE : XEF(0x61080000)
D/        ( 1273): [CP BOOT] __boot_6260: REQSECEND CMD DONE
D/        ( 1273): [CP BOOT] __boot_6260: REQFORCEHWRESET CMD DONE
D/        ( 1273): [CP BOOT] boot_6260_mipi: CP FLASHLESS ALL DONE
>fastboot flash comment xdathread.img
>adb push engrish /system/brain/

samsung galaxy nexus
rom: stock
kernel: stock

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes