Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,738,867 Members 41,445 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Nexus Won't Charge - Already Replaced Flex

Tip us?
 
opiuman
Old
(Last edited by opiuman; 13th September 2013 at 06:50 AM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2012
Default [Q] Nexus Won't Charge - Already Replaced Flex

A few days the phone stopped being able to charge while on/off from both wall/USB. Suspected it was due to the flex. Ordered one off of Ebay and when it came it looked identical to the one in the phone. Phone is about 14 months old so no more warranty (got it at IO 2012)

I did the standard instructions of removing the 6 screws with the battery and SIM card. Prying off the back cover, removing the screw for the bottom module along with the ribbon.

Disconnect the antenna, screen ribbon cable and the ribbon cable to the flex from mainboard. Replaced the flex underneath the vibration module and closed it all back up making sure to connect the 2 ribbon cables, the antenna and the cable from the bottom module to the flex but it still won't charge.

I can get it to be recognized in computer as a MTP/PTP device but it still won't charge from computer or wall while on or off. Is there anything else I can do or is this gone forever. Tried a factory reset as well but still won't charge, it was originally just running stock 4.3. Thanks.

EDIT: Battery under Settings says charging at the bottom but not at the top...

http://i.imgur.com/39XYzep.png
 
leyvatron
Old
#2  
leyvatron's Avatar
Senior Member
Thanks Meter 293
Posts: 2,553
Join Date: Dec 2007
Location: Los Angeles
Quote:
Originally Posted by opiuman View Post
A few days the phone stopped being able to charge while on/off from both wall/USB. Suspected it was due to the flex. Ordered one off of Ebay and when it came it looked identical to the one in the phone. Phone is about 14 months old so no more warranty (got it at IO 2012)

I did the standard instructions of removing the 6 screws with the battery and SIM card. Prying off the back cover, removing the screw for the bottom module along with the ribbon.

Disconnect the antenna, screen ribbon cable and the ribbon cable to the flex from mainboard. Replaced the flex underneath the vibration module and closed it all back up making sure to connect the 2 ribbon cables, the antenna and the cable from the bottom module to the flex but it still won't charge.

I can get it to be recognized in computer as a MTP/PTP device but it still won't charge from computer or wall while on or off. Is there anything else I can do or is this gone forever. Tried a factory reset as well but still won't charge, it was originally just running stock 4.3. Thanks.

EDIT: Battery under Settings says charging at the bottom but not at the top...

http://i.imgur.com/39XYzep.png
Get yourself a wall charger and 2 batteries. Rotate them.

For files you can use bluetooth, NFC, drop box, drive, copy , flicker, box, etc...

Edit: never mind. It connects just doesn't charge.
Follow me and my Android videos on YouTube if you want. Remember to click Thanks and Subscribe.
Join my Facebook group - Everybody is welcome

Google+ Add me
 
opiuman
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 9
Join Date: Nov 2012
Quote:
Originally Posted by leyvatron View Post
Get yourself a wall charger and 2 batteries. Rotate them.

For files you can use bluetooth, NFC, drop box, drive, copy , flicker, box, etc...

Edit: never mind. It connects just doesn't charge.
Yea to clarify before I changed the flex, the phone couldnt connect be recognized by computer on USB. Now I have at least that but nothing else.
 
Tux_92
Old
#4  
Junior Member
Thanks Meter 0
Posts: 9
Join Date: Jun 2013
I have the same problem but my nexus is already in warranty, so I try to resolve this problem with samsung!
 
serch826
Old
#5  
Senior Member
Thanks Meter 33
Posts: 280
Join Date: Dec 2009
Thumbs down my problema is backwards

After replaced the USB flat i can charge the phone, but the computer not recognizing
KITKAT 4.4.4 STOCK ROOTED
WITH XPOSED MODS
UNLOCKED
HALEBOP

 
grim281
Old
#6  
Junior Member
Thanks Meter 4
Posts: 28
Join Date: May 2010
I have the exact same problem. Replaced flex cable, still no charge. My pc recognized it with the old and new charge port as well. I had to re-activate my OG Droid until either the new HTC and G5 phones come out...sigh
 
sxm2
Old
#7  
Member
Thanks Meter 7
Posts: 68
Join Date: Jun 2010
long shot, but clean-up gold phone contact points for better conductivity?
 
Ahmetcenk07
Old
#8  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Jan 2011
Location: Brisbane
Default Same Here

I think it happened after flashing 4.4.2 roms, i tried to flash different roms different cables, wall,pc,ps..nothing worked if it is on.When i turn off the gnex it is charging..Anyone?
 
Ahmetcenk07
Old
#9  
Junior Member
Thanks Meter 0
Posts: 5
Join Date: Jan 2011
Location: Brisbane
Default I think i have solved mine

Well it was getting really weird like discharging while it is connected(turned off). So i thought it is not related to rom. So i wiped dalvik cache and now it looks ok
 
machtwerk
Old
#10  
machtwerk's Avatar
Senior Member
Thanks Meter 7
Posts: 147
Join Date: Jun 2010
Any news on this topic? I've got the same problem, swapped the USB flex cable and it still isn't charging. I can connect via ADB though and in the battery details menu it says "charging" at the bottom, although it obviously isn't.

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes