Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,814,238 Members 49,583 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Do any KitKat ROMs support Bluetooth Low Energy?

Tip us?
 
adamwsh
Old
(Last edited by adamwsh; 16th April 2014 at 01:34 PM.)
#1  
Junior Member - OP
Thanks Meter 1
Posts: 24
Join Date: Apr 2009
Question [Q] Do any KitKat ROMs support Bluetooth Low Energy?

I have a stock, unrooted Galaxy Nexus GSM purchased new from Google currently running 4.3.

I have a FitBit Flex which will only sync with phones that have Bluetooth Low Energy support.
I can not find any information on any of the KitKat ROMs out there for Galaxy Nexus to see if I install it, will Bluetooth LE work?

If it does then work, my next concern would be if the FitBit app would recognize that the Bluetooth LE works and it would then be able to sync, or if it simply would still see it as a Galaxy Nexus which they do not list as a supported device: http://www.fitbit.com/devices

If anyone can offer me some advice here, I'd greatly apprecaite it!

Thanks.

(btw, sorry if this is in the wrong froum. please move it if it is)
 
caluz78
Old
#2  
Member
Thanks Meter 18
Posts: 91
Join Date: Oct 2006
Location: Milano
Quote:
Originally Posted by adamwsh View Post
I have a stock, unrooted Galaxy Nexus GSM purchased new from Google currently running 4.3.

I have a FitBit Flex which will only sync with phones that have Bluetooth Low Energy support.
I can not find any information on any of the KitKat ROMs out there for Galaxy Nexus to see if I install it, will Bluetooth LE work?

If it does then work, my next concern would be if the FitBit app would recognize that the Bluetooth LE works and it would then be able to sync, or if it simply would still see it as a Galaxy Nexus which they do not list as a supported device: http://www.fitbit.com/devices

If anyone can offer me some advice here, I'd greatly apprecaite it!

Thanks.

(btw, sorry if this is in the wrong froum. please move it if it is)
See here.
http://forum.xda-developers.com/show....php?t=2492436

With any kitkat rom I install only the modified apk from that thread and everything is ok!
Il you wanna stay with 4.3 you must install btle libraries as mentioned in the thread.
The Following User Says Thank You to caluz78 For This Useful Post: [ Click to Expand ]
 
Shambola
Old
#3  
Shambola's Avatar
Senior Member
Thanks Meter 87
Posts: 159
Join Date: Dec 2013
Location: Somewhere in Spaghettiland
Gnex supports BLE with almost every KK rom.

(try BLE Checker on play store: on my Vanir says Supported!)
The quick brown DirtyV jumps over the lazy Nexus
The quick brown DirtyV jumps over the lazy Nexus
The quick brown DirtyV jumps over the lazy Nexus
 
paarthdesai
Old
#4  
paarthdesai's Avatar
Recognized Contributor
Thanks Meter 1,143
Posts: 3,234
Join Date: Jun 2012
Location: mumbai

 
DONATE TO ME
yes, and wrong place to ask this
my work


bbm pin - 73e00adf
check out my website
my devices - OnePlus One
- retired >samsung galaxy nexus, htc one v, htc explorer, nokiaC6 ,5233,3310,1100


if you're good at something never do it for free
-the joker
The Following 2 Users Say Thank You to paarthdesai For This Useful Post: [ Click to Expand ]
 
adamwsh
Old
#5  
Junior Member - OP
Thanks Meter 1
Posts: 24
Join Date: Apr 2009
Quote:
Originally Posted by caluz78 View Post
See here.
http://forum.xda-developers.com/show....php?t=2492436

With any kitkat rom I install only the modified apk from that thread and everything is ok!
Il you wanna stay with 4.3 you must install btle libraries as mentioned in the thread.

THANK YOU, THANK YOU, THANK YOU!

I used The Nexus Root Toolkit (by WugFresh) to Unolock and Root my GNex. Then I used the link you gave me to get the BTLE files and the FitBit apk. I installed everything and it freakin' works!!! I'm so happy!

I'm so annoyed at Google for letting support of this device go after only 18 months. I bought it because they praised it as being thee flagship, unaltered, always up-to-date phone to have. I figured I'd be on the latest version of Android with this phone for many years. I wanted to keep it stock, but they've forced me to now go rooted. I suppose I could now flash a KK ROM, but I'm not sure what that would benefit me at this point.

Thank you again SO much for your help and fast reply! (Even if I did post this in the wrong place!)

Love XDA!
 
adamwsh
Old
#6  
Junior Member - OP
Thanks Meter 1
Posts: 24
Join Date: Apr 2009
Ok, so I have to update what happened. Everything seemed to be working fine until I got into my car. My GPS has a bluetooth connection. It would connected, but then almost immediately the Bluetooth service would crash on my phone. Happened over and over again. Even after a reboot. Then when I got home, I tried it with my bluetooth speaker. Same exact thing. I figure the bluetooth binaries that I installed screwed up my connections that used to work. I even tried re-pairing them. Didn't help.

I gave up and decided to wipe everything and flash KK. I used CM11 nightly. Now everything, so far, is working as expected. GPS, speaker & fitbit. CM KK takes some getting used to over stock JB. I don't know what changes are KK and which are CM.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


XDA Xposed Tuesday: How to Shut Up Your Phone – XDA Developer TV

So many different applications want to send us notifications that … more

Add Some Power to First Generation Snapdragon CPUs

Some older devices still remain very popular. Phones like theHTC Desire, Sony Ericsson … more

Android M Mentions Spotted in Android Code Review

While we are still waiting for Android L to be officially released, the first mentions of … more

Create a Simple Custom Launcher from Scratch

When you are starting your journey intoany sort of development, it’s never easy at the … more