Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,804,192 Members 37,714 Now Online
XDA Developers Android and Mobile Development Forum

[SOLVED!](Q) Help! Phone showing it's charging when unplugged...

Tip us?
 
masterkamon842
Old
(Last edited by masterkamon842; 23rd May 2012 at 07:11 PM.) Reason: Problem solved.
#1  
masterkamon842's Avatar
Senior Member - OP
Thanks Meter 76
Posts: 463
Join Date: Jul 2011
Location: New York

 
DONATE TO ME
Default [SOLVED!](Q) Help! Phone showing it's charging when unplugged...

Since this morning my phone says it's charging when in fact it's unplugged. I tried cleaning the charging port, wiping cache, full wiping and reinstalling the rom, everything and don't understand why it'll never get off charging state.

I do check in settings while unplugged it says not charging and when plugged in says charging, but it's stuck saying "on battery for 23 min" and the icon never stops from charging....

Any suggestions? It's really annoying... Never had a single problem with my One S...

SOLUTION: Clean the charger port with a hard pointed object (that's what she said), make sure you clean and dirt or particles from underneath the middle piece in the charger port.
Also, if you notice the middle piece is too close or making contact with the bottom, use the pointed object to CAREFULLY bend it up a little.

Do all this while the phone is off and battery out. Use compressed air if available. if you wet it then completely dry it before putting the battery back in.
Current Phones:
-Nexus 5
-Moto G
The Following 5 Users Say Thank You to masterkamon842 For This Useful Post: [ Click to Expand ]
 
zuberio
Old
#2  
zuberio's Avatar
Senior Member
Thanks Meter 202
Posts: 290
Join Date: Sep 2010
Location: Mississauga, ON
did you try wiping the Dalvik cache when you did the regular cache?
Nexus 5
- Stock [Rooted] + TWRP
Nexus 7
- CM10.2
Nexus 4 (Hers)
- Stock
Galaxy Tab 10.1 (GT-P7510) (Hers)
- Stock
Nexus One (Babys)
- CM7.2

Feel free to feed my addiction to THANKS
 
martonikaj
Old
#3  
martonikaj's Avatar
Senior Member
Thanks Meter 1,714
Posts: 7,850
Join Date: Nov 2010
Location: Seattle, WA
Quote:
Originally Posted by masterkamon842 View Post
Any suggestions? It's really annoying... Never had a single problem with my One S...
Soo... do you have a One S with this problem, or a Galaxy Nexus?
Quit signing contracts, stop overpaying for service, GO PREPAID!
Follow me on Twitter / Google+
Don't have Dropbox yet? Sign up from this link, and we both get more storage!
 
masterkamon842
Old
#4  
masterkamon842's Avatar
Senior Member - OP
Thanks Meter 76
Posts: 463
Join Date: Jul 2011
Location: New York

 
DONATE TO ME
Quote:
Originally Posted by zuberio View Post
did you try wiping the Dalvik cache when you did the regular cache?
Yes I did.





Quote:
Originally Posted by martonikaj View Post
Soo... do you have a One S with this problem, or a Galaxy Nexus?
A nexus.

Sent from my Galaxy Nexus using Tapatalk 2
Current Phones:
-Nexus 5
-Moto G
 
zuberio
Old
#5  
zuberio's Avatar
Senior Member
Thanks Meter 202
Posts: 290
Join Date: Sep 2010
Location: Mississauga, ON
Have you tested what happens when you install a different ROM?
Nexus 5
- Stock [Rooted] + TWRP
Nexus 7
- CM10.2
Nexus 4 (Hers)
- Stock
Galaxy Tab 10.1 (GT-P7510) (Hers)
- Stock
Nexus One (Babys)
- CM7.2

Feel free to feed my addiction to THANKS
 
RedBlueGreen
Old
#6  
RedBlueGreen's Avatar
Senior Member
Thanks Meter 162
Posts: 528
Join Date: Feb 2011
Location: London
something like this happened to me about 2weeks ago.
It would say saying/ disconnected none stop.. if i didnt notice it would of burned my screen.
I just turned the phone off and removed the battery
 
Melhouse
Old
#7  
Senior Member
Thanks Meter 30
Posts: 130
Join Date: Dec 2011
Read an weep: http://code.google.com/p/android/issues/detail?id=23789

A LOT of users have reported this problem, yet Samsung claims it is water damage and won't do a warranty repair: http://www.reddit.com/r/GalaxyNexus/..._for_infamous/
 
xternal
Old
#8  
Senior Member
Thanks Meter 4
Posts: 208
Join Date: Jan 2007
There is already a thread on this which has some useful info:
http://forum.xda-developers.com/show...hp?t=1427539It ranges from yep your charging port is f*cked or it just needs a clean and little tweak.

To get mine fixed I gave it blast with compressed air and a little needle to make sure all the lint/gunk was out of the port. I made sure the port was straight (if it looks like it is bent downwards slightly, try and pop it back up softly). Then what fixed it for me is to hit it with a little electrical contact cleaner.
I have a feeling the port was getting shorted by something as each of the pins on the microusb port are very close.

Hope that helps
 
zuberio
Old
(Last edited by zuberio; 21st May 2012 at 05:56 PM.) Reason: Added link to ifixit for teardown guide
#9  
zuberio's Avatar
Senior Member
Thanks Meter 202
Posts: 290
Join Date: Sep 2010
Location: Mississauga, ON
Interesting - I'll have to keep an eye out for something like this on my phone.

I guess first step is the compressed air blast with a needle cleaning of the port. If that doesn't work then on to Samsung to see if they'll honor a warranty repair (outlook not good on this - apparently they claim water damage). Worst case you can get a replacement OEM charging cable off ebay:

http://www.ebay.com/itm/OEM-Charge-P...item33746d1eb8

And fix the faulty part yourself or have someone you trust do it.

[EDIT] here's a link to ifixit for step by step instructions on how to take your phone apart http://www.ifixit.com/Teardown/Samsu...1#.T7pzI8XdOII
Nexus 5
- Stock [Rooted] + TWRP
Nexus 7
- CM10.2
Nexus 4 (Hers)
- Stock
Galaxy Tab 10.1 (GT-P7510) (Hers)
- Stock
Nexus One (Babys)
- CM7.2

Feel free to feed my addiction to THANKS
 
masterkamon842
Old
#10  
masterkamon842's Avatar
Senior Member - OP
Thanks Meter 76
Posts: 463
Join Date: Jul 2011
Location: New York

 
DONATE TO ME
Thanks to all the suggestions, it does the same thing even after wiping, installing other roms or going back to stock. I tried cleaning it with a toothbrush but will try with a toothpick or something stronger. Will give updates once I do.
Current Phones:
-Nexus 5
-Moto G

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes