Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Omap Flash: MMC CONFIG FAILURE

OP chrisj2

22nd March 2014, 02:03 AM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2014
OMAP Flash consistently returns
Code:
Download failed (final data response error): Remote: : Driver init error 0x00FF8080 - MMC CONFIG FAILURE
Has anyone ever encountered this error?
Is it indicating a hardware error or a problem with my setup (windows drivers, omapflash configuration)?
Is the "OMAP4460_TUNA_8G_HS_PRO" configuration correct for a 16gb maguro device?

Can someone confirm if this indicates a hardware error or a configuration problem on my windows machine? Using Windows 7 64bit. The "Omap 4460" device appears in device manager but I am not sure if there should also be a second "TI" device.

Code:
 OMAPFlash v4.15 (Aug 12 2011)

 -v
 Entering parameter file:Targets\Projects\tuna\omap4460_tuna_hs_pro.txt at line: 1
     -omap 4
     -t 36000
     -p OMAP4460_TUNA_8G_HS_PRO
     -2
     chip_download EMMC Targets\Projects\tuna\MLO_4460_HS_PRO
     chip_download EMMC Targets\Projects\tuna\sbl.img
     command cold_sw_reset
 Leaving parameter file:Targets\Projects\tuna\omap4460_tuna_hs_pro.txt
 @Targets\Projects\tuna\omap4460_tuna_hs_pro.txt
 Looking for device (omap usb)
 Please turn on device
 Waiting for device (omap usb)
 Found device (omap usb)
 Requesting ASIC id
 AsicId items 05
 AsicId id        	01 05  01  44 40 07 01 
 AsicId secure_mode	13 02  01  00 
 AsicId public_id 	12 15  01  25 3F 71 BA 1B CB 03 AA A7 69 F1 31 D1 79 94 F3 7F 9C 94 51 
 AsicId root_key_hash	14 21  01  67 98 9B 35 54 CC 86 B4 67 32 47 05 36 74 E2 25 F0 9D A3 5C F4 59 B9 C9 3A 13 E0 B9 58 1E 5A BC 
 AsicId checksum  	15 09  01  22 9E 85 BA DC 58 74 BC 
 Searching 2nd for: OMAP4460_TUNA_8G_HS_PRO 444007 01 HS 
 Loading second file Targets/2nd-Downloaders/dnld_startup_omap4_hs_8g_es2.s2.signed.2nd.hs_pro
 Entering parameter file:omapflash2nd.txt at line: 46
     -pheriphalboot_reopen
 Reading board configuration file Targets\Configurations\configuration_omap4460_tuna_8g.txt
 Reading definition file .\targets\definitions\definitions_omap4.txt
     -board_config Targets\Configurations\configuration_omap4460_tuna_8g.txt
 Leaving parameter file:omapflash2nd.txt
 Sending size of second file (0x000071B0 bytes)
 Transferring second file to target (0x71B0 bytes)
 Closing boot connection
 Found device (omap usb)
 Waiting for 2nd
 Found 2nd
 Looking for a driver for 'EMMC'
 chip_driver EMMC Targets\Flash-Drivers\emmc_drv.bin sid 0 width 4 delay 9 rpapi_base 0x00030400
 Downloading driver
 Downloading 'Targets\Flash-Drivers\emmc_drv.bin'

 Sending data (47160 bytes) :::::::::::::....... [32768]
 Sending data (47160 bytes) :::::::::::::::::::: [47160]
 Sending data (47160 bytes) :::::::::::::::::::: [47160]
	  Interface 'OMAPFLASH DRIVER v6'
	  Driver 'eMMC JESD84-A43'
	  Driver configuration: sid = 0x00000000
	  Driver configuration: width = 0x00000004
	  Driver configuration: delay = 0x00000009
	  Driver configuration: rpapi_base = 0x00030400
	  MMC sid                = 0x00
	  MMC mmc_volt           = 0x01
	  MMC data_width         = 0x04
	  MMC card_rca           = 0x00
	  MMC card_type          = 0x00
	  MMC data_width_support = 0x00
	  MMC transfer_clk_max   = 0x00
	  MMC card_size          = 0x00
	  MMC mmc_config return 0x00FF8080
	  EMMC eMMC DRIVER DEINIT COMPLETE
 Download failed (final data response error): Remote: : Driver init error 0x00FF8080 - MMC CONFIG FAILURE
 Elapsed time: 0:05.921 (7990 bytes/s)
 Operation FAILED (Remote: : Driver init error 0x00FF8080 - MMC CONFIG FAILURE)
 Elapsed time: 0:20.357
What led me to OMAP Flash:
My Galaxy Nexus GSM 16gb suddenly and repeatedly closed any application I started and shortly later entered a reboot loop.
Probably stupidly I then tried to flash a recovery on my still locked device usind Heimdall in Download Mode.
Now my device shows no reaction when connecting a charger or trying to power on.

The OmapFlash I use is from:
http://forum.xda-developers.com/gala...aguro-t2146790
My system is Windows 7 64bit. Device Manager shows the Omap 4460 device.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes