Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Problems with my USB. Please diagnose...

OP jond84

5th August 2014, 11:52 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Aug 2014
I had an account here but can't remember my old email info. Anyways. Problem I am having started last week. I have a rooted galaxy nexus running 4.3 Jellybean vanilla. When I insert the usb cable for charging it does nothing initially. But after say 15min or so it will display charging on the icon. Or if I plug in the usb connector and reboot the phone it would charge immediately. It worked like this for a week until I decided it could be a software problem. I wiped the phone completely with TWRP with plans of installing everything on a clean slate. Problem is I can't get it to appear in windows. "USB device not recognized" and no matter how I install the drivers I can't get the thing to connect to my computer. a few days ago I was able to copy some files onto it but now nothing. So basically I have a phone with only recovery software on it and have no way of flashing a ROM back onto it. I am just wondering if this is a motherboard problem or a problem with the usb connector. Anyone have similar symptoms? Right now this thing is a brick and not in a position to buy a new phone a the moment. I am pretty handy when it comes to fixing things of this sort. I have tried cleaning the port out with a needle. Also have tried bending the connector back out to the center. Phone is a GSM Galaxy Nexus from Canada. Thanks for your help in advance.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes