Post Reply

[Q] Samsung Nexus wi-fi issues, firmware or hardware?

OP genetic_discount51

20th February 2014, 02:13 PM   |  #1  
genetic_discount51's Avatar
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Feb 2014
More
I've been dealing with this issue for just about 2 weeks, and i have no clue what to do...
The Wifi on my phone will not turn on at all. Even after a factory reset (many factor resets). So after looking around I thought rooting the phone and upgrading to Kit-Kat would help. But even after doing that, my phone still would tell me the phrase "turning on WiFi" and would never turn on.

So i flashed back to 4.3 and unrooted my phone to send it to Samsung. Samsung USA claims that they cannot take my phone b/c its a global phone based on the IMEI, but the problem sounded like a hardware issue because a light doesn't flash when i try to turn on the wifi.

LASTLY I went back to the people who sold me the phone, and they claim its a firm ware issue, and that i have to bring the phone back to 4.1 for it to work.

Is this wifi problem firmware or hardware issues? If its hardware, is there a way to make the phone 4.1 without rooting it?
20th February 2014, 04:12 PM   |  #2  
Junior Member
Thanks Meter: 0
 
19 posts
Join Date:Joined: Nov 2012
Quote:
Originally Posted by genetic_discount51

I've been dealing with this issue for just about 2 weeks, and i have no clue what to do...
The Wifi on my phone will not turn on at all. Even after a factory reset (many factor resets). So after looking around I thought rooting the phone and upgrading to Kit-Kat would help. But even after doing that, my phone still would tell me the phrase "turning on WiFi" and would never turn on.

So i flashed back to 4.3 and unrooted my phone to send it to Samsung. Samsung USA claims that they cannot take my phone b/c its a global phone based on the IMEI, but the problem sounded like a hardware issue because a light doesn't flash when i try to turn on the wifi.

LASTLY I went back to the people who sold me the phone, and they claim its a firm ware issue, and that i have to bring the phone back to 4.1 for it to work.

Is this wifi problem firmware or hardware issues? If its hardware, is there a way to make the phone 4.1 without rooting it?

If it's the international version you can get the official factory images from here: https://developers.google.com/android/nexus/images
Don't know if you should use the takju or yakju version, but I've heard they should both work.
The instructions on how to flash are on that page as well

That being said I don't think flashing the old rom will fix it. It's probably a hardware problem.... but, you never know
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes