Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] I cannot send SMS GSM Orange Network

OP MarcusVanSciver

11th January 2012, 05:52 PM   |  #21  
Senior Member
Thanks Meter: 49
 
236 posts
Join Date:Joined: Jan 2011
You may need to make sure you have "SMS over ims" turned _on_ in the hidden phone settings.
The Following User Says Thank You to dabl8 For This Useful Post: [ View ]
11th January 2012, 05:53 PM   |  #22  
rowanparker's Avatar
Senior Member
Flag Yorkshire, UK
Thanks Meter: 5
 
197 posts
Join Date:Joined: Apr 2010
More
Quote:
Originally Posted by dabl8

You may need to make sure you have "SMS over ims" turned _on_ in the hidden phone settings.

What does that do? I thought that was an LTE thing?
11th January 2012, 06:09 PM   |  #23  
Senior Member
Thanks Meter: 49
 
236 posts
Join Date:Joined: Jan 2011
Sorry, that doesn't matter. What does matter is that you press refresh after updating the centre number

edit: more info here http://wiki.cyanogenmod.com/wiki/SMSC_Updates
Last edited by dabl8; 24th April 2012 at 06:31 PM.
The Following User Says Thank You to dabl8 For This Useful Post: [ View ]
23rd January 2012, 06:40 AM   |  #24  
Junior Member
Flag Kajang
Thanks Meter: 2
 
17 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by IanDroidz

I too had the same problem. Out of curiosity, I went to check the Hidden phone settings on my Galaxy Nexus, I love looking at the temperature of the battery, network location and all that good stuff. But apparently ICS is glitchy regarding the SMSC settings. It apparently wipes the SMSC number as soon as you enter the hidden phone settings... To find this I went to a series of steps. The first thing I tried was popping in other SIM cards from my carrier (Telcel GSM in Mexico) All of them seemed to work fine.. And my primary SIM which didn't work on my Galaxy Nexus worked on an old Telcel-Locked phone I had.. so this sent me scrambling.. The next thing I tried was to update the SMSC through the process of encryption provided in an earlier post, and normally.. none of them which worked.. I then thought that the Phone must be keeping an erroneous configuration of my SIM card, so I resetted the phone, deleted my G-Account.. and still it would not work. I then popped another Telcel GSM SIM card in my old Blackberry 8520, went to the SMS settings and it had the SMSC number, which for Telcel Mexico is +5294100001410... I then popped in my primary SIM card which was giving me trouble in my Galaxy Nexus and when I went to the SMS settings in the Blackberry.. the SMSC value was gone.. empty.. So I just typed it in and hit save. Popped the SIM card Back in the Galaxy Nexus.. and It's all good again. Android ICS in the Galaxy Nexus just wipes the SMSC value as soon as you enter the hidden menu and is unable to rewrite it to the SIM card. I had to use the Blackberry to properly configure my SIM card again.. Funny, I thought I would never use the Blackberry for anything away.. I got to use some of the junk I keep around..

this worked for me. thanks alot for the solution. tried half the process you described before coming on here. wouldnt have known the other half of it abt setting the number on another phone if i didnt read your post. thanks.
30th January 2012, 02:27 PM   |  #25  
Junior Member
Flag Bern
Thanks Meter: 3
 
29 posts
Join Date:Joined: Aug 2007
More
Thumbs up Works also for Swisscom
I had the same problems with Swisscom Carrier SMSC.
Now it work thank you.

FOR SWISSCOM:
SMSC +41794999000
=
07911497949900F0
30th January 2012, 04:52 PM   |  #26  
beekay201's Avatar
Senior Member
Thanks Meter: 1,143
 
4,752 posts
Join Date:Joined: Nov 2010
More
Quote:
Originally Posted by rowanparker

What does that do? I thought that was an LTE thing?

IMS: Ip Multimedia Core Network System

it exists as a framework for delivering internet protocol multimedia services, uses IETF protocols, like SIP. it's been around since the need of delivering data through gprs, and has been updated/used until now.
a sms can be sent in two ways: binary (encoded over a IMS network, by a PDU - protocol data unit) and text.
the PDU contains various info, like SMSC adress, timestamp, sender number. if the user terminal doesnt send SMSC number/adress encoded (in hexadecimal) in the PDU, the sms doesnt get through to the PSTN, thus not reaching destination.

maybe the nexus doesnt do these operations well because it's missing STK (Sim Toolkit)?
Last edited by beekay201; 30th January 2012 at 05:04 PM.
29th March 2012, 10:37 AM   |  #27  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: Jan 2009
Quote:
Originally Posted by dabl8

Sorry, that doesn't matter. What does matter is that you press refresh after updating the centre number

thanks, this solved my problem together with the link that marcus posted.

I've been using GO SMS up until now (you can set your SMSC directly in the app there).

Cheers!
21st April 2012, 04:45 PM   |  #28  
Senior Member
Flag Montreal
Thanks Meter: 15
 
115 posts
Join Date:Joined: Aug 2010
More
Rogers (CANADA) Messaging center number
This is for Rogers customers

in the *#*#4636#*#* hidden menu,

scroll down to "SMSC:"
in the box type: 0791715097960300
press the "Update" / "Mettre Jour" (first button)
Now exit and Reboot the phone.
To test it, don't try to resend an old test message as it contain old message center number. I even suggest to delete previous text messages from your inbox if possible.

If it worked, everything should be fine by now. (you can even kudo me for this loll)
23rd April 2012, 02:03 PM   |  #29  
AndIKnow's Avatar
Senior Member
Flag Melbourne
Thanks Meter: 25
 
168 posts
Join Date:Joined: Apr 2012
More
http://forum.xda-developers.com/show...php?p=25204768

Easiest way to restore SMS functionality. No mucking around for a SMSC.
Sent from my Galaxy Nexus using XDA
24th April 2012, 04:03 AM   |  #30  
Junior Member
Flag bogota
Thanks Meter: 0
 
1 posts
Join Date:Joined: Feb 2012
helpme
Ayudenme ya que soy de colombia y mi Samsung Galaxia Nexus no me deja enviar mensajes ya probe lo del DPU y no funciona.

Mi numero de operador es +573003690025 y mi numero de cell es 3012037487, que hago........

Me encuentro en Colombia y mi operador es Tigo.

Thanks..........
Last edited by mariomendez; 24th April 2012 at 04:19 AM. Reason: nothing happend

Post Reply Subscribe to Thread

Tags
error, gsm, orange, sms
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes