Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Signal Lost with Screen Sleep

OP BruceWayne133

7th April 2012, 10:46 AM   |  #81  
Senior Member
Thanks Meter: 18
 
622 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by tacz

Hi guys,

It seems like mine Nexus is not affected by signal drop as I tried to replicate the problem as written above but couldn't(waited for approx. 10 minutes but no signal loss notification at all) also tried to call my phone several times (with 2, 5, 10, 15 minutes intervals) and no problem. I'm on yakju 4.0.4 IMM76D, baseband I9250XXLA2 flashed by fastboot method, on Vietnamese 3G network. Isn't it country specific problem?

Also to add to be more specific: my Nexus is from the "Made in Korea" batch

my phone stock 4.0.4 does not suffer of this problem.
have you understood what phones suffers this problem and why?
7th April 2012, 11:28 AM   |  #82  
Member
Flag King's Lynn
Thanks Meter: 18
 
51 posts
Join Date:Joined: Apr 2007
More
Quote:
Originally Posted by vro25

Easy Fix For Issue

This will require you have superuser.apk installed.

1. Unzip the attached script (radiosaver.sh) to /sdcard on your phone.
2. Download and run "Script Manager" from the Market.
3. From within Script Manager, click on radiosaver.sh file in /sdcard.
4. Click the Su and Boot icons to grant superuser and run at boot (see attached).
5. Click Save, exit the app and reboot your phone.
6. Upon reboot the app will request superuser permissions, click yes.

If everything was done properly then run through the test above and you should still have signal. Don't forget to re-enable data & wife when you're done ;)

The attached script just contains the following command to disable auto voltage as suggested earlier in this thread:

echo 0 > /sys/kernel/debug/smartreflex/sr_core/autocomp

Like I said, for me it didn't matter what radio I was on or what ROM, if I'm running 4.0.4 it would just fail. Also, I also tried a SIM from Wind (different provider) and it also failed.

Hope this helps at least preserve battery life for those who were using the SetCPU fix. Good luck!

I have tried this on my GNexus 4.0.4, and it works great. I can now clock the CPU minimum state back down to 350mhz and still maintain a signal. Once su rights are assigned to the script manager app, "remembered" by the superuser app, then it doesn't require any intervention after set-up, even on a reboot.

It's not the official fix, but at the moment it appears to be the best we have!
7th April 2012, 02:19 PM   |  #83  
Senior Member
Thanks Meter: 25
 
129 posts
Join Date:Joined: Jul 2009
More
Quote:
Originally Posted by tacz

Ok, I'll try to have it being idle for longer time at night as in the day its hard to have it idle longer than 15-20 minutes as always being interrupted by a call, e-mail or message. I'll try to turn of my e-mail sync as well.

If you're going 15 minutes without a drop in signal during sleep than I think you're fine. The main test is that you're still getting phone calls and battery life hasn't gone down since upgrading to 4.0.4.

If you check Settngs->Battery->Cell Stanby an it has a lot of "Time without signal" than you may have the problem - or you could just have poor cell coverage ;)
7th April 2012, 06:11 PM   |  #84  
Senior Member
Flag Hong Kong
Thanks Meter: 29
 
516 posts
Join Date:Joined: May 2009
More
Will there any side effects cause by this method?
thx

Sent from my Galaxy Nexus using xda premium
7th April 2012, 06:36 PM   |  #85  
Member
Flag King's Lynn
Thanks Meter: 18
 
51 posts
Join Date:Joined: Apr 2007
More
The only problem with this (and any other method mentioned here) is that you require root permissions to affect the necessary change. However it appears better than the CPU speed increase as it does not reduce battery life. I am noticing better battery life now I have implemented the scripted fix.

Sent from my Galaxy Nexus using xda premium
7th April 2012, 06:54 PM   |  #86  
rootusr's Avatar
Senior Member
Thanks Meter: 38
 
366 posts
Join Date:Joined: Dec 2010
More
Same here, i have no noticed side effeceffects implementing the script fix. Please keep in mind that this is a temporal fix, lets push Google to release a permanet fix.
7th April 2012, 06:56 PM   |  #87  
Senior Member
Thanks Meter: 18
 
622 posts
Join Date:Joined: Nov 2011
Quote:
Originally Posted by memoreks

The only problem with this (and any other method mentioned here) is that you require root permissions to affect the necessary change. However it appears better than the CPU speed increase as it does not reduce battery life. I am noticing better battery life now I have implemented the scripted fix.

Sent from my Galaxy Nexus using xda premium

Imho the problem is the root itself. Phones without root does not have this problem.
7th April 2012, 07:03 PM   |  #88  
rootusr's Avatar
Senior Member
Thanks Meter: 38
 
366 posts
Join Date:Joined: Dec 2010
More
Quote:
Originally Posted by sblantipodi

Imho the problem is the root itself. Phones without root does not have this problem.

That is in fact a posibility, when i noticed the problem I tried flashing stock image and not root for a few minutes and I did not notice the signal drop then I root it and after a while it happened again, I would need to test again without for a while.

Are you guys not having the problem are root?
7th April 2012, 07:31 PM   |  #89  
Senior Member
Thanks Meter: 25
 
129 posts
Join Date:Joined: Jul 2009
More
Quote:
Originally Posted by sblantipodi

Imho the problem is the root itself. Phones without root does not have this problem.

Not only is that comment utterly untrue, but your opinion is not based on any testing or research.

If you had done any testing you would quickly realize your theory was unsubstantiated.

If you had read thought the official Google support thread you would have seen the problem was reported by unrooted users who were pushed the update by Google.

Root access does not affect the kernel but simply allows greater permissions - you would know this if you understood how the superuser.apk works. Granted, a root user who is running setCPU or some other non-stock kernel modifications could have issues - but this is not the case here.

I have personally re-imaged my device DOZENS of times trying to resolve the issue - using official factory (4.0.1, 4.0.2, 4.0.4) images and radios and upgrading by "official" and forced means.

Making uninformed comments are not just a waste of everyone's time but insulting to those that invest their own time and effort trying to figure out solutions for everyone's benefit.


Sent from my Galaxy Nexus using xda premium
The Following 4 Users Say Thank You to vro25 For This Useful Post: [ View ]
7th April 2012, 09:59 PM   |  #90  
efrant's Avatar
Senior Moderator
Flag Montreal Bow2DaCow
Thanks Meter: 8,191
 
9,595 posts
Join Date:Joined: Feb 2009
Donate to Me
More
@vro25

I tried your little test, and it doesn't seem like I have the issue. I'm running 4.0.4 which I update from 4.0.2 with CWM using the update URL.

Edit: I tried it again with the NoSignalAlert app, and it does not seem to do what yours is doing. However, when I rebooted, but before the screen went off, the app gave me two alerts, one immediately after the other. Loss of signal followed by signal. Not sure if that was just the app starting up for the first time, but that was it. No loss of signal.

Sent from my Galaxy Nexus using Tapatalk
Last edited by efrant; 7th April 2012 at 10:05 PM.

Post Reply Subscribe to Thread

Tags
galaxy nexus, signal, sleep, telus
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes