Should You Get Wear? Wearer’s Practical Observations

Wear is said to not offer enough for mass adoption, even though its been in … more

SlimRoms: Updates on the Horizon

SlimRoms’ website has been experiencing technical difficulties for the last month or so, but … more

Your Favorite Wireless Charger?

Wireless charging is becoming more and more common as many OEMs are now starting to include this feature … more

ASUS US Invites Developers at XDA to Special Event

ASUS has built a solid name over the years for their computer components, but in the … more
Post Reply Subscribe to Thread Email Thread

[Q] Stock 4.2 camera is not working!

1st November 2012, 01:14 PM   |  #1  
OP Member
Thanks Meter: 4
 
36 posts
Join Date:Joined: Aug 2012
Today I read a little guide from youmobile, about installing the new camera in android 4.2. (cant post link since im new)


I did everything except I forgot to backup first. Now everytime i start up the phone, open camera or open gallery it comes "Gallery has crashed".
Anyone knows what I might have done wrong? I used ROM Manager -> Boot into clockwordmod recovery -> flash zip -> and i chose the zip.

The camera is working trough apps like Snapchat, but not trough the stock app.
I could also use the stock 4.1.2 gallery and camera .apk so I atleast can get back my camera.

I am running on 4.1.2 takju nexus, with Air Kernel 3.0.46.

Please help.

- Jakob
1st November 2012, 01:24 PM   |  #2  
Senior Member
Thanks Meter: 28
 
243 posts
Join Date:Joined: Jul 2010
try this zip. it's fixed so that everything should work.

http://www.mediafire.com/?e2yx2146j1qrv89

if you still get crashes, you may want to reflash your Rom (without wiping).
also try fixing permissions, either in clockwork or rom manager
The Following 3 Users Say Thank You to SplicedX For This Useful Post: [ View ]
1st November 2012, 02:18 PM   |  #3  
OP Member
Thanks Meter: 4
 
36 posts
Join Date:Joined: Aug 2012
Quote:
Originally Posted by SplicedX

try this zip. it's fixed so that everything should work.

*url*

if you still get crashes, you may want to reflash your Rom (without wiping).
also try fixing permissions, either in clockwork or rom manager

Thanks. I'm new tho, so what do you mean by fixing permissions. Could you give me step by step?
1st November 2012, 03:05 PM   |  #4  
Herman76's Avatar
Senior Member
Flag Trondheim
Thanks Meter: 257
 
1,368 posts
Join Date:Joined: May 2010
More
Go into recovery(CWM) and select the fix permissions option (might be under advanced)

Swype'ed on my CM10 Galaxy Nexus
The Following User Says Thank You to Herman76 For This Useful Post: [ View ]
1st November 2012, 05:31 PM   |  #5  
stbbrat's Avatar
Member
Thanks Meter: 6
 
95 posts
Join Date:Joined: Jan 2009
Installing the .zip file already fixes permissions. Have you tried renaming the apk to Gallerygoogle2.apk in your preferred file manager?
1st November 2012, 05:36 PM   |  #6  
zyasin's Avatar
Member
Flag Kuwait City
Thanks Meter: 8
 
85 posts
Join Date:Joined: Sep 2012
More
second post, the link works perfectly.
1st November 2012, 07:00 PM   |  #7  
Junior Member
Thanks Meter: 0
 
5 posts
Join Date:Joined: Mar 2011
Thanks!

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes