5,598,011 Members 40,841 Now Online
XDA Developers Android and Mobile Development Forum

Viber unlocks screen when message is received

Tip us?
 
Bresch
Old
(Last edited by Bresch; 20th January 2013 at 07:22 PM.)
#1  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: May 2012
Unhappy Viber unlocks screen when message is received

As the title states every time I get a message through Viber my screen turns on just as if I pressed the power button.
I've tried changing settings and obviously disabled the popup and "unlock for popups" but it still wont stay locked.

Is there something I've missed :s? Is it like that on other peoples Viber? It's damn annoying for me atleast..

Im using a Samsung Galaxy Nexus, maguro. Its been like this on stock 4.0, stock 4.1, a bunch of 4.1 roms and AOKP 4.1.2. Aka its always been like this..

Thank you for your time and please direct me if this is the wrong forums.
ps; ask if you need screen shots or whatnot and I will upload them.

Edit:
If I disable notifications for the app through jellybeans new option to disable notifications from the app info screen the screen STILL lights up and unlocks when I get a message..though no notification or anything.
 
Bresch
Old
#2  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: May 2012
soo no one know anything about it?
 
ljnkshady
Old
#3  
ljnkshady's Avatar
Member
Thanks Meter 74
Posts: 65
Join Date: Aug 2010
Location: Hanoi
Quote:
Originally Posted by Bresch View Post
soo no one know anything about it?
Do u try change on Viber's setting ?
 
khuzema9
Old
#4  
Member
Thanks Meter 4
Posts: 96
Join Date: Nov 2012
ok so you will have to gon in viber setting and uncheck new message popup. when you do this , next option unlock for popups , will be automatically disabled
 
thephantom
Old
#5  
thephantom's Avatar
Senior Member
Thanks Meter 440
Posts: 1,404
Join Date: Jul 2008
Location: Somewhere in between
This is something I've explained to viber in detail already and all they told me was to fix the settings so the unlock for pop up is unchecked. I emailed them back stating that it is unchecked and that this issue occurred ever since they did their last update and that I specifically mentioned my settings are set that way in the original email. All I got was an apology and that they would look into it. It's been months since and still no update from them

Sent from my Galaxy Nexus using Tapatalk 2
LG Nexus 5
Nokia Lumia 1520
Asus Google Nexus 7 4.4.2

Quote:
Originally Posted by @rbiter View Post
teach a man to fish, you feed him for life. teach a man to fastboot, and you create competency. and less threads on xda.
 
Bresch
Old
#6  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: May 2012
Quote:
Originally Posted by ljnkshady View Post
Do u try change on Viber's setting ?
Yes as I explain in the original post I've tried everything.

Quote:
Originally Posted by khuzema9 View Post
ok so you will have to gon in viber setting and uncheck new message popup. when you do this , next option unlock for popups , will be automatically disabled
Yes I've done that but it still unlocks the screen..

Quote:
Originally Posted by thephantom View Post
This is something I've explained to viber in detail already and all they told me was to fix the settings so the unlock for pop up is unchecked. I emailed them back stating that it is unchecked and that this issue occurred ever since they did their last update and that I specifically mentioned my settings are set that way in the original email. All I got was an apology and that they would look into it. It's been months since and still no update from them

Sent from my Galaxy Nexus using Tapatalk 2
I've written to them on twitter but they told me to write them an email but still haven't heard from them..

Also to note: If I disable notifications from the app through the new jellybean app info screen, the screen still unlocks and lits up but no sound or notification..my last desperate attempt would be to disable the permission to unlock screen somehow, is that possible?
 
khuzema9
Old
#7  
Member
Thanks Meter 4
Posts: 96
Join Date: Nov 2012
Quote:
Originally Posted by Bresch View Post
Yes as I explain in the original post I've tried everything.

Yes I've done that but it still unlocks the screen..

I've written to them on twitter but they told me to write them an email but still haven't heard from them..

Also to note: If I disable notifications from the app through the new jellybean app info screen, the screen still unlocks and lits up but no sound or notification..my last desperate attempt would be to disable the permission to unlock screen somehow, is that possible?

dude just try reinstalling it then and are you using any custom rom . though it should not cause such a problem
 
Bresch
Old
#8  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: May 2012
Quote:
Originally Posted by khuzema9 View Post
dude just try reinstalling it then and are you using any custom rom . though it should not cause such a problem
As I stated in the original post, tried multiple times. Even went back to stock ICS just to see if it would help.
 
thephantom
Old
#9  
thephantom's Avatar
Senior Member
Thanks Meter 440
Posts: 1,404
Join Date: Jul 2008
Location: Somewhere in between
I believe it's the latest update they did last October which causes this issue. Gives me the same result in both my gnex and nexus one. Prior to the update it wasn't acting like it. I made a follow up email and the response I got was that it has been forwarded to the 'proper department'

Sent from my Galaxy Nexus using Tapatalk 2
LG Nexus 5
Nokia Lumia 1520
Asus Google Nexus 7 4.4.2

Quote:
Originally Posted by @rbiter View Post
teach a man to fish, you feed him for life. teach a man to fastboot, and you create competency. and less threads on xda.
The Following User Says Thank You to thephantom For This Useful Post: [ Click to Expand ]
 
Bresch
Old
#10  
Junior Member - OP
Thanks Meter 0
Posts: 14
Join Date: May 2012
Quote:
Originally Posted by thephantom View Post
I believe it's the latest update they did last October which causes this issue. Gives me the same result in both my gnex and nexus one. Prior to the update it wasn't acting like it. I made a follow up email and the response I got was that it has been forwarded to the 'proper department'

Sent from my Galaxy Nexus using Tapatalk 2
I had the problem before that and during some version it stopped and came back in October sometime sounds about right. It's a shame really.. But it's a free app that originated from iOS so shouldn't expect too much I guess..

Is there any way to strip the app of the permission?

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes