Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] WLAN_RX_WAKE wakelock preventing GNex from entering deep sleep

OP shadvich

2nd October 2012, 04:20 AM   |  #1  
OP Senior Member
Thanks Meter: 13
 
131 posts
Join Date:Joined: Nov 2010
Really odd problem here - as of a couple days ago, everything was working perfectly with my galaxy nexus. I decided to jump over to CM10 (was on codename android, IIRC), right after I think there were some new commits to AOSP.

From here on out, my phone would never enter deep sleep when connected to wifi. Any wifi hotspot - the ones I've been using, a hotspot I created from my desktop - the icon would show the phone constant receiving data via wifi. Using better battery stats, over about 5 hours on my desk, 4.5hrs were spent with a WLAN_RX_WAKE kernel wakelock with my phone sitting at 350MHz instead of deep sleep for that time.

I tried a bunch of different kernels (stock CM10, franco, imoseyon, etc) both new and old versions, but the problem was still there. I tried clean flashing a rom, and only installing better battery stats. Same thing with all kernels.

Factory restored google stock images to BOTH ICS and JB. I still have the problem. Tried disabling google location services. No dice. Tried a couple basebands, but I'm pretty sure that only affects cell/data performance, right?

I honestly have no idea what is going on. I've been on this hotspot (campus wifi) for months now without a problem, and now this. Some threads say that this is caused by DHCP requests from the router, but why would I have not seen this until now? My idle drain was at about 1-2% per hour before this, now it is close to 10-15%.
Last edited by shadvich; 2nd October 2012 at 04:22 AM.
2nd October 2012, 05:04 AM   |  #2  
Senior Member
Thanks Meter: 390
 
773 posts
Join Date:Joined: May 2011
More
Quote:
Originally Posted by shadvich

Really odd problem here - as of a couple days ago, everything was working perfectly with my galaxy nexus. I decided to jump over to CM10 (was on codename android, IIRC), right after I think there were some new commits to AOSP.

From here on out, my phone would never enter deep sleep when connected to wifi. Any wifi hotspot - the ones I've been using, a hotspot I created from my desktop - the icon would show the phone constant receiving data via wifi. Using better battery stats, over about 5 hours on my desk, 4.5hrs were spent with a WLAN_RX_WAKE kernel wakelock with my phone sitting at 350MHz instead of deep sleep for that time.

I tried a bunch of different kernels (stock CM10, franco, imoseyon, etc) both new and old versions, but the problem was still there. I tried clean flashing a rom, and only installing better battery stats. Same thing with all kernels.

Factory restored google stock images to BOTH ICS and JB. I still have the problem. Tried disabling google location services. No dice. Tried a couple basebands, but I'm pretty sure that only affects cell/data performance, right?

I honestly have no idea what is going on. I've been on this hotspot (campus wifi) for months now without a problem, and now this. Some threads say that this is caused by DHCP requests from the router, but why would I have not seen this until now? My idle drain was at about 1-2% per hour before this, now it is close to 10-15%.

This is literally the EXACT SAME problem I'm having...I wish someone could properly explain why this is happening and how to fix it.

Sent from my Galaxy Nexus using xda app-developers app
The Following User Says Thank You to TheMan0790 For This Useful Post: [ View ]
2nd October 2012, 07:05 AM   |  #3  
Guiding.God's Avatar
Senior Member
Thanks Meter: 76
 
218 posts
Join Date:Joined: Apr 2012
More
Not sure if you've tried this and it helps but maybe you can try Network Log or Shark from the store to diagnose this?
The Following User Says Thank You to Guiding.God For This Useful Post: [ View ]
2nd October 2012, 07:33 AM   |  #4  
OP Senior Member
Thanks Meter: 13
 
131 posts
Join Date:Joined: Nov 2010
Network Log doesn't show up with anything, so the wakelock shouldn't be caused by a rogue app.

Shark, on the other hand, after about 10 seconds of logging, netted me about 300 DHCPv6 'solicit XID' requests. There a bunch of different sources from these requests, they just seem to be other devices on the network pinging my phone to see if it's a DHCPv6 server...?

I've seen some suggestions on other forums to mess around with the router settings, which I can't do because it's campus internet.
2nd October 2012, 09:51 AM   |  #5  
Guiding.God's Avatar
Senior Member
Thanks Meter: 76
 
218 posts
Join Date:Joined: Apr 2012
More
Since you've tinkered with rom/kernels etc on phone without any seeming change, it's feasible that there's been some change recently on the other side of the equation namely the network settings of your campus wifi? Maybe your University's tech department has implemented something new etc? Have you tried asking others with wifi enabled phones if they are experiencing this as well?

Found this here (pretty sure you've come across this if you've been googling abt this issue but posting anyways)

"Another more elaborate solution if you rely on that network a lot, is to purchase a wireless bridge or gaming adapter and connect it to your apartment wifi and then connect your own wifi router to that. Then the gaming adapter would get the dhcp IP from your apartment (so who cares if it is renewing it constantly) and your router would treat the connection just as if you were connected directly to an internet connection. Then configure your router for static IP addresses or if your router does not cause issues with DHCP then you don't need static IPs."

from http://rootzwiki.com/topic/16134-ker...-wlan-rx-wake/

I know I had an issue with some wlan rx wakelock thing last year but I cannot for the life of me remember how I got rid of it or what changed
3rd October 2012, 03:29 AM   |  #6  
OP Senior Member
Thanks Meter: 13
 
131 posts
Join Date:Joined: Nov 2010
Hmm, seems like an okay solution but my friend's devices don't seem to show the same symptom, and since I roam campus alot, a wifi extender wouldn't be ideal.
4th October 2012, 08:08 PM   |  #7  
OP Senior Member
Thanks Meter: 13
 
131 posts
Join Date:Joined: Nov 2010
Bump. Any other ideas?

Sent from my Galaxy Nexus using xda app-developers app
15th December 2012, 05:00 PM   |  #8  
Senior Member
Gothenburg
Thanks Meter: 27
 
144 posts
Join Date:Joined: May 2011
More
I am seriously ripping my hair out from this goddamn wakelock ****.

I wake up at 9am and have to charge my phone by 4pm because it's at 16% with 40 minutes of screen on time. Seriously? This is a JOKE.

I've checked with BetterBatteryStats and CPU Spy. Both confirm the phone keeps sitting at 350MHz when it's supposed to be sleeping, as well as wlan_rx_wake keeping the phone awake.

I've set my phone to receive a static IP from my router (DIR-655) but it doesn't help. I really don't know WHAT to do. I've downloaded shark to my phone, sniffed packets, but haven't been able to get anything useful out of it since there is a LOT to sift through (unless you know what you're looking for - which I don't).

This is by far the worst bug/issue I have ever encountered with my phone and it is seriously getting on my nerves. I will be forever greatful to anyone who can help me pinpoint the issue and make it stop.

Also, i REFUSE to "go buy a new router" as it's bull****. This is a bug people experience only sometimes it seems and NO ONE has a fix for it. I read somewhere about a fix being implemented in some kernels but they were for other phones, never found anything like it for the GNex. If anyone knows anything about a fix like that, please show me the way.

I already checked for rogue apps, there were none keeping wifi awake. I've even tried with a totally stock, newly flashed phone with stock kernel and everything. NO extra apps installed except shark, CPU spy and betterbatterystats sideloaded. I didn't even input my GMail to stop the syncing. It STILL KEPT MY GODDAMN PHONE AWAKE.

I am SERIOUSLY desperate. Considering just selling my phone and opting for something else if this continues, it totally cripples everything.

/rant over
15th December 2012, 05:33 PM   |  #9  
simms22's Avatar
Recognized Contributor
BROOKLYN!
Thanks Meter: 22,516
 
26,839 posts
Join Date:Joined: Jun 2009
turn on WiFi, Bluetooth, and GPS, for about 30seconds, then turn them off. put your phone to sleep, then check if you're going into deep sleep. CPU spy is a good app to check if your hitting deep sleep.
15th December 2012, 05:36 PM   |  #10  
beekay201's Avatar
Senior Member
Thanks Meter: 1,132
 
4,677 posts
Join Date:Joined: Nov 2010
More
Change wireless network encryption? Wpa2, tkip+aes, aes only, tkip only? Wpa?
Change wifi channel?

Edit: scratch that. Try disabling 5ghz band.

Sent from my i9250

The Following User Says Thank You to beekay201 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes