Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,811,541 Members 54,251 Now Online
XDA Developers Android and Mobile Development Forum

[Q] something very wrong with /data

Tip us?
 
bc1313
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 1
Join Date: Apr 2014
Default [Q] something very wrong with /data

I have a Galaxy Nexus with latest Cyanogenmod installer firmware. I woke up a few days ago and the phone had overnight got itself into a crash, reboot cycle. It starts up, gets to the homescreen and then crashes, usually 30-60 seconds after the homescreen has loaded. I have tried many things to reset/format the device to start again and none have worked. Here is the list of things I've tried:

In CWM Recovery:
Wipe data/factory reset - Reports successful but when reboot I am greeted by my old wallpaper and apps followed by the crash within 1 minute.
Restore from backup - crashes during restore
Advance Restore - all partitions restore successfully except /data, phone crashes during recovery of /data

CM Installer:
I tried using CM Installer by connecting to my laptop in Recovery mode and running the Windows CM Installer software. This looked promising, the install process appeared to be working with both the phone screen and laptop showing that the install was proceeding. The CM installer on the laptop reported that CM had successfully been installed however on re-booting the phone I was greeted again with my own wallpaper and apps followed by the inevitable crash.

Wugfresh:
I used Wugfresh to try to flash the stock ROM. I did this from Bootloader using the Flash stock/unroot with bricked phone option and even went into advanced options to enable force flash mode and I have not checked the option to keep userdata. This also appeared to work according to Wugfresh however when I re-booted nothing had changed and all my userdata remains with the crash following shortly after boot.

I have also tried flashboot and ADB commands to erase and/or format /data, all report success but when rebooting clearly haven't worked.

I've come to the conclusion that something is wrong with /data. The crash is being caused when the phone tries to access something in that partition. It seems that when flashing a new ROM by any method, the installer successfully writes all other partitions and that while it thinks that /data has been re-written, it actually doesn't.

Further info from Wugfresh log regarding "userdata" when flashing:
erasing 'userdata'...
OKAY [0.035s]
formatting 'userdata' partition
Creating filesystem with parameters:
Size: 14539534336 (etc etc)
Creating filessytem with 11/887696 inodes and 97200/3549691 blocks
sending 'userdata' (137559 KB)...
writing 'userdata' ...
OKAY [259.512s]
I have tried many ways to erase or format /data or userdata and somehow it still remains. Can anyone please help?
 
jackdeepie
Old
#2  
Junior Member
Thanks Meter 0
Posts: 10
Join Date: Apr 2014
I guess that you'd better get a repair shop to help take a look.
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes