Post Reply

[UPDATE] CWM/TWRP Flashable Update FC12->FD02, minus radios.

OP jwischka

4th May 2012, 03:13 PM   |  #1  
OP Senior Member
Thanks Meter: 94
 
157 posts
Join Date:Joined: Jun 2010
What this is:

This is a flashable zip file which will do all of the non-radio (and non-bootloader, and non-recovery) related changes to your system files that were performed by the OTA update. If you are still semi-stock and flashed the radio images, like I did, you're still stuck on FC12, and your phone is telling you that it needs to update. Annoying. This will fix that.

When you run this, you will hopefully end up with something that looks like this:



What this is not:

This will not update your radios. If you want it to update your radios, this is not the place for you. If you have used fastboot to update your radios, this is for you.

Typical disclaimers that my attorney sister would want me to put in:

This worked for me. If it does not work for you, tough crackers. You should take a nandroid of your phone before you apply this in case it doesn't work. I tested it in TWRP 2.1.2. If it doesn't work for you in CWM, again, tough crackers. I am not responsible if this breaks your phone. I'm also not really responsible if this doesn't break your phone. This zip file is provided with no warranty, expressed or implied. I'll try to help where I can, but when the rubber meets the road, you're on your own if this goes pear-shaped.

Installation:

Download this file. Flash with your preferred recovery. Enjoy.

Something didn't work:

1) Make sure you are on the latest version of CWM/TWRP. If you installed on Day 1, it is possible that you are running a toro CWM, and not a toroplus. Seeing as how this is the first thing the installer checks, it will not work if you have the VZW version installed. Rinse, repeat.

2) This will only work if you are on a stock rom. It's not for CM9, or any custom roms. Because it is implemented as a patch, if any of the files the update is trying to patch are different, the whole thing fails. This is expected behavior.

3) Send me a message.

Crap! My phone doesn't work!

I told you to make a nandroid. You should restore, then send me a message about what you did.
Last edited by jwischka; 4th May 2012 at 11:19 PM.
The Following 3 Users Say Thank You to jwischka For This Useful Post: [ View ]
4th May 2012, 04:13 PM   |  #2  
ifly4vamerica's Avatar
Senior Member
Thanks Meter: 311
 
1,267 posts
Join Date:Joined: Jun 2010
More
Thanks for this zip, while its downloading, im on 3g right now,just thought id ask what rom you were running when you flashed? Or better yet were you odex or deodex?

GN Sent
4th May 2012, 04:14 PM   |  #3  
OP Senior Member
Thanks Meter: 94
 
157 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by ifly4vamerica

Thanks for this zip, while its downloading, im on 3g right now,just thought id ask what rom you were running when you flashed? Or better yet were you odex or deodex?

GN Sent

Stock, unlocked bootloader, rooted, and Franco Kernel. Other than that, no changes.
4th May 2012, 04:52 PM   |  #4  
Senior Member
Thanks Meter: 14
 
150 posts
Join Date:Joined: Mar 2011
Thanks for this. Unfortunately, I'm getting the "error 7" that some people ran into in one of the other threads I was following. I followed the instructions from this thread to first install the FC12 radios, then the FD02 (using fastboot). When I try to apply your update through CWM, I get the error 7. I'm fully stock other than the radio upgrade, unlocked bootloader, and rooted (at least I think I'm still rooted).
4th May 2012, 04:53 PM   |  #5  
OP Senior Member
Thanks Meter: 94
 
157 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by anonim1

Thanks for this. Unfortunately, I'm getting the "error 7" that some people ran into in one of the other threads I was following. I followed the instructions from this thread to first install the FC12 radios, then the FD02 (using fastboot). When I try to apply your update through CWM, I get the error 7. I'm fully stock other than the radio upgrade, unlocked bootloader, and rooted (at least I think I'm still rooted).

Which assert is failing?

Can you post it here?

Thanks
4th May 2012, 04:57 PM   |  #6  
Senior Member
Thanks Meter: 14
 
150 posts
Join Date:Joined: Mar 2011
It looks like the device is failing either the product.device or build.product checks:
Code:
assert failed: getprop("ro.product.device") == "toroplus" || getprop("ro.build.product") == "toroplus"
E:Error in /sdcard/update_mysidspr_FC12_to_FD02_no_radio.zip
(Status 7)
4th May 2012, 05:00 PM   |  #7  
OP Senior Member
Thanks Meter: 94
 
157 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by anonim1

It looks like the device is failing either the product.device or build.product checks:

Code:
assert failed: getprop("ro.product.device") == "toroplus" || getprop("ro.build.product") == "toroplus"
E:Error in /sdcard/update_mysidspr_FC12_to_FD02_no_radio.zip
(Status 7)

Interesting. So you don't have a Galaxy Nexus (or at least, CWM doesn't think you do). I suspect that the CWM version just says "toro", or something similar, being ported straight away from the VZW Nexus.

I can rip that line out and make it probably work, but frankly I wouldn't be the first one flashing it on my phone. If you're up for it, I can put a new zip up and see if it works.
4th May 2012, 05:03 PM   |  #8  
Senior Member
Thanks Meter: 14
 
150 posts
Join Date:Joined: Mar 2011
How about a simple zip that just displays the values of those two properties first? Sorry, I've done development before but don't know the first thing to creating a zip to deploy on Android

Thanks for your help.
4th May 2012, 05:07 PM   |  #9  
OP Senior Member
Thanks Meter: 94
 
157 posts
Join Date:Joined: Jun 2010
Quote:
Originally Posted by anonim1

How about a simple zip that just displays the values of those two properties first? Sorry, I've done development before but don't know the first thing to creating a zip to deploy on Android

Thanks for your help.

Actually I've replaced it with a zip that will allow it to be run on a toroplus or toro.

If you don't mind giving that a whirl? If my suspicion is correct, it will work straight away. If that doesn't work, I can do the other, I think.

Assuming you are on a Stock Sprint Galaxy Nexus, this shouldn't break anything, and that's the first assert in the file - so you're going to have to pass a few hundred others to make sure it doesn't break stuff.

(download link is updated).
4th May 2012, 05:08 PM   |  #10  
Paleryder's Avatar
Senior Member
Flag Chicago
Thanks Meter: 125
 
886 posts
Join Date:Joined: Apr 2011
Donate to Me
More
I wonder what type of bootloader updates were involved?

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes


Top Threads in Sprint Galaxy Nexus Android Development by ThreadRank