Default [Q] Change character encoding for ftp in My Files

The character encoding for ftp connections in the My Files app is always set to UTF-8. In the ftp setup box there is an arrow indicating a drop down list of additional encoding options, but it is always greyed out so that the encoding cannot be changed. With UTF-8 file names and folders with special characters like German umlauts in their name are not displayed properly and I cannot access them. I am not sure why UTF-8 does not work, though, because I thought umlauts are included in UTF-8. Does anyone know how to resolve this?