Sony SmartEyeglass SDK Developer Preview Released

A little over a month ago in Tokyo, Japan, Sony unveiled its new SmartEyeglasstechnology. … more

XDA and Leaseweb: Server Trial/Moto 360 Contest (Winners!)

About a month ago, we held a contest along with XDA’s host, Leaseweb, to … more

Updated Android Lollipop Preview Images – XDA TV

The Android Lollipop Preview Images are now available! That and much more news is … more

Get a Complete Set of Logs with Andy Log

The importance of proper logging is undeniable. No, we’re not talking about lumberjack work. … more
Post Reply

p600 wifi turning off on of on off on....

OP nirurin

11th July 2014, 01:48 PM   |  #1  
OP Senior Member
Flag Bristol
Thanks Meter: 30
 
263 posts
Join Date:Joined: Nov 2012
More
Ok this started last night, tablet has been working flawlessly for the last 6 months or more.
What happened was, I wasn't able to use the Internet. Just wasn't working. And every 20 seconds or so it would flash up at the bottom of the screen "connected to (my router)".
So I turned wifi off and on, which usually fixed connection issues, but didn't help. I also restarted router, even though my computer and my phone isn't having any issues.

So then I went to the wifi settings screen to see if there was any way to reset networks. What I saw was this:

If i turn wifi toggle on and watch the screen, it would scan for networks, find the list... Couple seconds pass... Then the toggle would switch itself off and back on! And then it would start looking and finding networks again, and then off and on, and etc etc.

I have tried a factory reset and cache reset.

I have also downloaded the 4.4.2 stock rom and installed using odin for a totally new install.

Still does it.

Any suggestions? Seems very strange. It's under warranty but it seems like an odd hardware fault, seems more like software but I dunno.

Help me xda, you're my only hope.
11th July 2014, 07:51 PM   |  #2  
OP Senior Member
Flag Bristol
Thanks Meter: 30
 
263 posts
Join Date:Joined: Nov 2012
More
I've been searching the Internet all day trying to find someone else havin this problem... But I seem to be the only one. And noone seems to have any suggestions.

At the moment I'm having to consider a warranty dispute, but that means however many days/weeks without the tablet which I use on a daily basis.

Not ideal Samsung.
11th July 2014, 09:49 PM   |  #3  
Member
Thanks Meter: 2
 
31 posts
Join Date:Joined: Sep 2009
Quote:
Originally Posted by nirurin

I've been searching the Internet all day trying to find someone else havin this problem... But I seem to be the only one. And noone seems to have any suggestions.

At the moment I'm having to consider a warranty dispute, but that means however many days/weeks without the tablet which I use on a daily basis.

Not ideal Samsung.

Hey. I had the EXACT same problem. Even made a video of it and showed it to the service point personell. Turning on off on again and again, it also displays in the settings the switch just switches itself without any action of mine. It was a hardware defect. send it in and get a new one, better than being annoyed by it. Mine did it on a 5-10sec interval length...
11th July 2014, 10:41 PM   |  #4  
OP Senior Member
Flag Bristol
Thanks Meter: 30
 
263 posts
Join Date:Joined: Nov 2012
More
Quote:
Originally Posted by Keks1234

Hey. I had the EXACT same problem. Even made a video of it and showed it to the service point personell. Turning on off on again and again, it also displays in the settings the switch just switches itself without any action of mine. It was a hardware defect. send it in and get a new one, better than being annoyed by it. Mine did it on a 5-10sec interval length...


Yeh mines probably every 5-10 seconds...
So this is definitly a hardware fault? In which case I'll have to get in touch with john lewis and hope they will do an exchange in store. If it involves having to send it off to samsung and waiting for it..

Anyway thanks for replying to the question, shame it wasn't better news haha!
12th July 2014, 06:00 AM   |  #5  
Member
Thanks Meter: 2
 
31 posts
Join Date:Joined: Sep 2009
Quote:
Originally Posted by nirurin

Yeh mines probably every 5-10 seconds...
So this is definitly a hardware fault? In which case I'll have to get in touch with john lewis and hope they will do an exchange in store. If it involves having to send it off to samsung and waiting for it..

Anyway thanks for replying to the question, shame it wasn't better news haha!

yeah sorry to be the one to tell you this is a faulty device but it seems like this unit ain't free of errors and there quality control is somewhat sketchy.
Which android version are you running? I am asking because I run kitkat and also have relatively ****ty battery life. I use it for university so I have the screen on and write notes during lectures. Usually it lasted 7-8hours but for about a week or two it now only lasts 4-5 hours of screen time which is really ****ty.

I read somewhere that this might be a motherboard issue and if it is it might be somewhat corellated to our wifi problem. In my case they replaced the wifi module and gave me back my "old" device but this is having bad battery life so I am thinking about sending it in (again). I did however root so I would have to make use of the warranty provided by the seller, not samsung itself, since my knox is tripped.
(in Germany the sellers also must provide 6months - 2 years of warranty and there was a judgement in Europe that rooting must not have any influence on wether your device still is under warranty or not. sadly this only applies to the warranty provided by the seller, not the manufacturer)
12th July 2014, 07:36 AM   |  #6  
Senior Member
Thanks Meter: 66
 
186 posts
Join Date:Joined: Feb 2012
Is your BT on and are you connected to a 2.4 GHZ network?

If so, turn off BT

I get random WiFi disconnects and reconnects from 2.4 GHZ networks when BT is on but not connected. Though, Ive never noticed the wifi switch going off and on.
Last edited by sam2c; 12th July 2014 at 07:39 AM.
12th July 2014, 12:54 PM   |  #7  
OP Senior Member
Flag Bristol
Thanks Meter: 30
 
263 posts
Join Date:Joined: Nov 2012
More
I am running 4.4.2 or whatever, kitkat anyway.

Bluetooth is off, I never use it on my tablet. I dunno what network type I'm running, might be N or might be B/G, but whatever it is it what it has been for months as I havent changed any router settings lately.

I have restarted the router twice already in case this was a network problem, but the network wouldn't cause the wifi to toggle off and on, it would just cause disconnects etc. Least I assume so. I may try this just in case but like I said the network type hasn't changed lately
12th July 2014, 04:49 PM   |  #8  
OP Senior Member
Flag Bristol
Thanks Meter: 30
 
263 posts
Join Date:Joined: Nov 2012
More
John Lewis are saying they won't exchange it, it will have to be sent off to Samsung for "repair". Meaning I'll probably get sent back a refurbished second hand one with a dodgy light bleed screen, as I expect they have hundreds of those lying around now.

Oh and it'll be up to 28 days. For a premium and expensive device that's less than 6 months old this just isn't good enough.
16th July 2014, 04:52 PM   |  #9  
Member
Thanks Meter: 2
 
31 posts
Join Date:Joined: Sep 2009
Quote:
Originally Posted by nirurin

John Lewis are saying they won't exchange it, it will have to be sent off to Samsung for "repair". Meaning I'll probably get sent back a refurbished second hand one with a dodgy light bleed screen, as I expect they have hundreds of those lying around now.

Oh and it'll be up to 28 days. For a premium and expensive device that's less than 6 months old this just isn't good enough.

I had mine replaced as well but dont remember wether I got a new one or just my old one repaired... should have written down the IMEI I guess :-/

you're from Bristol, don't the EU rights apply there? If so your retailer should be obliged to replace or repair the device.

http://forum.xda-developers.com/show....php?t=1998801

Anyways my replacement was done through Samsung and it took 6 days. But then again idk differences between UK and Germany...

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes