FORUMS
Remove All Ads from XDA

P605 Charging/USB Problems

216 posts
Thanks Meter: 31
 
By andythilo, Senior Member on 19th December 2014, 10:18 PM
Post Reply Email Thread
Hi

Just recently my P605 has developed 2 rather serious problems. The first is that my PC no longer recognizes the tablet, when I plug it in, nothing happens at all, no USB device is detected, nothing comes up on the tablet to say USB connected, it just starts charging. The second problem is it keeps stopping charging. Just this morning it was stuck at 22%, it would charge up to that, then the battery icon would not show it charging anymore.

Through continued switching on and off, it's charging up, but seems very irregular. I've left it switched off on charge now to see what happens. I've ordered a replacement USB port for the tablet wondering if somehow I've damaged it. I've also cleaned the socket out to make sure no fluff was stuck in there causing connection problems.

I've tried the tablet plugged into different PCs/Laptops with different cables, still no USB connection . I've also tried a new ROM, reflashed a few times (which was a PITA) as I had to download via dropbox as I couldn't find my SD card adaptor lol.

Any ideas?

Cheers

Andy
 
 
22nd December 2014, 10:29 PM |#2  
OP Senior Member
Thanks Meter: 31
 
More
Well I'm stumped. Must be a hardware issue .

I've swapped out the USB connector/ribbon cable and still no USB connection to my PC. Plug it in and nothing at all, either on the tablet or PC. Got it charging back up to 100% and everything else is fine.

Guess I'll have to live with it as it's not under warranty as it was bought from Hong Kong and is also pretty well hacked/rooted etc..

Any other ideas?
23rd December 2014, 08:30 AM |#3  
xytherion's Avatar
Member
Flag Iloilo City
Thanks Meter: 2
 
More
i hope someone answers this. i also have the same kind of problem.

really though, i think we'll be better off with better supported tablets in the future
5th January 2015, 08:48 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Similar Issue
Quote:
Originally Posted by andythilo

Hi

Just recently my P605 has developed 2 rather serious problems. The first is that my PC no longer recognizes the tablet, when I plug it in, nothing happens at all, no USB device is detected, nothing comes up on the tablet to say USB connected, it just starts charging. The second problem is it keeps stopping charging. Just this morning it was stuck at 22%, it would charge up to that, then the battery icon would not show it charging anymore.

Through continued switching on and off, it's charging up, but seems very irregular. I've left it switched off on charge now to see what happens. I've ordered a replacement USB port for the tablet wondering if somehow I've damaged it. I've also cleaned the socket out to make sure no fluff was stuck in there causing connection problems.

I've tried the tablet plugged into different PCs/Laptops with different cables, still no USB connection . I've also tried a new ROM, reflashed a few times (which was a PITA) as I had to download via dropbox as I couldn't find my SD card adaptor lol.

Any ideas?

Cheers

Andy


Hi I bought the 10.1 2014 Edition back in June. Around November it suddenly started to stop charging. Tried different cables, chargers, charging through PC (very slow) and charging through socket. Took me a couple of weeks to see a pattern. Seems that while charging, if it goes to sleep or locks itself, it stops charging. So I set it to turn the screen off after 30minutes and then it charges. I have it beside me and just touch the screen before the 30mins are up. Not ideal, but allows me to charge it.

I have been searching online and can't see anywhere about how to tell it to keep charging when locking?

Anyone confirm my findings or know a solution?
5th January 2015, 08:57 AM |#5  
OP Senior Member
Thanks Meter: 31
 
More
Hi

Well I'm still stumped. I can only charge to 100% now if the tablet is switched off completely. If it's switched on, it tends to stop charging at any given point. It also still does not connect to a PC/Laptop. Plug it in and nothing happens, USB connection is dead. I changed the USB socket/ribbon cable out and still the same, so must be a hardware issue deeper inside.

Unfortunately my tablet is so hacked about that I doubt Samsung would touch it. Can't really sell it either as who would want a tablet that they can't connect to USB or have to switch off to charge .

Cheers

Andy
5th January 2015, 11:12 AM |#6  
Junior Member
Thanks Meter: 3
 
More
My P605 only charge with samsung charger.
with the original one and another samsung charger (700mAh) it charge very well, with standard USB chargers (5V, 500mAh to 2000mAh) the connection is "unstable" and seems the cable is connecting-disconnecting. Try it
11th January 2015, 12:39 PM |#7  
OP Senior Member
Thanks Meter: 31
 
More
All these issues are with the Samsung OEM charger. Seems it'll charge as I use it, but once it goes into standby, it stops. So only way to charge is either switching off completely, or charging whilst in use.
17th January 2015, 03:47 PM |#8  
OP Senior Member
Thanks Meter: 31
 
More
Finally fixed this issue!

Sold the tablet and bought a Note 12.2
6th March 2015, 07:42 AM |#9  
Junior Member
Flag Seattle
Thanks Meter: 2
 
More
Quote:
Originally Posted by OzTraveller

Hi I bought the 10.1 2014 Edition back in June. Around November it suddenly started to stop charging. Tried different cables, chargers, charging through PC (very slow) and charging through socket. Took me a couple of weeks to see a pattern. Seems that while charging, if it goes to sleep or locks itself, it stops charging. So I set it to turn the screen off after 30minutes and then it charges. I have it beside me and just touch the screen before the 30mins are up. Not ideal, but allows me to charge it.

I have been searching online and can't see anywhere about how to tell it to keep charging when locking?

Anyone confirm my findings or know a solution?

Bringing this back up because mine started doing this exact thing, and I'm having to charge mine the same way.

Im about to call into TMo CS and get a replacement, but Id rather not deal with that if I can keep my current tablet.

Any fresh ideas?
7th March 2015, 06:15 PM |#10  
rsacipher's Avatar
Senior Member
Flag Washington DC
Thanks Meter: 6
 
More
I'm having the same problem, mine happened after replacing the battery. I can get it to charge but it's a slow trickle and it will lose power even when plugged in if I'm using it.
I replaced the USB flex cable and that didn't work either. I'm thinking something happened to the motherboard since I can't track it down.

I'm going to take mine to a repair shop to see if they can figure it out.
6th August 2015, 09:00 AM |#11  
Junior Member
Thanks Meter: 0
 
More
changing problems
I have two of these Samsung Tablets. One charges perfectly as expected.

The other tablet is a problem.
It charged fine for about a week after purchase and then stopped working as expected, i.e. it started
charging and showing the charging symbol but then it would stop charging after a short while.

After several chargers and many $$$'s (all 2.0A current or more), I found that I could charge it when
switched OFF but very Sloooooowly. Unfortunately, I have not been able to get 100% charge for
several months now as it would take more than 1 night of charging to achieve this.

This afternoon, as I searched for solutions on the web (as I have many many times before), I found the
Display was going off within seconds of plugging in the charger so I updated the settings to have the
display on for the maximum 30 minutes. Interestingly, I found that the charger symbol stayed on!!!
It stayed ON until the 30 minutes display timeout completed. I am now ensuring that there is some
interaction with the table at least every 30 minutes until it is fully charged. By the way, the charging is
fairly quick too - certainly quicker that when it is switched off.

So, I am agreeing with one of the other people on this forum on what is occurring.
My suspicion is that this USB issue was triggered when I attached an external storage device to the USB
but I cannot find anything in the configs to look at or change its status (as you can on some Android
phones, e.g. Sony Xperia).

Hope this is of HELP to some of you.

regards
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes