Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Question [Q] Incredibly slow wifi

OP RishiS

29th June 2014, 01:13 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
Hey guys,

I'm getting incredibly slow wifi after doing the kit Kat upgrade. I'm currently running the xKat latest from but have the same issue on other roms. I've tried everything from clearing cache to factory resets to fiddling around with wifi settings. My download speeds have dropped from like 40Mbps to 3Mbps. Anyone else experiencing the same issues?

Thanks!
29th June 2014, 08:41 PM   |  #2  
Member
Thanks Meter: 3
 
76 posts
Join Date:Joined: Sep 2010
My wifi transport is pretty bad too. :/. idk y. If i try to upload or download something via wifi to my device, i dont see anything higher than 5mbs.
30th June 2014, 02:57 AM   |  #3  
Senior Member
Thanks Meter: 66
 
186 posts
Join Date:Joined: Feb 2012
Quote:
Originally Posted by RishiS

Hey guys,

I'm getting incredibly slow wifi after doing the kit Kat upgrade. I'm currently running the xKat latest from but have the same issue on other roms. I've tried everything from clearing cache to factory resets to fiddling around with wifi settings. My download speeds have dropped from like 40Mbps to 3Mbps. Anyone else experiencing the same issues?

Thanks!

Having Bluetooth enabled slows down WiFi considerably for me...maybe that's ur issue. Try disabling BT if its on
30th June 2014, 02:58 PM   |  #4  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by sam2c

Having Bluetooth enabled slows down WiFi considerably for me...maybe that's ur issue. Try disabling BT if its on

Never have it on actually so unfortunately that isn't the culprit.
1st July 2014, 07:07 PM   |  #5  
OP Junior Member
Thanks Meter: 0
 
4 posts
Join Date:Joined: Jun 2014
So it actually became a lot worse. I was fiddling around with channel settings on my router and noticed that my speed was horrible on my laptop. I turned wifi off and on on the Galaxy Note and noticed that whenever the Galaxy Note is connected to the wifi network every device slows down to an awful 3.5Mbps. No one else experiencing anything like this?
19th August 2014, 12:14 PM   |  #6  
Member
Thanks Meter: 3
 
39 posts
Join Date:Joined: Dec 2007
Mine isn't nearly as bad as what you're describing, but I'm definitely seeing some bad wifi performance. Lots of stuttering and uneven speeds. Also, with my Internet speeds and router, I should be getting a lot higher than what I am.


EDIT: my problem actually seems to be a router problem with having too many devices connected. I disconnected a few and rebooted, and now my Note gets 110 Mbps.
Last edited by JTH182; 20th August 2014 at 05:23 AM.
31st August 2014, 02:47 AM   |  #7  
Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Aug 2014
Quote:
Originally Posted by RishiS

Hey guys,

I'm getting incredibly slow wifi after doing the kit Kat upgrade. I'm currently running the xKat latest from but have the same issue on other roms. I've tried everything from clearing cache to factory resets to fiddling around with wifi settings. My download speeds have dropped from like 40Mbps to 3Mbps. Anyone else experiencing the same issues?


Thanks!

Used 2 have exact same problem with my old router pre N bought a new badass router with all the bells abd whistles and now everyrhing works fine. Well that is without having smb streaming dropping here and there.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes