Don’t Forget About Birthdays with Birthday Reminder

A person’s birthday is, without a doubt,one of the most important days in his … more

Don’t Fear Flashing with I Don’t Want You!

The XDA message boards are full of various modifications, with many of these helping … more

Quo Vadis, Open {Source, Standards, World}? w/ Jan Wildeboer – XDA:DevCon 2014

Open Source was a big topic at this years XDA:DevCon … more

Android 5.0 Leaked for the Samsung Galaxy Note 3

Android Lollipop is still making its way to many new devices. Firmware updates have been … more

Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

How To Tether Free on AT&T Android 4.4.2

OP 06SilveradoZ71

30th June 2014, 07:28 AM   |  #1  
OP Member
Thanks Meter: 11
 
77 posts
Join Date:Joined: Jun 2014
1. Go to Settings --> More --> Tab on Application Manager
2. Go to All tab (By scrolling Vertically)
3. Find AT&T Hot Spots and click it
4. When App info opens, click Turn off

Now AT&T Hotspot is turned off (The above steps just to ensure that AT&T hotspot is off

5. Download RootBrowser and the attached file and save to your phone. Know exactly where you saved it, so you can use it later on.

6. Browse to System/app and rename TetheringProvision.apk and TetheringProvision.odex . Rename the apk and odex to*.bak*(This way, you can rename them back in case the steps did not work for you)

7. After you finish replacing the files, go to your folder where you saved the attached file and copy it to system/app & change permissions to same as the other file you renamed

7. Reboot your phone.

8. Enjoy using foxfi app or any tether app

You cant use the phone settings hotspot but atleast you can tether free on 4.4.2 alot of people are still on unlimited plan so this helps alot

Download Here

Hit Thanks If I Helped

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
Last edited by 06SilveradoZ71; 30th June 2014 at 08:43 AM.
The Following 3 Users Say Thank You to 06SilveradoZ71 For This Useful Post: [ View ]
30th June 2014, 08:06 AM   |  #2  
dicksteele's Avatar
Senior Member
Flag California
Thanks Meter: 1,575
 
2,423 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by 06SilveradoZ71

1. Go to Settings --> More --> Tab on Application Manager
2. Go to All tab (By scrolling Vertically)
3. Find AT&T Hot Spots and click it
4. When App info opens, click Turn off

Now AT&T Hotspot is turned off (The above steps just to ensure that AT&T hotspot is off

5. Download RootBrowser and the attached file and save to your phone. Know exactly where you saved it, so you can use it later on.

6. Browse to System/app and rename TetheringProvision.apk and TetheringProvision.odex . Rename the apk and odex to*.bak*(This way, you can rename them back in case the steps did not work for you)

7. After you finish replacing the files, go to your folder where you saved the attached file and copy it to system/app

7. Reboot your phone.

8. Enjoy using foxfi

Download Here


Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app

Just throwing a couple things out there.....

1. Have you tried this without changing file permissions after the copy?

2. The file is not foxfi.... Foxfi is a different app. This file is one of the stock files that has been modified. And this one does not look like it has been done completely, since it still pops up the notification that it is checking if the device is authorized to tether,

Yes it did work. Honestly I didn't test it without changing file permissions, because I already knew what they were and changed them before I rebooted.
30th June 2014, 08:38 AM   |  #3  
OP Member
Thanks Meter: 11
 
77 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by dicksteele

Just throwing a couple things out there.....

1. Have you tried this without changing file permissions after the copy?

2. The file is not foxfi.... Foxfi is a different app. This file is one of the stock files that has been modified. And this one does not look like it has been done completely, since it still pops up the notification that it is checking if the device is authorized to tether,

Yes it did work. Honestly I didn't test it without changing file permissions, because I already knew what they were and changed them before I rebooted.

Did you like it works great

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
30th June 2014, 07:57 PM   |  #4  
dicksteele's Avatar
Senior Member
Flag California
Thanks Meter: 1,575
 
2,423 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by 06SilveradoZ71

Did you like it works great

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app

I'm not using it. I'm using one that was modified fully and does not have the notification pop up that it's checking for authorization.
30th June 2014, 08:17 PM   |  #5  
OP Member
Thanks Meter: 11
 
77 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by dicksteele

I'm not using it. I'm using one that was modified fully and does not have the notification pop up that it's checking for authorization.

Which one is that?

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
30th June 2014, 09:57 PM   |  #6  
dicksteele's Avatar
Senior Member
Flag California
Thanks Meter: 1,575
 
2,423 posts
Join Date:Joined: Sep 2010
More
Quote:
Originally Posted by 06SilveradoZ71

Which one is that?

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app

I had it on my PC... It should be in General or Q&A Help forums.

Search for tether in those. Not going to be able to find it until later tonight
30th June 2014, 11:36 PM   |  #7  
OP Member
Thanks Meter: 11
 
77 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by dicksteele

I had it on my PC... It should be in General or Q&A Help forums.

Search for tether in those. Not going to be able to find it until later tonight

Ill just use app called quarantine and disable tetheringprovision.apk & es file explorer to tether its fast & easy to turn off & on

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
14th July 2014, 05:59 PM   |  #8  
Senior Member
Thanks Meter: 9
 
146 posts
Join Date:Joined: Nov 2005
I assume root neded?
26th July 2014, 10:16 PM   |  #9  
M-Link,Int.'s Avatar
Member
Flag Somewhere...
Thanks Meter: 11
 
35 posts
Join Date:Joined: May 2013
Donate to Me
More
--Removed--

---------- Post added at 08:16 PM ---------- Previous post was at 07:19 PM ----------

Quote:
Originally Posted by sooby77

I assume root neded?

Yes you will, as the process requires a ROOT Explorer/Browser
Last edited by M-Link,Int.; 26th July 2014 at 10:15 PM. Reason: ---
29th July 2014, 02:39 AM   |  #10  
Junior Member
Thanks Meter: 0
 
10 posts
Join Date:Joined: Jan 2010
What am I missing?
Hello All,

I just tried this and I am still unable to tether with AT&T. I have a Note II currently running 4.4.2. My OTA upgrade semi-bricked my phone (probably because I had a rooted 4.3 install). So I installed 4.4.2 using Zen's ODIN package. I then rerooted using CF-Autoroot and upgrade to SU 2.02 manually. According to Root checker I am rooted, I am also running 4.4.2 w/ the latest boot loader, modem, and kernel.

I first turned off ATT Hotspot as instructed. I then used Total Commander to rename the two existing files under System/app. I moved the APK in the OP into System/app and set permissions as before. I restarted my phone and tried FoxFi. It starts up and goes for a few seconds (which it did not on 4.3) It also seems to be transferring more data. However, once I try to connect my PC to the hotspot I get the "verifying" window and then the notice to call 611 to enable mobile hotspot.

Any ideas?

Thanks.
Last edited by Shadow Lord; 29th July 2014 at 02:44 AM. Reason: Changed notification settings

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes