Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,979 Members 45,366 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Help Confirming I317m Hardware Issue

Tip us?
 
Ill Named
Old
#1  
Member - OP
Thanks Meter 1
Posts: 34
Join Date: Oct 2011
Phone [Q] Help Confirming I317m Hardware Issue

I have this I317m locked to bell. I am trying to use it on virgin mobile canada. From what I've read, I shouldn't have to unlock it to use it on virgin. Anyway, when I insert my virgin sim card, sometimes it'll say unregistered sim and other times it'll just tell me emergency call only. When I look under status, it knows my phone number and it knows that there is a sim card inserted, but it won't let me connect to anything. It's completely stock and on 4.4.2. It never asks to enter an unlock code when booted up and no combination of any symbols and numbers that I have found on the web results in anything happening through the dialer. I have an unlock code for it and I cannot input it anywhere. I am starting to think that I have a hardware issue of some kind and hope that it can be confirmed with help from you guys. Any advice would be greatly appreciated.
 
Ill Named
Old
#2  
Member - OP
Thanks Meter 1
Posts: 34
Join Date: Oct 2011
So it can pick up virgin under available networks, it just can't register on anything. This time, when I turned it on, it read virgin for a split second on the lock screen then switched to unregistered sim and then to just emergency calls only. It has bars showing up, I just can't connect to anything. strange.
 
Ill Named
Old
#3  
Member - OP
Thanks Meter 1
Posts: 34
Join Date: Oct 2011
Well, I have it all apart now and figured for the $7.69 it costs for a new sim reader and micro sd reader, I'll give it a shot.I kinda have a feeling that it not the issue though. I'm kinda leaning toward the nand being fried or something like that.
 
Darkshado
Old
#4  
Darkshado's Avatar
Senior Member
Thanks Meter 433
Posts: 958
Join Date: Apr 2011
Location: Montréal

 
DONATE TO ME
Have you checked that the IMEI was clean?
My phones: Galaxy Note II SGH-T889V (with LTE enabled / ext4 SD card support on TouchWiz ROMs), Motorola XT-1045 Moto G LTE (TWRP)
Previous phones: Nexus S GT-I9020A, Galaxy Gio GT-S5660M (Arpeggiomod ROM / Discussion, stock rooted ROM), Motorola XT-1032 Moto G.
Phones for which I play "tech support" for family and friends: Galaxy Nexus GT-I9250, Galaxy Q SGH-T589R, Galaxy 551 GT-I5510M, LG C-800G Eclypse, Motorola XT-1032 Moto G
The Following User Says Thank You to Darkshado For This Useful Post: [ Click to Expand ]
 
Ill Named
Old
#5  
Member - OP
Thanks Meter 1
Posts: 34
Join Date: Oct 2011
The imei comes up under about phone and matches the sticker. What else is there to check? It also shows up doing the #*06# trick.
 
Ill Named
Old
#6  
Member - OP
Thanks Meter 1
Posts: 34
Join Date: Oct 2011
Aha! Checked IMEI. Not clean. Will fix properly now. Thanks.
 
Darkshado
Old
#7  
Darkshado's Avatar
Senior Member
Thanks Meter 433
Posts: 958
Join Date: Apr 2011
Location: Montréal

 
DONATE TO ME
Which normally means you're in possession of a lost, unpaid or stolen device...
My phones: Galaxy Note II SGH-T889V (with LTE enabled / ext4 SD card support on TouchWiz ROMs), Motorola XT-1045 Moto G LTE (TWRP)
Previous phones: Nexus S GT-I9020A, Galaxy Gio GT-S5660M (Arpeggiomod ROM / Discussion, stock rooted ROM), Motorola XT-1032 Moto G.
Phones for which I play "tech support" for family and friends: Galaxy Nexus GT-I9250, Galaxy Q SGH-T589R, Galaxy 551 GT-I5510M, LG C-800G Eclypse, Motorola XT-1032 Moto G

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes