Post Reply

[Q] [HELP] No gps on kitkat roms

OP engle2192

26th February 2014, 11:53 AM   |  #1  
OP Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Jun 2009
Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.
3rd March 2014, 01:50 AM   |  #2  
Envynet's Avatar
Senior Member
Flag Columbus
Thanks Meter: 52
 
714 posts
Join Date:Joined: Oct 2009
More
I had the exact same problem even after going back to tw roms, I ended up doing a full unroot with Odin and doing the root process all over again. Now my GPS is working again.

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
The Following User Says Thank You to Envynet For This Useful Post: [ View ]
3rd March 2014, 02:27 AM   |  #3  
Steve.99's Avatar
Member
Flag Montreal
Thanks Meter: 18
 
80 posts
Join Date:Joined: Feb 2012
More
Quote:
Originally Posted by engle2192

Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.

I had this problem a few times with different roms, gps would never lock. GPS Status from Play store always fixed it.

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
3rd March 2014, 03:05 AM   |  #4  
OP Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Jun 2009
ahhh i didnt want to have to odin =[ and i tried GPS status but that hasnt helped at all. I guess odin it is =[
5th March 2014, 11:13 PM   |  #5  
Furioustylez's Avatar
Senior Member
Thanks Meter: 154
 
374 posts
Join Date:Joined: Jun 2011
Quote:

Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.

Here's what I used on my kit kat ROM that worked for me.

https://play.google.com/store/apps/d...hibo.gpsstatus

Sent from my GT-N7105 using xda premium
6th March 2014, 02:49 AM   |  #6  
OP Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Jun 2009
Quote:
Originally Posted by Furioustylez

Here's what I used on my kit kat ROM that worked for me.

https://play.google.com/store/apps/d...hibo.gpsstatus

Sent from my GT-N7105 using xda premium

That didn't work for me never gets a lock. Even used the fix tools thing at the bottom of the app.

Sent from my SAMSUNG-SGH-I317 using Tapatalk
6th March 2014, 03:07 AM   |  #7  
cpttrippa's Avatar
Member
Thanks Meter: 6
 
45 posts
Join Date:Joined: Mar 2012
Had the same issue. Nothing worked except Odin back to stock.

Sent from my SAMSUNG-SGH-I317 using xda premium
6th March 2014, 05:36 AM   |  #8  
michaelatrix's Avatar
Senior Member
Thanks Meter: 51
 
481 posts
Join Date:Joined: Jul 2011
Yea Odin fixed me too but I went back to 4.1.2 then back to 4.3 don't know if you have to go to 4.1.2 or not but I did.

Sent from my SAMSUNG-SGH-I317 using xda app-developers app
10th March 2014, 06:06 PM   |  #9  
OP Member
Thanks Meter: 4
 
32 posts
Join Date:Joined: Jun 2009
Well i finally used mobile odin and flashed back to 4.1.2 and that did the trick. Im now back to using a 4.4 kit kat rom and GPS and everything works with no issues. Thanks for the help guys!
1st July 2014, 11:13 PM   |  #10  
Junior Member
Thanks Meter: 3
 
12 posts
Join Date:Joined: Mar 2013
More
Was having the issue with GPS as well.. tried to go back to twrp backup of 4.3 (stock ota) with no success.

Followed these steps to get to 4.1.1 via odin and it's working again.

http://forum.xda-developers.com/show....php?t=2618447
Last edited by SoundBeacon; 2nd July 2014 at 12:26 AM.

Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes