Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,782,368 Members 44,536 Now Online
XDA Developers Android and Mobile Development Forum

[Q] [HELP] No gps on kitkat roms

Tip us?
 
engle2192
Old
#1  
Member - OP
Thanks Meter 4
Posts: 32
Join Date: Jun 2009
Default [Q] [HELP] No gps on kitkat roms

Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.
 
Envynet
Old
#2  
Envynet's Avatar
Senior Member
Thanks Meter 52
Posts: 714
Join Date: Oct 2009
Location: Columbus
I had the exact same problem even after going back to tw roms, I ended up doing a full unroot with Odin and doing the root process all over again. Now my GPS is working again.

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
Current Device
HTC One X
Rom: KingCobraX 1.5
Kernel: Beastmode
My Old Theme: Slate Sense
Recovery: twrp latest
Donate Link
The Following User Says Thank You to Envynet For This Useful Post: [ Click to Expand ]
 
Steve.99
Old
#3  
Steve.99's Avatar
Member
Thanks Meter 18
Posts: 80
Join Date: Feb 2012
Location: Montreal
Quote:
Originally Posted by engle2192 View Post
Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.
I had this problem a few times with different roms, gps would never lock. GPS Status from Play store always fixed it.

Sent from my SAMSUNG-SGH-I317 using XDA Premium 4 mobile app
 
engle2192
Old
#4  
Member - OP
Thanks Meter 4
Posts: 32
Join Date: Jun 2009
ahhh i didnt want to have to odin =[ and i tried GPS status but that hasnt helped at all. I guess odin it is =[
 
Furioustylez
Old
#5  
Furioustylez's Avatar
Senior Member
Thanks Meter 154
Posts: 373
Join Date: Jun 2011
Quote:
Ive been searching and i cant seem to find anything that helps :/ Any kitkat rom that i have tried so far i cant get my GPS to work. Everything else works with no issues just no gps. I have tried using the stock kernels that have came with the rom and also Devil2 kernel. I've done clean install's of the roms as well. I would truly appreciate it if anyone has any ideas on how to get it fixed. Thanks in advance.
Here's what I used on my kit kat ROM that worked for me.

https://play.google.com/store/apps/d...hibo.gpsstatus

Sent from my GT-N7105 using xda premium
 
engle2192
Old
#6  
Member - OP
Thanks Meter 4
Posts: 32
Join Date: Jun 2009
Quote:
Originally Posted by Furioustylez View Post
Here's what I used on my kit kat ROM that worked for me.

https://play.google.com/store/apps/d...hibo.gpsstatus

Sent from my GT-N7105 using xda premium
That didn't work for me never gets a lock. Even used the fix tools thing at the bottom of the app.

Sent from my SAMSUNG-SGH-I317 using Tapatalk
 
cpttrippa
Old
#7  
cpttrippa's Avatar
Member
Thanks Meter 6
Posts: 45
Join Date: Mar 2012
Had the same issue. Nothing worked except Odin back to stock.

Sent from my SAMSUNG-SGH-I317 using xda premium
 
michaelatrix
Old
#8  
michaelatrix's Avatar
Senior Member
Thanks Meter 51
Posts: 480
Join Date: Jul 2011
Yea Odin fixed me too but I went back to 4.1.2 then back to 4.3 don't know if you have to go to 4.1.2 or not but I did.

Sent from my SAMSUNG-SGH-I317 using xda app-developers app
 
engle2192
Old
#9  
Member - OP
Thanks Meter 4
Posts: 32
Join Date: Jun 2009
Well i finally used mobile odin and flashed back to 4.1.2 and that did the trick. Im now back to using a 4.4 kit kat rom and GPS and everything works with no issues. Thanks for the help guys!
 
SoundBeacon
Old
(Last edited by SoundBeacon; 2nd July 2014 at 12:26 AM.)
#10  
Junior Member
Thanks Meter 3
Posts: 12
Join Date: Mar 2013
Was having the issue with GPS as well.. tried to go back to twrp backup of 4.3 (stock ota) with no success.

Followed these steps to get to 4.1.1 via odin and it's working again.

http://forum.xda-developers.com/show....php?t=2618447

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes