FORUMS

Swappa’s New App Helps You Value Your Device

There comes a sad time in everyone’s life where you must part ways with your … more

Xiaomi Sold 34.7 Million Phones In 6 Months

2015 has been a phenomenal year for Xiaomi so far. With a stellar rise in 2014, 2015 saw … more

Sprint Reacts To Jab From T-Mobile

America’s cellular network space has always been a battle of the big four: Verizon, AT&T, … more

Floating Apps with Rovers – XDA App Review

There are a lot of great launchers to help customize your phone. Some Launchers allow … more

[Q] accelerometer

43 posts
Thanks Meter: 10
 
By motfis, Member on 26th August 2014, 07:02 AM
Post Reply Subscribe to Thread Email Thread
Hi, I want to ask something. I have a problem with my accelerometer. So in the gpsstatus, it always shows g ~ 0.49 (https://www.dropbox.com/s/ylqclmxp71...49-06.png?dl=0)
I am not sure since when it happened. Then I download the system monitor, and only the Z accelerometer that gives wrong value (I guess it shouldbe close to 9.8??). Also from *#0*# looks like the Z value is wrong.
What is the number in your devices?
Is there anyway to reset/calibrate this number, specially without rooting?

Thanks!
Attached Thumbnails
Click image for larger version

Name:	Screenshot_2014-08-26-00-17-18.png
Views:	31
Size:	117.2 KB
ID:	2912540   Click image for larger version

Name:	Screenshot_2014-08-25-23-48-07.png
Views:	23
Size:	31.7 KB
ID:	2912541  
 
 
27th August 2014, 09:45 PM |#2  
OP Member
Flag Groningen
Thanks Meter: 10
 
More
Quote:
Originally Posted by motfis

Hi, I want to ask something. I have a problem with my accelerometer. So in the gpsstatus, it always shows g ~ 0.49 (https://www.dropbox.com/s/ylqclmxp71...49-06.png?dl=0)
I am not sure since when it happened. Then I download the system monitor, and only the Z accelerometer that gives wrong value (I guess it shouldbe close to 9.8??). Also from *#0*# looks like the Z value is wrong.
What is the number in your devices?
Is there anyway to reset/calibrate this number, specially without rooting?

Thanks!

Anyone here know how to fix this problem?
28th August 2014, 03:01 AM |#3  
Senior Member
Thanks Meter: 97
 
More
there could be only 2 possible causes for this: software or hardware.
For software issue you could reset the phone to factory or even wipe it clean and reload stock firmware to see if that helps.
If it's a hardware then the only thing I could think off is to make sure all the connectors are clean and make good contact, but I don't remember if sensors are on separate module like vibration or cam modules or are they build onto motherboard. If they are on separate board then check connectors and look for replacement, if they're on MB, then no connectors to worry, but fixing it gets more complex.
I can't remember ever seeing calibration for accelerometers, sorry.
What issues do you have, outside of showing wrong on gps status? Is it worth the trouble of fixing it? Samsung repair service is probably best bet, if that's an option.
ps
my gps status shows 0 unless moved, so there is something wonky there
Last edited by pete4k; 28th August 2014 at 03:03 AM.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes