FORUMS
Post Reply Subscribe to Thread Email Thread

[A] [SM-P900] HOWTO: Full Backup without Root and Easiest way to get Root

25th April 2015, 04:07 PM |#1  
OP Member
Flag Nuremberg
Thanks Meter: 10
 
More
Disclaimer: Not responsible for what you do with this information.

Important Note: So far (April 2015), no one has been able to root or flash non-stock recovery on SM-P900 without tripping KNOX. For all we know, KNOX is useless to us, but nonetheless use the SuperSU app to disable KNOX after you are able to get root. No need to disable KNOX if you don't root.

I tried to get root on my SM-P900 but for some reason I couldn't get TWRP recovery to stick (always reverted to stock recovery) and also had corrupted display after flashing Chainfire autoroot using ODIN (Odin was stuck on flashing cache.img). My summary here should help anyone else to quickly what they need without digging through different threads. FYI-- these steps work on latest Samsung OTA with Kitkat 4.4.2


Tools required (for full backup or to get root):
Windows 7 PC (or Virtual Box VM https://www.modern.ie/en-us/virtuali...ools#downloads -- did not test using a VM)
Samsung USB Drivers for Note Pro 12.2
Odin3 (v3.09, not 3.07 or 3.10.x)-- Only get this from xda-developers forums, not from any third party website http://forum.xda-developers.com/atta...4&d=1385179473 -
P900XXUANB3-RecoveryImg.tar -- http://forum.xda-developers.com/atta...3&d=1392923580
twrp-2.8.6.0-v1awifi.img.tar (or just latest twrp for P900 .img.tar image)

Two things to be aware of:
To Boot Tablet in Odin mode press and hold: (Vol Down + Menu + Power)
To Boot Tablet to Recovery press and hold: (Vol Up + Menu + Power) release after seeing Samsung logo for the second time

1. Compleletly remove Samsung Kies from your PC
2. Install latest Samsung USB drivers for Galaxy Note Pro 12.2 (just google and get it from the official Samsung Website)
3. Keep USB cable disconnected from PC, Boot into Odin Download Mode on the tablet
- Make sure to accept the warning by pushing Vol up
- Odin Mode should say:
Current Binary: Samsung (or Official)
System Status: Samsung (or Official)
Knox Warranty Void: 0

4. Start Odin on the Windows PC as Administrator (not sure if Admin rights are necessary but just do it)
5. Load the P900XXUANB3-RecoveryImg.tar image into "AP" (or "PDA" if you are using an earlier Odin3 version!!!). Also remove "Auto Reboot" option and keep "F. Reset Time" enabled
6. Connect the Tablet. Odin should say ""<ID:0/00#> Added!! -- this means USB connection established
7. Flash the Recovery Image by hitting "Start". Should take maybe 5-10 seconds.
8. Next load the twrp .img.tar file in to "AP". Flash that by hitting "Start". Should take maybe 10 seconds.
9. Power tablet off. Disconnect USB.
10. Plug in an external microSD card (if you want to backup). Boot in to recovery (Vol up + Menu + Power).

If you do a full boot, you will lose recovery. If you flash CF Auto Root .tar.md5 image you will get corrupted display then you wont be able to boot unless you flash the P900XXUANB3-RecoveryImg.tar image.

11. Once in TWRP recovery, you should do a backup and select the destination the external microSD card.
12. Then go to reboot, select system, and then swipe right if you want to root.
13. Boot up normally, then download SuperSU app from Google Play Store
14. Run SuperSU, it will say binary needs to be updated. Hit OK, then hit TWRP/CWM Recovery. Device will reboot in to TWRP, run a script then will say "FAILED" and reboot automatically.
15. Boot up normally, you now have root. Open SuperSU app, it will say seems that you have KNOX, do you want to disable it? Say yes.

People on this forum said that if Root is acquired and KNOX is not disabled, they suffered from random soft-reboots.

Download Adaway APK and install it. Once installed run the app an it will ask for root privileges. Now you're golden.

Troubleshooting:

If you tried to flash and TWRP doesn't stick check your status by going in to Odin Mode if the tablet still says:
Current Binary: Samsung (or Official)
System Status: Samsung (or Official)
Knox Warranty Void: 0

Then nothing changed from stock settings.

If it says:
Current Binary: Samsung (or Official)
System Status: Custom
Knox Warranty Void: 1

Then you probably have TWRP installed but didn't try booting in to it.

If it says:
Current Binary: Custom
System Status: Custom
Knox Warranty Void: 1

Then you probably have TWRP installed and also root (if you swiped right).


Where to go from here?
You can stay rooted, or you can now use TWRP to flash another rom (CM12+ for example).
Attached Thumbnails
Click image for larger version

Name:	IMG_20150425_132157.jpg
Views:	104
Size:	253.4 KB
ID:	3281210  
 
 
25th April 2015, 04:08 PM |#2  
OP Member
Flag Nuremberg
Thanks Meter: 10
 
More
reserved.
26th April 2015, 12:13 PM |#3  
Junior Member
Thanks Meter: 0
 
More
Good Guide, thank you!, was about to write one anyways.

5 more things:

1.) On the Note Pro you don't need the home button! You can reach recovery by pressing Vol up + Power, let got of the Power and keep pressing Vol when you see the screen turn on (easier when device is unplugged from both PC and power)

2.) For those interested in using a VM to use with Odin: VirtualBox DOES NOT WORK! (tested with Win XP and Win7). The problem seems to be the virtual USB Controller to connect to Host USB devices. Odin won't detect connected devices.
Use VmWare instead! I used VMWare Fusion with Win 7 Enterprise and it worked like a charm. Seems to have better USB Host integration.

3.) Odin 3.10.6 worked fine for me (Odin 3.9 also works!)

4.)Suggestion:
If you want root, instead of downloading SuperSU from the Play store, place the TWRP SuperSU (at the moment SuperSU 2.46) on your SD card. When you boot into recovery, you can flash the SuperSU directly after making you initial backup.
No Errors, so installing Supersu twice, no problems

5. SUPERSU link is missing in the "things needed" list.

Feel free to add this information to the first post.
26th April 2015, 12:36 PM |#4  
OP Member
Flag Nuremberg
Thanks Meter: 10
 
More
thanks for the tips.

using the method described above, SuperSU script is downloaded with the play store SuperSU app. So it guarantees you're using the latest version. plus you should use the SuperSU app to monitor which apps have been granted root privileges.

although i haven't tried Odin with Virtual Box, I've used fastboot and adb a few thousand times and it always worked for me. maybe its something specific happening here.
Post Reply Subscribe to Thread

Tags
note pro 12.2, p900, root, sm-p900, twrp
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes