FORUMS

SM-P900 Wifi Touch Screen has Malfunctioned

17 posts
Thanks Meter: 0
 
By gamecheif, Junior Member on 31st March 2015, 09:01 AM
Post Reply Subscribe to Thread Email Thread
Hello All,

In my attempt to root the device which I was successful in doing somehow things went south when i tried to flash TWRP on my device. I performed the .img to tar.md5 conversion with the CWM Tool on another thread then i flashed the file to my device, afterwards the devices were rebooted and now I am unable to touch the screen with my fingers and only my S-Pen works, which tells me hardware wise the screen is ok but something software wise is causing this issue. Can someone please help me in troubleshooting this issue. I seen another user have this same exact issue but it ended with him sending it to the service center. I have performed a full dat/factory reset.... I have performed a full reflashing of the stock rom i have re-rooted. I am all out of options.

See video i made regarding this issue.

https://www.youtube.com/watch?v=orLEnWhlATo

Thanks in advance!
 
 
5th April 2015, 04:40 AM |#2  
OP Junior Member
Thanks Meter: 0
 
More
Can anyone help with this
6th April 2015, 05:03 PM |#3  
Serinety's Avatar
Senior Member
Flag Davis, CA
Thanks Meter: 352
 
Donate to Me
More
Capacitive touch and spen use 2 totally different chips inside the tablet. The spen uses a Wacom digitizer, while touch interaction is processed using standard methods.

In fact, each one has their own ribbon cable from the screen to different points on the motherboard.

I have no idea how rooting broke your touch ability, but the spen working is not an indication that the touch interaction is not damaged in some way.

I can tell you that on mine (especially when using papyrus) it has a tendency to lose touch until I shut the screen off and turn it back on. Maybe something screwy is going on with the touch driver. Flash back to stock and see if it's still broken
22nd June 2015, 06:11 AM |#4  
Junior Member
Thanks Meter: 0
 
More
Did the reset work?
I ask because we just got a used tablet off ebay and it is doing the same thing to me. My wife emailed Samsung who said blah-blah-blah so we are stuck with it. I know enough to brick a phone really fast, but I have been running custom Roms a long time and have replaced screens so I may check the cables on my day off.
But it was doing it before I rooted it, recovery, and Hyper-drive Rom.
though the knox had been tripped before I got it, so I don't know what has been done to it before this. So please let me know what you think even if you try it and it does or doesn't work and I will gladly do the same for you.
Thanks--Rick
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools
Display Modes