Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,730,051 Members 53,794 Now Online
XDA Developers Android and Mobile Development Forum

[CWM][Repo]ClockWorkMod Recovery - ||Kit-Kat 4.4 Compatible||

Tip us?
 
ReiKo90
Old
#31  
Senior Member
Thanks Meter 9
Posts: 313
Join Date: Dec 2010
Can I use this if I have installed Ice Cream Sandwich ROM with Siyah kernel? My goal is to transfer to Paranoid Android which needs this Kit Kat 4.4 compatibility.
 
Ryuinferno
Old
#32  
Ryuinferno's Avatar
Recognized Contributor
Thanks Meter 6666
Posts: 3,416
Join Date: Apr 2012

 
DONATE TO ME
@-Grift-

For the s2 family, recovery.img = boot.img, it's just copied over, and /dev/block/mmcblk0p5 is the boot partition, in other words, there is a kernel (recovery and kernel are combined, unlike other devices which have separate boot and recovery), but ROM's might not boot properly, but if it is just for the purpose of utilising the recovery to flash ROMs that require set_metadata, it's OK...you might wanna update the description to avoid confusion...


Maintains for:
- CyanogenMod (i9100g)
- MoKee OpenSource Project (deb, i9100g, i9100)
- Slimroms Slim Kat (i9100g)
- VanirAOSP (i9100g)
- AOSPA Paranoid Android (i9100g)
- AoCP The Android Collective Project (i9100g)




My GitHub: https://github.com/Ryuinferno
My works: http://ryuinferno.github.io

MoKee OpenSource Build Status
MoKee OpenSource Server Bandwidth Monitor
(6TB per/mo, extra at USD0.02/GB)

Donate to support MoKee OpenSource development!
 
tramsss
Old
(Last edited by tramsss; 17th June 2014 at 09:15 PM.)
#33  
Junior Member
Thanks Meter 2
Posts: 20
Join Date: Dec 2010
Hello,
i installed "PhilZ Touch 5 CWM Base Version: 6.0.3.3" with Odin on my Galaxy S2 and then i tried to install latest Cyanogenmod (cm-11-20140617-NIGHTLY-i9100.zip)... but i get this error:

"set_metadata_recursive: some changes failed" and the installation aborted.

Now every time i turn on the phone it runs ClockWorkMod instead of normal startup.

I searched on Google and it should be a problem related to the incompatibility between this CWM version and this CM version.
How to find out a solution?

If i want to change the CWM version, can i install it using the currently CWM? If this is could be possibile, how to do it and where i can get the right CWM version for my phone?


EDIT: i Flashed Recovery_CWM_6.0.4.7_I9100.zip via currently CWM and i installed successfully Cyanogenmod... but now it hangs on CM logo... how to solve this?

EDIT2: i solved, please delete this post. thank you.
 
Jabbacks
Old
#34  
Member
Thanks Meter 0
Posts: 44
Join Date: Aug 2011
Default WiFi Region Code

In cm-10.1.3-i9100 (stable) everytime you turn on wifi, you have to go and set the wifi region code. Is it possible to save it so we don't have to go back and re set it everytime we turn on the wifi, esp after you power up the phone?

Thank you very much!
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes