Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,812,579 Members 43,191 Now Online
XDA Developers Android and Mobile Development Forum

[Guide] Alternate to Ad-Hoc Wi-Fi Network for your Android Device

Tip us?
 
ggfairy
Old
#21  
Junior Member
Thanks Meter 3
Posts: 1
Join Date: Nov 2012
I've created a GUI solution to your method. It is lightweight (less than 200kb) and works only with a click
Download : sdrv.ms/TmzOfU
The Following 3 Users Say Thank You to ggfairy For This Useful Post: [ Click to Expand ]
 
aarrun
Old
#22  
aarrun's Avatar
Recognized Themer
Thanks Meter 290
Posts: 627
Join Date: Jan 2011
Location: Mumbai
THANX a ton brol... was finding something which cud do this...which cud make a network of my own without use of 3rd party app...... coz i really dont like connectify which was kinda buggy a lota times.... thanx a lot bro... nice guide and it works for non anddroid fones too.... ....


PHONE: SAMF**KED....GALAXY 3
ROM: GingerDX(Modded as for my needs)
KERNEL:CM7 apollo#889 OC
THEME: My Modded Achep's Theme


MY THEME WORK FOR G3:

Antonda Design Blue for Froyo
Antonda Design Green for Froyo
AOSP Gingerbread for Froyo
ICS Theme for Froyo
Sensation Crysis for Froyo
Theme Elegance for Froyo
Hi-Tech Sense for Froyo
 
Harsha Raj
Old
#23  
Harsha Raj's Avatar
Senior Member - OP
Thanks Meter 1,233
Posts: 4,229
Join Date: Jun 2011
Quote:
Originally Posted by ggfairy View Post
I've created a GUI solution to your method. It is lightweight (less than 200kb) and works only with a click
Download : sdrv.ms/TmzOfU
Thank you. Yet to try it out.


Quote:
Originally Posted by aarrun View Post
THANX a ton brol... was finding something which cud do this...which cud make a network of my own without use of 3rd party app...... coz i really dont like connectify which was kinda buggy a lota times.... thanx a lot bro... nice guide and it works for non anddroid fones too.... ....
Well yes. The virtual wifi which you create is just like any router. So anything that has a wifi receiver can connect to it :thumbup:

Sent from my GT-I9100 using Tapatalk 2

ROM: SlimSaber - Android 4.4.4 Kernel: Stock

History: Nokia 3100 > Nokia 6230i > Nokia 6111 > Nokia 3100 Classic > Nokia 5700 > Nokia 5230 > Samsung Galaxy S > Samsung Galaxy S II i9100

Secondary Device: Motorola Moto G Dual SIM - ROM: Stock Kernel: Stock

 
aarrun
Old
#24  
aarrun's Avatar
Recognized Themer
Thanks Meter 290
Posts: 627
Join Date: Jan 2011
Location: Mumbai
yesterday i ws figuring out how to make an automatic or kinda one click on off for the wifi hotspot coz typing the command each time is hectic. so i made 2 .bat(batch) files with command for starting wifi ap and other for stopping. but just now i saw theres a person who has made an app for it....thanx to him and u ...coz its really helpfull.


PHONE: SAMF**KED....GALAXY 3
ROM: GingerDX(Modded as for my needs)
KERNEL:CM7 apollo#889 OC
THEME: My Modded Achep's Theme


MY THEME WORK FOR G3:

Antonda Design Blue for Froyo
Antonda Design Green for Froyo
AOSP Gingerbread for Froyo
ICS Theme for Froyo
Sensation Crysis for Froyo
Theme Elegance for Froyo
Hi-Tech Sense for Froyo
 
peekeesh
Old
(Last edited by peekeesh; 27th November 2012 at 10:19 PM.)
#25  
Senior Member
Thanks Meter 160
Posts: 343
Join Date: Oct 2010
i was able to create the virtual AP using the steps provided by the OP. However, my phone will pass authentication, will show obtaining IP address and then it won't connect. Then the status will show as Saved, Secured. It will reconnect and then a message will appear the says "Attention! network disabled. Poor connection."

anyone has any ideas how to fix this?
 
Harsha Raj
Old
#26  
Harsha Raj's Avatar
Senior Member - OP
Thanks Meter 1,233
Posts: 4,229
Join Date: Jun 2011
Quote:
Originally Posted by peekeesh View Post
i was able to create the virtual AP using the steps provided by the OP. However, my phone will pass authentication, will show obtaining IP address and then it won't connect. Then the status will show as Saved, Secured. It will reconnect and then a message will appear the says "Attention! network disabled. Poor connection."

anyone has any ideas how to fix this?
Well looks like the device is having problem in taking the IP address. You sure have shared the internet from LAN properties?

1. Make sure that virtual wifi adapter created has an IP address. System automatically sets it to 192.168.137.1.

2. You can try is try setting the IP address manually in your S2 to 192.168.137.xxx, anything except 192.168. 137.1 and xxx can't be greater than 225.

Now this would skip the" obtaining IP address" when connecting.

Sent from my GT-I9100 using Tapatalk 2

ROM: SlimSaber - Android 4.4.4 Kernel: Stock

History: Nokia 3100 > Nokia 6230i > Nokia 6111 > Nokia 3100 Classic > Nokia 5700 > Nokia 5230 > Samsung Galaxy S > Samsung Galaxy S II i9100

Secondary Device: Motorola Moto G Dual SIM - ROM: Stock Kernel: Stock

The Following 2 Users Say Thank You to Harsha Raj For This Useful Post: [ Click to Expand ]
 
Harsha Raj
Old
#27  
Harsha Raj's Avatar
Senior Member - OP
Thanks Meter 1,233
Posts: 4,229
Join Date: Jun 2011
Quote:
Originally Posted by aarrun View Post
yesterday i ws figuring out how to make an automatic or kinda one click on off for the wifi hotspot coz typing the command each time is hectic. so i made 2 .bat(batch) files with command for starting wifi ap and other for stopping. but just now i saw theres a person who has made an app for it....thanx to him and u ...coz its really helpfull.
Thank you. I will to try it out once and add it to OP.

Sent from my GT-I9100 using Tapatalk 2

ROM: SlimSaber - Android 4.4.4 Kernel: Stock

History: Nokia 3100 > Nokia 6230i > Nokia 6111 > Nokia 3100 Classic > Nokia 5700 > Nokia 5230 > Samsung Galaxy S > Samsung Galaxy S II i9100

Secondary Device: Motorola Moto G Dual SIM - ROM: Stock Kernel: Stock

 
peekeesh
Old
(Last edited by peekeesh; 28th November 2012 at 10:05 PM.)
#28  
Senior Member
Thanks Meter 160
Posts: 343
Join Date: Oct 2010
Quote:
Originally Posted by Harsha Raj View Post
Well looks like the device is having problem in taking the IP address. You sure have shared the internet from LAN properties?

1. Make sure that virtual wifi adapter created has an IP address. System automatically sets it to 192.168.137.1.

2. You can try is try setting the IP address manually in your S2 to 192.168.137.xxx, anything except 192.168. 137.1 and xxx can't be greater than 225.

Now this would skip the" obtaining IP address" when connecting.

Sent from my GT-I9100 using Tapatalk 2
I tried setting static IP but still it didn't work. But i managed to get it to work by uninstalling Dell Wireless Lan utility and re-installing the wifi driver. I'm thinking Dell utility is not compatible with it and it's causing it to not work properly. Anyway, it's all good now so thank you!

To all those who use Dell laptops with Dell Wireless 1540 wifi card and can't get virtual AP to work, you can try doing what I did.
 
milan188
Old
#29  
Senior Member
Thanks Meter 44
Posts: 281
Join Date: Sep 2011
Location: Johannesburg
Connectify does this in 1 step
Neat Rom LPG
Phenomenal Extreme 5.5
 
aarrun
Old
#30  
aarrun's Avatar
Recognized Themer
Thanks Meter 290
Posts: 627
Join Date: Jan 2011
Location: Mumbai
but conenctify is slow and buggy


PHONE: SAMF**KED....GALAXY 3
ROM: GingerDX(Modded as for my needs)
KERNEL:CM7 apollo#889 OC
THEME: My Modded Achep's Theme


MY THEME WORK FOR G3:

Antonda Design Blue for Froyo
Antonda Design Green for Froyo
AOSP Gingerbread for Froyo
ICS Theme for Froyo
Sensation Crysis for Froyo
Theme Elegance for Froyo
Hi-Tech Sense for Froyo

Tags
alternate ad hoc, virtual wifi
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes