Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,806,934 Members 37,624 Now Online
XDA Developers Android and Mobile Development Forum

[ROM][DEV][CM11.0][KERNEL][SGH-I757M]UNOFFICIAL CM11.0 For Bell SGH-I757M

Tip us?
 
shivraj67
Old
(Last edited by shivraj67; 14th September 2014 at 09:48 AM.)
#501  
Junior Member
Thanks Meter 9
Posts: 9
Join Date: Apr 2011
Quote:
Originally Posted by titanic_fanatic View Post
For those of you still on the latest cm11 and also experiencing the bugs with the phone, please see my post on the carbon thread about it:

http://forum.xda-developers.com/show...php?p=55430805

EDIT:
Now the problem is fixed. See the post from me after the one I posted above
Unfortunately, even while being on the latest CM11 build I still had the same issue of not being able to hear my calls. I have it set on OnDemand, and all I did was raise the minimum cpu frequency to one step above. Since the issue persisted with other governors, I don't think that's the issue.

I will try out the build.prop fix and report back after testing. EDIT: I don't experience the exact same bug as Carbon (I do receive calls), but will still give it a try.

Also, does anyone encounter a 'upload failed' issue with Instagram videos?
The Following User Says Thank You to shivraj67 For This Useful Post: [ Click to Expand ]
 
big_biso
Old
(Last edited by big_biso; 15th September 2014 at 01:39 AM.)
#502  
Senior Member
Thanks Meter 87
Posts: 108
Join Date: Apr 2009
Hi TF, I have found what causing occasional loss of speaker and microphone. As some user reported on various builds when they call or receive calls.
It just happened to me and now I can reproduce it. Some VoIP apps will highjack the phone mic and speaker and will not be able to use them any more with the regular dialer. In the past Facebook messenger did that and today the new hangouts did it when I used VoIP. Other apps like viber or majicjack do not do that.
The Following User Says Thank You to big_biso For This Useful Post: [ Click to Expand ]
 
shivraj67
Old
#503  
Junior Member
Thanks Meter 9
Posts: 9
Join Date: Apr 2011
Quote:
Originally Posted by big_biso View Post
Hi TF, I have found what causing occasional loss of speaker and microphone. As some user reported on various build when they call or receive calls.
It just happened to me and now I can reproduce it. Some VoIP apos will highjack the phone mic and speaker and will not be able to use them any more with the regular dialer. In the past Facebook messenger did that and no. Today the new hangouts did it when I used VoIP. Other apps like viber or majicjack do not do that.
It happened to me with Facebook messenger and Hangouts both uninstalled. Maybe there are some other stock and/or user apps requesting use of the 'Phone' app.
The Following User Says Thank You to shivraj67 For This Useful Post: [ Click to Expand ]
 
titanic_fanatic
Old
#504  
titanic_fanatic's Avatar
Recognized Contributor - OP
Thanks Meter 1,863
Posts: 1,902
Join Date: Sep 2012
Location: Calgary

 
DONATE TO ME
Quote:
Originally Posted by shivraj67 View Post
It happened to me with Facebook messenger and Hangouts both uninstalled. Maybe there are some other stock and/or user apps requesting use of the 'Phone' app.

Which voice/VoIP apps do you have installed?


Sent from my iPad using Tapatalk
------------------------------------------------------------------------------------------------------------
Follow my apps and development at any of the social media outlets below:



Old Phone: Bell GT-I9000M (CM10.2 Nightlies)
Current Phone: Bell SGH-I757M (Carbon KitKat - carbon_celoxhd-eng 4.4.4 KTU84Q ed15ef468c test-keys)
 
shivraj67
Old
#505  
Junior Member
Thanks Meter 9
Posts: 9
Join Date: Apr 2011
Quote:
Originally Posted by titanic_fanatic View Post
Which voice/VoIP apps do you have installed?


Sent from my iPad using Tapatalk
None that I know of, except Facebook Messenger. But even with that, I have never used calling through it, and the problem persisted when I uninstalled it.

Hopefully if I get some free time from school in the near future, I can install the ROM clean and test out the dialer for a while after installing each new app. This way we can rule out if any user apps are causing the issue.
The Following User Says Thank You to shivraj67 For This Useful Post: [ Click to Expand ]
 
big_biso
Old
#506  
Senior Member
Thanks Meter 87
Posts: 108
Join Date: Apr 2009
Quote:
Originally Posted by titanic_fanatic View Post
Which voice/VoIP apps do you have installed?


Sent from my iPad using Tapatalk
Hi TF, Since I can reproduce it every time. I managed to get a logcat for you.
I looked in the logcat and I found some errors during the Hangouts voice call like out of memory and I found a warning that state it is detecting a memory leak.

attached
Attached Files
File Type: 7z logcat.7z - [Click for QR Code] (89.1 KB, 1 views)
The Following User Says Thank You to big_biso For This Useful Post: [ Click to Expand ]
 
shivraj67
Old
#507  
Junior Member
Thanks Meter 9
Posts: 9
Join Date: Apr 2011
Quote:
Originally Posted by big_biso View Post
Hi TF, Since I can reproduce it every time. I managed to get a logcat for you.
I looked in the logcat and I found some errors during the Hangouts voice call like out of memory and I found a warning that state it is detecting a memory leak.

attached
I was going to make 2 logcats, one while calling works and one while it doesn't. Fortunately, it seems that I found a fix. Going into the sound settings and enabling 'lock screen sound' seems to do the trick!

@big_biso, please try it out and let me know if it works for you. Then again I don't use any VOIP features.
The Following 2 Users Say Thank You to shivraj67 For This Useful Post: [ Click to Expand ]
 
big_biso
Old
#508  
Senior Member
Thanks Meter 87
Posts: 108
Join Date: Apr 2009
Quote:
Originally Posted by shivraj67 View Post
I was going to make 2 logcats, one while calling works and one while it doesn't. Fortunately, it seems that I found a fix. Going into the sound settings and enabling 'lock screen sound' seems to do the trick!

@big_biso, please try it out and let me know if it works for you. Then again I don't use any VOIP features.
Unfortunately that did not solve the issue when using voip . still after hangouts no voice on regular calls
The Following 2 Users Say Thank You to big_biso For This Useful Post: [ Click to Expand ]
 
big_biso
Old
#509  
Senior Member
Thanks Meter 87
Posts: 108
Join Date: Apr 2009
Quote:
Originally Posted by big_biso View Post
Hi TF, Since I can reproduce it every time. I managed to get a logcat for you.
I looked in the logcat and I found some errors during the Hangouts voice call like out of memory and I found a warning that state it is detecting a memory leak.

attached
Hi TF, Anything you find in this logcat?
 
titanic_fanatic
Old
#510  
titanic_fanatic's Avatar
Recognized Contributor - OP
Thanks Meter 1,863
Posts: 1,902
Join Date: Sep 2012
Location: Calgary

 
DONATE TO ME
Quote:
Originally Posted by big_biso View Post
Hi TF, Anything you find in this logcat?
No, unfortunately not. Thinking of logs though, are you able to get a dmesg log. You just run

dmesg > /sdcard/dmesg.txt

After having done su of course. This is the kernel log and there might be something useful going on in there.
------------------------------------------------------------------------------------------------------------
Follow my apps and development at any of the social media outlets below:



Old Phone: Bell GT-I9000M (CM10.2 Nightlies)
Current Phone: Bell SGH-I757M (Carbon KitKat - carbon_celoxhd-eng 4.4.4 KTU84Q ed15ef468c test-keys)

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes