FORUMS

Moto X Style, Moto X Play and Moto G Forums Are Here!

The latest family members of the new generation of Motorola devices are … more

Galaxy Unpacked: What is Samsung Going to Unveil?

Amidst all the hype of the OnePlus 2 and the rain of Moto 2015 news, Samsung tried … more

Arrow Launcher: Good Effort Without Direction

Microsoft’s Android expansion has been well received on the productivity front, but … more

Two New Moto X and New Moto G – Specs & Details

Today’s Moto event just ended and now we have a clear look at all of … more

No 4G on non-stock roms

33 posts
Thanks Meter: 3
 
By fukanigaup, Member on 18th August 2012, 09:53 PM
Post Reply Subscribe to Thread Email Thread
I have a GT- i9100 with a 4G plan (HSPA+). The problem is that I cannot get it to work on any non-stock rom. I have tried at least six stock roms and it has worked on each one. But whether aosp/aokp/miui, I can not use my data connection for internet. I have manually entered and double checked apn settings many times. I have enabled hsdpa etc under Galaxy/ Advanced settings and restarted many times. I have tried numerous modems to no avail. My phone is rooted but not unlocked. I am not sure if that is relevant. Help would be greatly appreciated.
 
 
18th August 2012, 10:06 PM |#2  
Jokesy's Avatar
Senior Member
Flag Lagos
Thanks Meter: 1,156
 
More
Quote:
Originally Posted by fukanigaup

I have a GT- i9100 with a 4G plan (HSPA+). The problem is that I cannot get it to work on any non-stock rom. I have tried at least six stock roms and it has worked on each one. But whether aosp/aokp/miui, I can not use my data connection for internet. I have manually entered and double checked apn settings many times. I have enabled hsdpa etc under Galaxy/ Advanced settings and restarted many times. I have tried numerous modems to no avail. My phone is rooted but not unlocked. I am not sure if that is relevant. Help would be greatly appreciated.

dial *#*#4636*#*# to enter device mode.
Change your radio to LTE.
Tell me if it works


Swyped from my Samsung Galaxy SII
18th August 2012, 11:12 PM |#3  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Jokesy

dial *#*#4636*#*# to enter device mode.
Change your radio to LTE.
Tell me if it works


Swyped from my Samsung Galaxy SII

Tried to enter four times. Every time got the following message
"Connection problem or invalid MMI code."
Last edited by fukanigaup; 18th August 2012 at 11:14 PM.
18th August 2012, 11:28 PM |#4  
Senior Member
Thanks Meter: 715
 
More
HSPA+ isn't 4G.
18th August 2012, 11:45 PM |#5  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by oinkylicious

HSPA+ isn't 4G.

This is not a HSPA+ vs LTE debate. I am just trying to get my data connection working on non samsung roms.
18th August 2012, 11:54 PM |#6  
Jokesy's Avatar
Senior Member
Flag Lagos
Thanks Meter: 1,156
 
More
Quote:
Originally Posted by fukanigaup

Tried to enter four times. Every time got the following message
"Connection problem or invalid MMI code."

Sorry, I made mistake while typing the code the other time.
-Dial *#*#4636#*#*
-open phone information
-set radio to the band of your choice.

Good luck

Swyped from my Samsung Galaxy SII
Last edited by Jokesy; 18th August 2012 at 11:56 PM.
The Following User Says Thank You to Jokesy For This Useful Post: [ View ]
19th August 2012, 12:17 AM |#7  
OP Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Jokesy

Sorry, I made mistake while typing the code the other time.
-Dial *#*#4636#*#*
-open phone information
-set radio to the band of your choice.

Good luck

Swyped from my Samsung Galaxy SII

Tried different bands to no avail. most just reverted to default of WCDMA preferred
19th August 2012, 11:54 AM |#8  
boki9999's Avatar
Senior Member
Flag Zagreb
Thanks Meter: 73
 
More
I'm also interested on activating H+ on non-stock roms. I really hope you'll find a solution.

Sent from my Galaxy S2 GT i9100
19th August 2012, 08:27 PM |#9  
OP Member
Thanks Meter: 3
 
More
I am hopeful.
9th September 2012, 02:10 AM |#10  
Jokesy's Avatar
Senior Member
Flag Lagos
Thanks Meter: 1,156
 
More
Quote:
Originally Posted by fukanigaup

I am hopeful.

Let me know if you have solved for problem or not.


Swyped from my Samsung Galaxy SII
9th September 2012, 07:54 AM |#11  
Omaxe's Avatar
Senior Member
Flag Patiala
Thanks Meter: 223
 
More
Wait i9100 isnt 4G i think... Well as my Above friend said try *#*#4636#*#*

And select 3G Mode...


WCDMA Commonly..



Please Hit Thanks || It won't Cost You

Sent from S II || Running Official ICS 4.0.4 with Siyah 4.1

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes