5,603,729 Members 37,862 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Battery charging issue

Tip us?
 
bidomo
Old
#1  
Member - OP
Thanks Meter 2
Posts: 46
Join Date: Aug 2011
Location: Tlalnepantla
Default [Q] Battery charging issue

I know there are hundreds of threads like this, but I found myself with a strange problem...

My S2 will connect to USB perfectly, will be able to move data, big files like ROMs, even flashed a CF root through Odin, everything ok...

Well, it will not charge, when the USB or wall charger are connected, it will display the power icon, but will not be animated nor charging, keeps draining battery even if connected.

When it hit 5%, it kept playing the low battery/charger connected sounds, like some kind of failed USB connection, which I not believe to be the case...

Already cleaned with isopropyl alcohol the battery , battery and charging port (without alcohol).

Waiting to try it...

Any sugestions? battery seems to charge in other phones
 
MistahBungle
Old
#2  
Senior Member
Thanks Meter 3037
Posts: 6,722
Join Date: Nov 2011
Try another battery and/or replace USB board/port. Regardless of whether you can move data to/from the phone via USB, it very much sounds like the board/port needs replacing. Quick/cheap/easy to do yourself, has been covered here a lot this year - search for threads where KeithRoss39 & TheUnderling have posted on this issue to get the info you need.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Probably the best thread ever posted on XDA
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
Donate to you ?? Bahahaaaaahahahahahahaaahahaha !!!
The Following User Says Thank You to MistahBungle For This Useful Post: [ Click to Expand ]
 
bidomo
Old
(Last edited by bidomo; 24th December 2013 at 06:04 AM.)
#3  
Member - OP
Thanks Meter 2
Posts: 46
Join Date: Aug 2011
Location: Tlalnepantla
Quote:
Originally Posted by MistahBungle View Post
Try another battery and/or replace USB board/port. Regardless of whether you can move data to/from the phone via USB, it very much sounds like the board/port needs replacing. Quick/cheap/easy to do yourself, has been covered here a lot this year - search for threads where KeithRoss39 & TheUnderling have posted on this issue to get the info you need.
Already switched the usb board (as today), the battery is charging now, but only with the phone turned off, it will stay as before, not charging the battery, already installed a different ROM (using Disaster v10)

I dont think thats the battery... will try to put my hands in another battery and see.

In the meantime, is there anything else I should be trying?
 
bidomo
Old
#4  
Member - OP
Thanks Meter 2
Posts: 46
Join Date: Aug 2011
Location: Tlalnepantla
Quote:
Originally Posted by bidomo View Post
Already switched the usb board (as today), the battery is charging now, but only with the phone turned off, it will stay as before, not charging the battery, already installed a different ROM (using Disaster v10)

I dont think thats the battery... will try to put my hands in another battery and see.

In the meantime, is there anything else I should be trying?
Looks like my battery is in no good healt...

also, I have a problem with the microphone, is not getting anything, does not have the rubber protector, and only speaker phone works...

Any workround?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes