FORUMS

HTC Delivering Ads Straight to Sense Home

HTC’s 2015 has been a year marked by a desperate search for revenue.The HTC One M9 … more

Galaxy S6 & Edge get €100 Price Cut—New Models Incoming

Samsung has dropped the price of both the Galaxy S6 and S6 Edge by … more

How To Port Fully Featured Sony Xperia Z4 Camera

Xperia Z4’s hardware may not impress, but its software is definitely … more

Experimental TWRP Available For Moto G 2015

XDA Senior Member squid2 has posted experimental builds of TWRP for the Moto G … more

[Q] Bluetooth voice dialing problem

9 posts
Thanks Meter: 1
 
By interline, Junior Member on 8th June 2011, 03:15 PM
Post Reply Subscribe to Thread Email Thread
Hi

I installed " Cyberon Voice Commander " from the Market on my Galaxy S2.
The first time I used my Bluetooth headset to voice dial, the phone asked me to choose which default program I would like to use for Bluetooth voice dialing, the Cyberon voice commander or the Vlingo voice commands, I chose the Cyberon and from then on every time I pressed the Bluetooth headset it would initiate a call using the Cyberon voice commander.
Recently something changed, every time I am pressing the Bluetooth headset it starts the Vlingo voice commands, no matter what I do I can't go back to use the Cyberon voice commander as my default program, I can only use Cyberon if I open the program through my phone.
I tried using voice input and output settings and looking also through the setting of Cyberon and Vlingo, nothing works.
Could someone tell me what am I doing wrong? How do I change the default back to Cyberon.

Many Thanks.
 
 
7th July 2011, 02:14 PM |#2  
Member
Thanks Meter: 7
 
More
Same problem
I have the same problem, but Galaxy s2 never asked me what application to set as preferred.. simply I can't set Cyberon to start when pressing BT button.
It always start slingo. Maybe because my GS2 was already updated.

Cyberon wrote me it's a samsung not standard managing of BT events.

From what you wrote it seems that at the beginning the implementetion was standard, than an update broke it up.

Have you updated ROM or are samsung apps updates?

It would be nice to repack the old apps to turn back the possibility to choose BT event.

For now I use Tasker to kill Samsung Voice command process and start cyberon. It works fairy well.. but not always perfectly.


Very annoying!!

Any one??
8th July 2011, 06:20 AM |#3  
Senior Member
Thanks Meter: 48
 
More
Hi same problem here. I would like to chose the application to start with the bt headset button, but the phone forces to use the vlingo app.
8th July 2011, 08:30 AM |#4  
Senior Member
Flag Dublin
Thanks Meter: 25
 
More
My father has this app on his SGS2 and actually emailed developers about this problem.

The extremely polite and professional support (seriously, I have never read such a concrete and polite reply from a software company, ever!) said, that this is a firmware limitation and they cannot fix it.

I think this started happening after he updated firmware from Polish KF1 to newer one.

They said, that unless Samsung changes this behaviour, they cannot do anything about it, at least they are not aware of the solution for now.
9th July 2011, 11:03 AM |#5  
Member
Thanks Meter: 7
 
More
Yes Cyberon folks are very kindly and polite!!

I have found a fix!!

* Root your device
* Set google as default voice recognition instead of vlingo in settings>voice recognition (not sure this is important to do)
* Install Titanium backup (i Have paid full version, but probably you can use free
* Disable "comandi vocali" (Italy) which in english should be like "voice commands"
* Than I have cancelled the BR pairing, restarted the phone and paired BT again...
* Set Cyberon to use long press bt button to start

IT WORKS!!
The Following 2 Users Say Thank You to lwizard For This Useful Post: [ View ]
15th July 2011, 07:29 AM |#6  
Junior Member
Thanks Meter: 0
 
More
Hi all.

Yesterday I've updated firmware through KIES to last one for my region. And now I'm facing same problem
Before updating it was possible to select which app will be default for voice dial. Now, even after factory reset, phone doesn't ask me which app to use. And I unable to find "Voice Talk" in the list of All applications to change its defaults.

I don't want to root device and don't want to install firmware through ODIN. Don't ask why Just want my device to be clear.

Any help with this problem will be highly appreciated.

Thank you
18th July 2011, 07:33 AM |#7  
Junior Member
Thanks Meter: 0
 
More
Any news about this issue?
28th July 2011, 12:57 PM |#8  
stefanjadex's Avatar
Senior Member
Thanks Meter: 31
 
More
Hi all.

Today I've updated firmware through KIES to last one (KG2) for my region (Romania). Now I'm facing same problem as all the others.

Before updating it was possible to select which app will be default for voice dial (Cyberon Voice Speed Dial). Now it is launching the Vlingo by default.

I changed to Google Voice but in vain... It's still launching this useless Vlingo.

Does anybody has found a solution without rooting the phone?

Stefan
28th July 2011, 05:09 PM |#9  
Senior Member
Flag Piacenza
Thanks Meter: 12
 
More
Quote:
Originally Posted by stefanjadex

Hi all.

Today I've updated firmware through KIES to last one (KG2) for my region (Romania). Now I'm facing same problem as all the others.

Before updating it was possible to select which app will be default for voice dial (Cyberon Voice Speed Dial). Now it is launching the Vlingo by default.

I changed to Google Voice but in vain... It's still launching this useless Vlingo.

Does anybody has found a solution without rooting the phone?

Stefan

I applied solution described in post #5. It works fine.
....but you must be rooted
Last edited by kielkiam; 28th July 2011 at 05:16 PM.
10th August 2011, 01:42 AM |#10  
k1sr's Avatar
Senior Member
Thanks Meter: 13
 
More
I have a slightly different problem...

I have no issue using Vlingo (if it worked)

Firstly, it's not responding to pressing the button on my bluetooth anymore.
Secondly, when it did, the device had to be unlocked for it to work.

Damn you Vlingo.
21st September 2011, 12:54 PM |#11  
Junior Member
Thanks Meter: 0
 
More
The only legal solution is unfortunately this, as far as I know:

1 Backup the phone
2 Take it to authorized repair service
3 They will "degrade" firmware to the last version which was problem free
4 Restore from backup and hope it will work. More chance to succesfully restore is if you made a backup on previous firmware
5 Reinstall all the apps.

Well done Samsung

Bytheway can anyone tell me what was their last firmware that did not have this issue?
Last edited by niceasmay; 21st September 2011 at 01:16 PM. Reason: forgo to add

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes