Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,731,116 Members 47,127 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Bricked hardware or system?

Tip us?
 
kanenas_0
Old
#1  
Member - OP
Thanks Meter 3
Posts: 34
Join Date: Aug 2011
Default [Q] Bricked hardware or system?

Hi.

I have a Galaxy S2 i9100 running Resurrection Remix 4.0.7 (as well as its previous releases for the last couple of years).

While connected to my laptop (Win7 SP1 x64), I transferred a few files over to the phone and let it there.
When, later, I tried to transfer an extra file, the Explorer's transfer popup became unresponsive, as well as any new Explorer windows that included the phone (e.g. 'my computer'). Disconnecting the phone, let those windows open up.

I disconnected the phone and rebooted it.
It got to the RR animation logo and stayed there for over an hour. Removing the battery and restarting, had the same results.

I went into download mode to see if it's working, it did, and then I went into Recovery mode and tried to clean the cache.
It gave me this scary looking result:

CWM-based Recovery v6.0.3.6
E: Can't mount cache/recovery/command
warning: No file_contexts
E: Can't mount /cache/recovery/log
E: Can't open /cache/recovery/log
E: Can't mount /cache/recovery/last_log
E: Can't open /cache/recovery/last_log

-- Wiping cache...
Formatting cache completed

It stuck there so I restarted the phone.
No response at all from now on. Just a black screen.
No download/recovery mode, no identification when connected to the USB (by Windows itself or Odin), ADB finds no devices, the jig I got from eBay gets no response (unless I don't use it properly or maybe it's not applicable to JB systems as I seem to remember).

The phone looks like it's bricked for all intents and purposes.

So what happened? How did it get bricked?
Was it its time to do that (2 year old phone), or something I did?
Is there any possibility to restore it (I can't afford to buy a replacement nowadays).

Thanks much for any help.

P.S. I posted a similar message to the RR forum in case they have some way to get to the OS and fix something, but the problem looks generic and I might get more suggestions here. Sorry for the (almost) double post.
 
MistahBungle
Old
#2  
Senior Member
Thanks Meter 3205
Posts: 7,088
Join Date: Nov 2011
If the phone won't boot at all, no download/recovery & not detected when you connect to PC, it's cactus, I'm afraid. Having said that, search for KingRat's 'jumpstart' method where you can try to get the phone going with just the charger/minus the battery. Unlikely to work, but you might as well try it.

Why did it happen ? Impossible to say. You were running custom firmware, so it isn't the brickbug. Many people seemed to curiously begin having hardware issues (dead WiFi, dead USB ports, dead headphone jacks, damage caused by moisture exposure taking a long time to start having effects) with this phone as it approached/went past the two year mark (I was one of these people as well).

I guess you could try a new battery & replace the USB board/port which is relatively cheap to do, but that could still leave you with a non-working phone & money spent that you didn't need to spend. More likely you need to replace the motherboard; a Samsung service centre will charge you a fair bit (mostly for labour) to put a new board in, you can source a 2nd hand board more cheaply online (Google search/eBay/Swappa) & either replace it yourself, or pay a local mobile repair shop to do the swap.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
 
kanenas_0
Old
#3  
Member - OP
Thanks Meter 3
Posts: 34
Join Date: Aug 2011
Quote:
Originally Posted by MistahBungle View Post
If the phone won't boot at all, no download/recovery & not detected when you connect to PC, it's cactus, I'm afraid. Having said that, search for KingRat's 'jumpstart' method where you can try to get the phone going with just the charger/minus the battery. Unlikely to work, but you might as well try it.

Why did it happen ? Impossible to say. You were running custom firmware, so it isn't the brickbug. Many people seemed to curiously begin having hardware issues (dead WiFi, dead USB ports, dead headphone jacks, damage caused by moisture exposure taking a long time to start having effects) with this phone as it approached/went past the two year mark (I was one of these people as well).

I guess you could try a new battery & replace the USB board/port which is relatively cheap to do, but that could still leave you with a non-working phone & money spent that you didn't need to spend. More likely you need to replace the motherboard; a Samsung service centre will charge you a fair bit (mostly for labour) to put a new board in, you can source a 2nd hand board more cheaply online (Google search/eBay/Swappa) & either replace it yourself, or pay a local mobile repair shop to do the swap.
King_Rat's hotboot didn't work either.
Not a good way to start the new year

I'll look for some 3rd party service center just in case they have some way to jumper-start it (which, by fluke, also happened to my car yesterday).

Thank you much for the prompt and detailed reply.
Happy New Year.
The Following User Says Thank You to kanenas_0 For This Useful Post: [ Click to Expand ]
 
MistahBungle
Old
#4  
Senior Member
Thanks Meter 3205
Posts: 7,088
Join Date: Nov 2011
No probs. Good luck & Happy New Year to you too.
If it's important enough to cause you grief if it's lost, back it up. No excuses
Trolling for thanks is lame
Does Samsung's auto-brightness implementation crap drive you to self-harm ? A solution !
Failure to search is the leading cause of male impotence on XDA
If you don't know how to recover if things go wrong, what are you doing flashing custom roms ?
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes