Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Can't connect to PC in anyway, shape or form!

OP Woodyz82

6th February 2014, 09:28 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2012
Can anyone help?

I am a newbie to Android, but a bit of a pro with IOS!

My Brother in Law has been passed down a Galaxy S II by his Father, and want's it unlocking to all networks, so once again I have been dragged in to do it as with anything tech related.....

I have read the forums and understand how to root and unlock etc., but here is my problem.

I can't connect the phone to the PC in any way, shape or form.

It is locked to T-Mobile and is model GT-I9100 on 2.3.3 Gingerbread.

It won’t connect to Kies, Odin, or show up in explorer as a USB device etc. I have tried the suggested methods of debugging mode etc., tried various cables, different PC's, drivers.

I believe the fault is the phone, as if I plug my friends S II in Kies see it right away and installs drivers no problem, however they and on version 4.x.x.

The phone will charge via PC USB and also when I connect the cable it brings a screen up showing a USB plug and says MTP Application at the top and says connected, press the home key to quit Kies. But other than that nothing.

I also tried to update the software from 2.3.3 to the latest software via Wi-Fi from the phone, but again it gets as far as connecting to server for about a minute then just says connection failed.

I can only think it either has a software corruption or a faulty dock connector? Or perhaps I need drivers compatible with Gingerbread 2.3.3 and Windows 7.

Any help please!
7th February 2014, 12:19 AM   |  #2  
Senior Member
Thanks Meter: 3,210
 
7,087 posts
Join Date:Joined: Nov 2011
I'd be replacing the USB board/port; quick/easy/cheap (~US$15) to do - search for KeithRoss39's guide in the General sections, has all the info you need.
The Following 2 Users Say Thank You to MistahBungle For This Useful Post: [ View ]
7th February 2014, 12:33 AM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Mar 2012
Thanks for the reply.

Just had the back off and gave it a good clean, but no joy, so that may be the next step.

However when I connect the USB cable from the PC to the phone, the phone does pop up the MTP USB Application image on the screen.

But it isn't detected by PC at all.

Any ideas?
7th February 2014, 01:45 AM   |  #4  
Senior Member
Thanks Meter: 3,210
 
7,087 posts
Join Date:Joined: Nov 2011
Yes. Replace the USB board/port. It often will show only a few faults (like you're seeing) rather than crap out completely. This is what I would do if I was in your situation.
The Following 2 Users Say Thank You to MistahBungle For This Useful Post: [ View ]
7th February 2014, 02:44 AM   |  #5  
keithross39's Avatar
Senior Member
Flag Oxford
Thanks Meter: 1,209
 
1,995 posts
Join Date:Joined: Aug 2012
More
As @MistahBungle says.....these ports do fail......
There are a number of specific connectors within the port.....each one controls a different function. So it IS possible for the port to remain functioning for charging while failing for PC connection (for example).
There really is no other option than to replace the whole port/board assembly.........

Sent from my GT-I9100 using xda app-developers app
The Following User Says Thank You to keithross39 For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes