Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] Download mode on Mac OS X

OP Ingo.Weiss

12th September 2011, 09:45 PM   |  #1  
OP Junior Member
Flag Rio de Janeiro
Thanks Meter: 0
 
9 posts
Join Date:Joined: Nov 2006
More
Hi guys,

I just got a S II and I'm trying to upgrade the firmware, but I use Mac OS X with Parallels and when I put the phone on Download mode it doesn't get recognized by the Mac and then can't be mapped on Windows XP inside Parallels.

I've never had this issue with my old Milestone for example.

I get the following messages on the Mac OS logs:

Code:
12/09/2011 4:38:59.000 PM kernel: USBF:	17750.236	[0xffffff8014140800] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:05.000 PM kernel: USBF:	17756.200	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:11.000 PM kernel: USBF:	17762.201	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:17.000 PM kernel: USBF:	17768.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:18.000 PM kernel: USBF:	17769.139	[0xffffff8014140800] The IOUSBFamily was not able to enumerate a device.
12/09/2011 4:39:24.000 PM kernel: USBF:	17775.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:24.000 PM kernel: USBF:	17775.238	[0xffffff8014140800] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.238	[0xffffff8014140800] The IOUSBFamily gave up enumerating a USB device after 10 retries.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.238	[0xffffff8014140800] The IOUSBFamily was not able to enumerate a device.
Any ideas how I can get this fixed or to work?
12th September 2011, 09:50 PM   |  #2  
Member
Thanks Meter: 15
 
90 posts
Join Date:Joined: Jan 2008
More
I think you should look at Heimdall. I'm using it on linux without any problem.
12th September 2011, 09:52 PM   |  #3  
OP Junior Member
Flag Rio de Janeiro
Thanks Meter: 0
 
9 posts
Join Date:Joined: Nov 2006
More
I've tried without luck.
It gives me: "Failed to detect compatible download-mode device."

Also I don't know how to use Odin .tar files with Heimdall.

I don't know if this is a phone or Mac OS X Lion issue.
12th September 2011, 09:59 PM   |  #4  
Member
Thanks Meter: 15
 
90 posts
Join Date:Joined: Jan 2008
More
I'm using VMware Workstation(for mac VMware Fusion) for using windows only things. I have been using Odin with it. No problem for me. Also you can try Virtualbox but im not sure about good usb support.
After installing virtual machine, you should install drivers on virtual machine.
Last edited by hayspat; 12th September 2011 at 10:04 PM.
12th September 2011, 10:04 PM   |  #5  
OP Junior Member
Flag Rio de Janeiro
Thanks Meter: 0
 
9 posts
Join Date:Joined: Nov 2006
More
Thanks hayspat, but I think the problem lies on Mac OS X Lion.
If it doesn't recognize the device it can't pass it along to the VM it seems. I'm not 100% sure.

Can you check on Console.app what messages related to USB show up when you put your S II on Download mode?
12th September 2011, 10:12 PM   |  #6  
afilopou's Avatar
Senior Member
Flag Athens
Thanks Meter: 497
 
1,675 posts
Join Date:Joined: Oct 2010
More
Quote:
Originally Posted by Ingo.Weiss

Thanks hayspat, but I think the problem lies on Mac OS X Lion.
If it doesn't recognize the device it can't pass it along to the VM it seems. I'm not 100% sure.

Can you check on Console.app what messages related to USB show up when you put your S II on Download mode?

Had the same problem with snow leopard and parallels and vmware.In download mode you can not connect it to VM(or I don't know how to do it successfully).Of course with lion I had the same issues
Made bootcamp(just small partition to use odin and few other programs)

Ps installed parallel tools etc etc
No luck

Sent from my GT-I9100 using Tapatalk
12th September 2011, 10:13 PM   |  #7  
Member
Thanks Meter: 15
 
90 posts
Join Date:Joined: Jan 2008
More
I'm not using mac now but I was using Macbook Air with Snow Leopard previously.
Heimdall and VMware Fusion with Odin worked for me. I recognized successfully my Galaxy S I9000. Maybe you're right, it can be Lion's problem.
12th September 2011, 10:36 PM   |  #8  
prodygee's Avatar
Senior Member
Flag Vlaardingen
Thanks Meter: 61
 
598 posts
Join Date:Joined: Oct 2009
More
I read Heimdall has no SGS2 support on OSX yet.
31st May 2014, 03:20 AM   |  #9  
Junior Member
Thanks Meter: 0
 
1 posts
Join Date:Joined: May 2014
it's 2014 and the problem still exists
Quote:
Originally Posted by Ingo.Weiss

Hi guys,

I just got a S II and I'm trying to upgrade the firmware, but I use Mac OS X with Parallels and when I put the phone on Download mode it doesn't get recognized by the Mac and then can't be mapped on Windows XP inside Parallels.

I've never had this issue with my old Milestone for example.

I get the following messages on the Mac OS logs:

Code:
12/09/2011 4:38:59.000 PM kernel: USBF:	17750.236	[0xffffff8014140800] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:05.000 PM kernel: USBF:	17756.200	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:11.000 PM kernel: USBF:	17762.201	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:17.000 PM kernel: USBF:	17768.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:18.000 PM kernel: USBF:	17769.139	[0xffffff8014140800] The IOUSBFamily was not able to enumerate a device.
12/09/2011 4:39:24.000 PM kernel: USBF:	17775.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:24.000 PM kernel: USBF:	17775.238	[0xffffff8014140800] The IOUSBFamily is having trouble enumerating a USB device that has been plugged in.  It will keep retrying.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.202	AppleUSBEHCI[0xffffff8013ffc000]::Found a transaction which hasn't moved in 5 seconds on bus 0xfa, timing out! (Addr: 0, EP: 0)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.238	[0xffffff8014140800] The IOUSBFamily gave up enumerating a USB device after 10 retries.  (Port 3 of Hub at 0xfa100000)
12/09/2011 4:39:30.000 PM kernel: USBF:	17781.238	[0xffffff8014140800] The IOUSBFamily was not able to enumerate a device.
Any ideas how I can get this fixed or to work?

Hi,

Did you find a solution for us?

Been all over the web.
No solution found.

PROBLEM:
Finder will not see the phone in download mode. MAC simply does NOT RECOGNIZE IT
Galaxy S2 4.1.2

Finder ONLY sees phone when I activate usb utilities in settings.
But of course the phone is all booted up by then.

SOLUTION NEEDED:
MAC TO RECOGNIZE MY PHONE IN DOWNLOAD MODE

HISTORY:
Mac and Adnroid phone have a history of this.
I hope someone answers soon.
I am pretty annoyed and tired. over 100 hours of research.
I also made a utube video about this.

Thanks
31st May 2014, 07:47 AM   |  #10  
Senior Member
Thanks Meter: 3,208
 
7,088 posts
Join Date:Joined: Nov 2011
Be prepared for a very long wait. Few people post here these days, and as you've already said, this issue remains. Your best option is to use a PC/Odin whenever you need to flash anything in DL mode.

And before you arc up with 'I shouldn't have to blah blah blah', the reality is Heimdall is hit & miss at best. I've given you a solution, you can either avail yourself of it or live with the problems you've currently got (they won't be solved anytime soon given it's been 3 yrs since this phone was released).

Post Reply Subscribe to Thread

Tags
download mode, mac, sii
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes