FORUMS

ZenFone 2 Lolliflash and ZenPower Giveaway!

We recently did an in-depth review of the Asus Zenfone 2 but one of the things people may … more

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

[Q] My Galaxy S2 only accepts official ROMS, no custom rom working please help

9 posts
Thanks Meter: 1
 
By vanquishV12, Junior Member on 14th October 2011, 11:31 PM
Post Reply Subscribe to Thread Email Thread
Hi there,

I've got a huge problem.

After having tried the official Samsung ROM (2.3.5, I9100XXKI3), I rooted my phone using CF-ROOT 4.2. That works perfectly.

Then, I've downloaded a custom ROM.
I've put the .zip file at the root of my phone.
Then, I have rebooted in recovery mode.
I've done a data/cache/dalvik wipe.
I've done a "install zip from card", using the zip file of the rom.

The script says everything is allright... but after restart my phone stays blocked at the same point : the Samsung Galaxy SII logo with the yellow triangle.
Nothing more.

I've tried 4 different custom roms and it does the same with all (Cyanogenmod, MIUI, Litening, Revolution).
With the Cyanogenmod, it's a bit different : i have the same issue but it also seems to loop reboot...

The only ROM that works is the official Smasung ROM that I install using Odin.

Any idea of what I can do to fix this ?
Any idea of what I'm doing bad ?

Many thanks

PS : I would love to install a MIUI.

PS : I've justed tried again to install MIUI, and now, after rebooting after the installation from CWM, the phone goes to Recoverymode by itself and says :
E:Can't mount /cache/recovery/command
E:Can't mount /cache/recovery/log
E:Can't mount /cache/recovery/log
E:Can't mount /cache/recovery/last_log
E:Can't mount /cache/recovery/last_log
Last edited by vanquishV12; 14th October 2011 at 11:41 PM.
The Following User Says Thank You to vanquishV12 For This Useful Post: [ View ]
 
 
15th October 2011, 03:37 AM |#2  
meranto's Avatar
Senior Member
Flag Rotterdam
Thanks Meter: 120
 
More
Try Cyanogen. I've heard a few things about installing from zip twice. After it's finished the first time, install from zip again. No guarantees off course.
15th October 2011, 05:47 AM |#3  
aceofclubs's Avatar
Senior Member
Thanks Meter: 211
 
More
You could try flashing an earlier official Rom first then cfroot then Custom Rom.

Read somewhere that you need to factory reset if you're downgrading which is possible since you're going from 2.3.5.

Sent from my GT-I9100 using XDA App
15th October 2011, 06:12 AM |#4  
Member
Thanks Meter: 2
 
More
you may flash the rom twice. or u can downgrade to official 2.3.4 (KH3) via Odin and then flash other custom rom u like
15th October 2011, 09:34 AM |#5  
OP Junior Member
Thanks Meter: 1
 
More
First of all, many thanks yo you all.
@meranto : Already tried and the only thing it does is a boot loop.
@aceofclubs : Good idea. That's what I'm trying right now.
@Henrywcy81 : flash twice : see above. Downgrade : again, good idea

Any advice on which Kernel I should use ? Could it be a kernel problem ?

Many thanks guys.
15th October 2011, 09:52 AM |#6  
OP Junior Member
Thanks Meter: 1
 
More
Wow I've just tried to downgrade and WOW.
Never had so much error messages.
I loose root but everything crashes just after the first Samsung Galaxy SII logo.
I have a lot of error messages saying that the phone can't mount partitions.

Sounds bad :S
15th October 2011, 10:56 AM |#7  
aceofclubs's Avatar
Senior Member
Thanks Meter: 211
 
More
Did you flash the downgrade with Odin?



Sent from my GT-I9100 using XDA App
15th October 2011, 12:00 PM |#8  
Senior Member
Thanks Meter: 4,492
 
More
Rescue
Boot recovery
Mounts and storage
Format SD card system data cache dalvik

Power off

Download mode
Flash stock rom via Odin

jje
15th October 2011, 12:04 PM |#9  
mariosraptor's Avatar
Senior Member
Flag Corfu
Thanks Meter: 654
 
Donate to Me
More
http://forum.xda-developers.com/show....php?t=1291282
firstly flash XXKI3 by repartitioning. i had this.
The Following User Says Thank You to mariosraptor For This Useful Post: [ View ]
16th October 2011, 08:26 PM |#10  
OP Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by mariosraptor

http://forum.xda-developers.com/show....php?t=1291282
firstly flash XXKI3 by repartitioning. i had this.

Many thanks. It now works !
17th October 2011, 07:09 AM |#11  
mariosraptor's Avatar
Senior Member
Flag Corfu
Thanks Meter: 654
 
Donate to Me
More
you are very welcome!!!

Quote:
Originally Posted by vanquishV12

Many thanks. It now works !

Read More
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes