Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] galaxy s2 kernels?

OP Jumong_mirana

1st January 2014, 12:12 PM   |  #1  
OP Junior Member
4232
Thanks Meter: 0
 
3 posts
Join Date:Joined: Mar 2012
Hello im still newbie on flashing roms/kernels on galaxy s2 ive just tried flashing roms. Havent tried to flash kernels.. Do i need to wipe data before flashing kernel.. How to know if that kernel was supported on my rom.. Currently i have installed beanstalk rom 4.4. 2 and i want to flash kernel that has tweaks but im unsure of what kernel to flash on it i might got brick again if i flash unsupported one...
1st January 2014, 01:32 PM   |  #2  
Senior Member
Thanks Meter: 3,208
 
7,088 posts
Join Date:Joined: Nov 2011
Do you need to wipe data when flashing kernels ? No. You shouldn't need to wipe cache/Dalvik either, though do it if the developer of the kernel says to in the flashing instructions for the kernel.

How to determine rom compatibility for a kernel ? Read the first page of the thread devoted to the kernel. Should tell you what it's compatible with, if it doesn't, ask in the kernel thread. The worst thing that can happen if you flash & it isn't compatible is you'll end up with bootloop. Unlikely to brick your phone outright unless you're one of the 0.000001% of people who end up with a bad flash full stop.
1st January 2014, 02:57 PM   |  #3  
Sun90's Avatar
Recognized Contributor
Flag MYSORE - KARNATAKA - INDIA
Thanks Meter: 8,823
 
6,925 posts
Join Date:Joined: Oct 2011
More
Quote:
Originally Posted by Jumong_mirana

Hello im still newbie on flashing roms/kernels on galaxy s2 ive just tried flashing roms. Havent tried to flash kernels.. Do i need to wipe data before flashing kernel.. How to know if that kernel was supported on my rom.. Currently i have installed beanstalk rom 4.4. 2 and i want to flash kernel that has tweaks but im unsure of what kernel to flash on it i might got brick again if i flash unsupported one...

Stay with stock kernel that comes with 'Beanstalk 4.4.2 rom' for now

And Do some reading with the below mentioned kernel threads

http://forum.xda-developers.com/show....php?t=2222843

http://forum.xda-developers.com/show....php?t=2291756
18th February 2014, 04:42 PM   |  #4  
omkarsathe92's Avatar
Senior Member
Flag Thane
Thanks Meter: 157
 
156 posts
Join Date:Joined: Mar 2012
More
Smile Hope this helps
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes