5,595,000 Members 38,994 Now Online
XDA Developers Android and Mobile Development Forum

[Q] Galaxy S2 looses network

Tip us?
 
cromalhao
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Question [Q] Galaxy S2 looses network

hi. I have a samsung galaxy s2 i9100 (for now 3 and half years)

i am in the uk with 3 network



for some time i have been experiencing loss of network all of a sudden thoughout the day
specially if i tether my phone via wireless

i have changed its software (rom and modem) and I am still experiencing this loss of network

in order to get network again I must reboot the phone, it is the only way of getting it back working




I travel a lot to Portugal and take the phone but I do not seem to have experienced this there
tough i dont tether there nor i use the connection for data



currently i am using a slim rom 4.2.2 build 8 official

the baseband is i9100xxLs9


any toughts about what is happening? do you think the phone is to blame? software? hardware? sim card?
 
Vivek_Neel
Old
#2  
Vivek_Neel's Avatar
Recognized Contributor
Thanks Meter 16099
Posts: 5,923
Join Date: Dec 2012
Location: chennai

 
DONATE TO ME
Modem is what the culprit.

Change to other modem and see

Sent from my GT-I9100 using Tapatalk 2
 
cromalhao
Old
#3  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Jan 2014
Quote:
Originally Posted by corruptionfreeindia View Post
Modem is what the culprit.

Change to other modem and see

Sent from my GT-I9100 using Tapatalk 2
Hi! Thanks for the reply!

I already tried that. I reflashed and put a new modem aswell.

It improved the simptoms but they still persist

Any specific modem that you think i should try?

Some times my phone freaks out and just gets corrupt and i have to reflash
Do you think it might be going to die? Maybe replace it?

Best regards
 
najrazlug
Old
#4  
Junior Member
Thanks Meter 0
Posts: 6
Join Date: Jan 2014
Default Flash This Firmware

Quote:
Originally Posted by cromalhao View Post
hi. I have a samsung galaxy s2 i9100 (for now 3 and half years)

i am in the uk with 3 network



for some time i have been experiencing loss of network all of a sudden thoughout the day
specially if i tether my phone via wireless

i have changed its software (rom and modem) and I am still experiencing this loss of network

in order to get network again I must reboot the phone, it is the only way of getting it back working




I travel a lot to Portugal and take the phone but I do not seem to have experienced this there
tough i dont tether there nor i use the connection for data



currently i am using a slim rom 4.2.2 build 8 official

the baseband is i9100xxLs9


any toughts about what is happening? do you think the phone is to blame? software? hardware? sim card?
Flash with this firmware ,hope will help
I9100XXLPQ_I9100OXALPQ_I9100XXLPQ_HOME.tar
 
vishal11in
Old
#5  
Senior Member
Thanks Meter 184
Posts: 766
Join Date: Jan 2012
Put it on gsm mode which is also called 2g mode.
Monitor it if you still loose signal.
If so, then i would recommend you do a clean wipe, use any rom wipe script available and then install your rom back

Sent from my GT-I9100 using xda premium
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes