Document the Story of Your Social Life with 8tory

The different forms of social media are growing every day. It’s hard to imagine a day … more

Make Calling Your Loved Ones Easier and Cheaper this Diwali

Diwali, or Deepawali as some Indians call it, is the pride and joy of Indian … more

Big Android BBQ 5.0 Recap – XDA TV

This fifth annual Big Android BBQ has come and gone. The speakers have spoke, the sponsors have … more

Microsoft to Counter “OK Google” with Bing Torque

When Microsoft is making apps for Android, users should be aware that something … more
Post Reply

[Q] Galaxy S2 MHL cable subtitles problem

OP oneill366

1st September 2011, 12:12 PM   |  #1  
OP Junior Member
Flag Inowrocław
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2011
More
Hello there XDA users!
I have a problem with viewing subtitles for movies via my MHL cable (oryginal) on TV screen.
Stock movie player shows them (.srt) but it doesn't make subtitles dissapear when the dialogue finishes (it just leave them on when nobody is talking till the next dialogue). Other movie players from market (like mVideoPlayer or QQplayer) doesn't show subtitles on TV screen at all (just on the phone screen).
I would be very thankful of Your advice.

Cheers.
2nd September 2011, 01:28 PM   |  #2  
OP Junior Member
Flag Inowrocław
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2011
More
Am I the only one facing this problem?
Can't find solution myself.
7th September 2011, 05:15 PM   |  #3  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jul 2011
More
You are not alone in this, but apparently there are very few people (or devices ;) ) with this particular problem. I myself have this as well. I can't imagine why this is such an "exclusive" bug. The only player from the market (that I have tried) that displays subtitles over MHL is Rock Player Lite, and only if you select software decoding mode, but then you will also have a mildly annoying logo on the upper left corner of the screen... plus it crashes a lot in my case, no idea if it'll crash to you too.

May I ask what your firmware is? Mine is 2.3.3 (XWKF3).
7th September 2011, 07:47 PM   |  #4  
OP Junior Member
Flag Inowrocław
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2011
More
Thanks for Your reply.
I have Lite'ning Rom v6.1 XXKH3 and speedmod kernel K1-T30.
I didn't try Rock Player Lite as I was aware of that annoying logo. I would be very happy if I only had fix for stock player (as I consider "not disappearing" subtitles to be easier to manage, but I'm not sure).
8th September 2011, 12:08 AM   |  #5  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jul 2011
More
Same here. Apparently, the MHL interface is designed to send the video feed directly, without any interface "overlay" (in this case subtitles). No "mirroring" effect, like when in the Galaxy menus etc. Rock Player achieves that only when using software mode. In hardware mode you will get no subtitles (and no logo ). After having used mVideo Player, I searched their forums, and it was mentioned that Samsung has modified their stock player to take care of that.

As I have mentioned in another post, I have tried .srt & .sub files, as well as both ANSI & Unicode encoding for the charsets (english-only and non-english). I even changed the phone language to english, hopping that it would be something this trivial. As you can imagine, the subtitles are never removed from screen and change only when a new line is to be displayed. I can't imagine that all my subtitles are defective or that there is noone else with this kind of problem.

Come on people ! What are we doing differently? I want to belong to the rest of you fine problem-free movie-watching GalaxySII-owners ...

PS: BTW, I have this problem even when viewing on the phone's screen, not just via MHL. How about you? Also, how do you transfer files on the phone?
8th September 2011, 06:41 PM   |  #6  
OP Junior Member
Flag Inowrocław
Thanks Meter: 0
 
6 posts
Join Date:Joined: Apr 2011
More
Yes, as I posted I also have problem with not removing subtiltes till the next line on the phone screen using stock player. Thats the main problem, because i will survive with no mVideoPlayer support for MHL cable if I will be able to watch movies with properly working subtitles using stock player.
Still mVideoPlayer support would be AWESOME!
12th September 2011, 01:56 AM   |  #7  
Member
Thanks Meter: 15
 
60 posts
Join Date:Joined: Sep 2011
I too have noticed the problem of subtitles appearing, but not disappearing until the next subtitle appears, with the stock media player.

Am I reading the comment from Alchemius above correctly, to say that this is only a problem for some of the Galaxy S2s?

I just assumed it was a bug that needs to be sorted out in the software for all the SGS2 units out there.
13th September 2011, 06:40 PM   |  #8  
Junior Member
Thanks Meter: 0
 
7 posts
Join Date:Joined: Jul 2011
More
Actually, this is what I am trying to figure out myself. I have asked this question in other topics as well, but apart from a couple of owners (only 2 so far !!! 3 if I include you), I get no response. Most of the SGS2 users probably use another media player (e.g. mVideoPlayer) that has no such problem, and won't notice it.

It would be pretty weird to assume that this is a problem for only a few handsets, but then again, apart from us three, nobody else is complaining. I know that the MHL API from Samsung is indeed modified, in order to send the subtitles via MHL, and I would imagine it being responsible. But as I said, noone else is complaining. And that's what worries me...
20th September 2011, 03:33 PM   |  #9  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: Sep 2011
Ive got this problem. Im facing some crashes when some video is playing too. I think this issues is all about softwares... Maybe Ill try to change the firmware...
My fw now is UHKE2
21st September 2011, 11:37 PM   |  #10  
Senior Member
Thanks Meter: 24
 
585 posts
Join Date:Joined: Aug 2008
More
Im facing the same issues as mentioned here.
Thats sad as most of my movies I tried to move to watch them with the device on a big screen are DTS...
So DicePlayer works great..on the phone, on the screen its another thing.
BsPlayer, Vplayer and any others are slow.
mvideoplayer = no sound
What we've got left? isnt there any kind of mod or change to make the default player support it?
I dont buying an app for a few bucks. I tried Dice and it wasnt well.
I just want it to work..

And the built-in player isnt that great either, as the encoding isnt right. Im using hebrew subtitles and it shows only some signs.

Post Reply Subscribe to Thread

Tags
cable, hdmi, mhl, subtitles, tvout
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes