Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

Galaxy S2 softbricked... please help

OP Kapalition

12th June 2014, 08:41 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
No introductions here, just want to get straight to business... I don't mean to sound so impulsive but I've just been so annoyed by this and I just want a working phone again. I am running Stock Jelly Bean 4.1.2 on the carrier Vodafone (I have not rooted my phone). I have looked around the forums for answers but all of them don't seem to work for me.

This all started over a month ago when I was on Youtube and suddenly the touchscreen froze (the video was still playing) and the buttons were unresponsive. I pulled the battery out and put it back in after a few seconds. When I turned it back on it came to the 'Samsung' animation again and again (a boot loop).

Not knowing that the best option here want to go into recovery and do a factory reset, I went to recovery mode and wiped the cache partition. I rebooted the phone. But this time I was stuck on the 'Samsung Galaxy S2 GT-I9100' screen. I also found out that my recovery mode was not working. It would just have the android robot with a sphere in the middle for ages then it would reboot into the 'GT-I9100' screen. My download mode however, is still functional to this day.

As I've been told, as long as you have access to download mode, there is still hope for recovering your phone and putting it back to normal. So far I have tried:

Installing multiple stock JB ROM's such as the ROM's with LSW and MS2 on the end of the file. I have tried two versions of Odin (1.35 and 3.07) but with no results. The downloads of the ROM were no problem.The flash would be OK up until 'cache.img'. The flash would then freeze then proceed to say a big red 'FAIL'. Note that I have tried to do this on multiple computers while using different USB ports (mainport with no USB hub) for each flash. I have Kies installed but have killed all the processes and opened Odin as an administrator. I have used the original S2 cable that came with my phone and one other data cable, but still no results. I refuse to flash any PIT files because I don't like the risk associated with them. I have yet to flash these firmwares:


LSJ (JB leak), LSD, LSS, LS8, MS7


The drivers might be the problem so I might reinstall them but I don't know how...

Yesterday, I was told by a friend that he had the same problem before and all he did to simply fix this was to download the S2 Jeboo custom kernel (which has CMW with it). He also said rooting the phone would also fix it. I have attempted to flash said kernel with Odin 1.35 when it got stuck when the green bar was full. I pulled out the battery and the USB, put the battery back in and the USB (in a different port) and attempted to flash again. Nothing. I notice now that there is a yellow triangle below the 'GT-I9100' screen when I attempt to boot the phone and that my custom binary count has increased to 2. When I attempt to go into recovery mode the screen flashes twice and just stays in the 'GT-I9100' screen instead of the android robot from earlier.

That's it really. I hope someone can help me in this almost hopeless situation... I have typed about this before on another forum but I had no replies that would help me. I could go to a service centre but my warranty's gone and the yellow triangle might cause some problems. The information from xda-developers has always been solid and reliable... so can someone help me out
12th June 2014, 08:58 PM   |  #2  
Senior Member
Thanks Meter: 3,210
 
7,087 posts
Join Date:Joined: Nov 2011
Same as everyone else in this situation - find Hopper8's 'Odin troubleshooting' thread stickied in General, and go through the troubleshooting steps in a methodical manner until you get a successful stock flash, as this is the only way you're fixing it.

In your situation/given what you've already tried, I would be downloading the 3 part firmware (the 'leak' you referred to) linked to in the thread & flashing that first, which will wipe your phone & hopefully remove any remnants of what was previously on the phone which may be tripping you up.

This may not be successful first time, your flash may still barf as the one's you've tried so far have; in this case it's a matter of going through as many of the suggestions in the thread as many times as you need to until you meet success (including multiple PCs if necessary). When these are recoverable (and most are), they're often fixed by perseverance.

That thread is 'the bible' in these situations, and there isn't anything else which isn't in the thread that can be suggested in these situations, so you really do need to try absolutely every thing in that thread if you want your phone fixed.
Last edited by MistahBungle; 13th June 2014 at 07:51 AM.
The Following User Says Thank You to MistahBungle For This Useful Post: [ View ]
15th June 2014, 06:56 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
Quote:
Originally Posted by MistahBungle

Same as everyone else in this situation - find Hopper8's 'Odin troubleshooting' thread stickied in General, and go through the troubleshooting steps in a methodical manner until you get a successful stock flash, as this is the only way you're fixing it.

In your situation/given what you've already tried, I would be downloading the 3 part firmware (the 'leak' you referred to) linked to in the thread & flashing that first, which will wipe your phone & hopefully remove any remnants of what was previously on the phone which may be tripping you up.

This may not be successful first time, your flash may still barf as the one's you've tried so far have; in this case it's a matter of going through as many of the suggestions in the thread as many times as you need to until you meet success (including multiple PCs if necessary). When these are recoverable (and most are), they're often fixed by perseverance.

That thread is 'the bible' in these situations, and there isn't anything else which isn't in the thread that can be suggested in these situations, so you really do need to try absolutely every thing in that thread if you want your phone fixed.

Thanks for the quick reply, I will look into the guide in more detail and follow the instructions carefully. In regards to the flashing of the JB leak, will this fix the problem of being unable to access recovery mode? And is there any other firmwares you recommend flashing? I really don't want to wipe my phone, as I'm saving the flash of the JB leak as a last resort.
15th June 2014, 07:40 PM   |  #4  
Senior Member
Thanks Meter: 3,210
 
7,087 posts
Join Date:Joined: Nov 2011
Given what you've already tried & the information you've provided, if I was in your situation I'd be starting with the leak. But that's up to you. If you don't want to do that, you'll need to go through everything in Hopper's thread methodically; eventually you'll get a successful stock flash (and you may end up having to flash the leak to fix it anyway).

Will the leak fix your problem ? Quite possibly, but possibly not. What it will do (if it works) is take you back to a stock setup, so you'll have access to stock recovery. You may end up with bootloop after the flash even though it's successful; in that case you boot into recovery & do a wipe/factory reset.

So far as what stock firmwares to flash, it doesn't matter; they're all essentially the same. The only important thing is you get a firmware on your phone/working. But if it was me in that situation, I'd be sticking with firmwares released by your carrier (flash one of these after the leak if you go down that path).

There isn't a lot else beyond what I've already told you & I can offer; we have that thread as 'the reference' in these situations, neither I nor anyone else here can offer you anything which isn't in that thread. It's the gold standard & covers this issue from every possible angle.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes