Welcome to XDA

Search to go directly to your device's forum

Register an account

Unlock full posting privileges

Ask a question

No registration required
Post Reply

[Q] GPS not working - Galaxy S2 i9100 CM11 M7

OP MegaSharkXDA

7th July 2014, 05:51 PM   |  #1  
OP Senior Member
Thanks Meter: 3
 
114 posts
Join Date:Joined: Dec 2010
Hi,

I'm using CM11 M7 and my GPS is not working - I'm not able to get a GPS fix in direct view to the sky even during a two-hour card drive.
I've been able to get a fix to the GPS signal before with this phone, both with CM10.2 and at least with CM11 M5 (I can't remember with CM11 M6).

I have already tried getting a fix with or without Network Location on. I've also tried to reset GPS with the "GPS Status" app - all with no success whatsoever.

Any help?

Thanks in advance
14th October 2014, 12:45 PM   |  #2  
Junior Member
Thanks Meter: 0
 
3 posts
Join Date:Joined: May 2012
GPS problem fixed
I had the same issue and already tried different Modems etc. which had no effects. I also tried tightening the screws on the back of the mobile, but also to no avail.
Now (some minutes ago) I finally found a solution that works for me (GT-i9100; CM 11; 4.4.4; Baseband-Version: i9100XXLPS; Kernel: 3.0.64-CM):

I downloaded the GPS.conf from this post (post Nr. 4): http://forum.xda-developers.com/show....php?t=1789212 and copied the contents into my GPS.conf in system/etc/ (using FX-Explorer with root addon). I added the GPS-conf as *.txt to the post.

Now I get a fix in less than 5 seconds.
Let me know if it worked for you as well.

btw: I'm using O2 (DeutschlandSIM) in Germany and although the gps.conf doesn't include my country it still works perfectly
Attached Files
File Type: txt gps.conf.txt - [Click for QR Code] (1.2 KB, 80 views)
Last edited by userXt; 14th October 2014 at 01:16 PM. Reason: more info
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes