FORUMS
Post Reply Subscribe to Thread Email Thread

[Q] GPS not working - Galaxy S2 i9100 CM11 M7

7th July 2014, 04:51 PM |#1  
OP Senior Member
Thanks Meter: 3
 
More
Hi,

I'm using CM11 M7 and my GPS is not working - I'm not able to get a GPS fix in direct view to the sky even during a two-hour card drive.
I've been able to get a fix to the GPS signal before with this phone, both with CM10.2 and at least with CM11 M5 (I can't remember with CM11 M6).

I have already tried getting a fix with or without Network Location on. I've also tried to reset GPS with the "GPS Status" app - all with no success whatsoever.

Any help?

Thanks in advance
 
 
14th October 2014, 11:45 AM |#2  
Junior Member
Thanks Meter: 1
 
More
GPS problem fixed
I had the same issue and already tried different Modems etc. which had no effects. I also tried tightening the screws on the back of the mobile, but also to no avail.
Now (some minutes ago) I finally found a solution that works for me (GT-i9100; CM 11; 4.4.4; Baseband-Version: i9100XXLPS; Kernel: 3.0.64-CM):

I downloaded the GPS.conf from this post (post Nr. 4): http://forum.xda-developers.com/show....php?t=1789212 and copied the contents into my GPS.conf in system/etc/ (using FX-Explorer with root addon). I added the GPS-conf as *.txt to the post.

Now I get a fix in less than 5 seconds.
Let me know if it worked for you as well.

btw: I'm using O2 (DeutschlandSIM) in Germany and although the gps.conf doesn't include my country it still works perfectly
Attached Files
File Type: txt gps.conf.txt - [Click for QR Code] (1.2 KB, 422 views)
Last edited by userXt; 14th October 2014 at 12:16 PM. Reason: more info
The Following User Says Thank You to userXt For This Useful Post: [ View ]
27th December 2014, 02:34 PM |#3  
Junior Member
Thanks Meter: 3
 
More
works for germany eplus as well
Quote:
Originally Posted by userXt

I had the same issue and already tried different Modems etc. which had no effects. I also tried tightening the screws on the back of the mobile, but also to no avail.
Now (some minutes ago) I finally found a solution that works for me (GT-i9100; CM 11; 4.4.4; Baseband-Version: i9100XXLPS; Kernel: 3.0.64-CM):

I downloaded the GPS.conf from this post (post Nr. 4): http://forum.xda-developers.com/show....php?t=1789212 and copied the contents into my GPS.conf in system/etc/ (using FX-Explorer with root addon). I added the GPS-conf as *.txt to the post.

Now I get a fix in less than 5 seconds.
Let me know if it worked for you as well.

btw: I'm using O2 (DeutschlandSIM) in Germany and although the gps.conf doesn't include my country it still works perfectly


Thanks a lot, same for me (Eplus), also very important is to install agps data via an app like gps status.
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes