Post Reply

[Q] GT-i9100 Bootloop & Device not recognized

17th June 2014, 06:20 PM   |  #1  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
Hey guys,

a friend's Galaxy S2 (GT-i9100) hangs in a boot loop after updating Android (she says). She asked my if i could rescue her photo's, contacts, etc...

Booting Phone to Download-Mode works, connecting then via USB Windows 8 device manager prints USB\DEVICE_DESCRIPTOR_FAILURE as Hardware-ID.
There's no custom ROM installed, the device is not rooted and there's no CWM installed.
In Download mode, there's no option to "apply update from external sd card".
Tried "wipe cache partition", still boot loop.

Any ideas?!


EDIT:
I've tried to use/install various drivers. But IMHO if there's no Hardware ID / Vendor ID in the Windows Device Manager, Windows can't decide which driver matches for this device. So, if there's no device driver loaded, there's no chance for Odin or adb?! Correct me if I'm wrong.
Last edited by psm1k3; 17th June 2014 at 09:54 PM.
18th June 2014, 07:04 AM   |  #2  
Senior Member
Thanks Meter: 3,206
 
7,088 posts
Join Date:Joined: Nov 2011
Same as everyone else who's trying to do an Odin flash & having problems; Hopper8's 'Odin troubleshooting' thread stickied in General - go through the troubleshooting steps methodically (pay particular attention to the ones that relate to connectivity as that's the problem you're obviously having). Don't be surprised if your only option is to use another PC though given previous instances like yours I've seen.

Also, why would there be an option to 'update from external sd card in download mode ? You seem to be confused between it & recovery.

Download mode is very 'low level'; the only option you have is to get a stock rom from Samfirmware & flash it with Odin. This may/may not fix the problem. If it does, no data will be lost. But it's quite possible you may need to do a factory reset after the flash to fix, or even in some cases, flash the 3 part firmware linked in the thread I mentioned - in both cases this will wipe the phone.
The Following User Says Thank You to MistahBungle For This Useful Post: [ View ]
18th June 2014, 02:28 PM   |  #3  
OP Junior Member
Thanks Meter: 0
 
2 posts
Join Date:Joined: Jun 2014
Yes, you're right, i've mixed up Download & Recovery Mode. But i hope you know what my problem is.
Tried these steps (although another laptop using Windows 7), but no success.
I have another GT-i9100 which is successfully recognized by Windows 7 & 8 using Odin v1.85.

Is here any chance to extract / backup the user data from the device?


Btw:
If I boot it in Reocvery Mode, and choose "apply update from sdcard", it's possible to browse through /storage/sdcard0. It's soo depressing to see the user data and have no chance to backup them
18th June 2014, 02:40 PM   |  #4  
Senior Member
Thanks Meter: 3,206
 
7,088 posts
Join Date:Joined: Nov 2011
Unless you either get a stock rom on the phone or get the phone & PC to connect to each other so you can maybe use ADB to pull the data, you have no other way to access that data.

If after trying everything in that thread for a day or two & you still have no joy, I'd be looking at replacing the USB board in the phone (you mentioning another I9100 can connect to the same machine just fine makes me suspect this might be the cause). This is a more & more common fault with the I9100 as the period since it was released increases, and this will absolutely cause the connectivity issues you're seeing. Unfortunately, you don't really have a way to test for this definitively, best you can do is replace it & see if if works.

However, fortunately, this is easy & cheap (~US$10) to do yourself. If you decide to go down this path, search for KeithRoss39's guide in General (search for 'replacing USB charger board'/similar). This guide has all the info you need to get it done painlessly.
The Following User Says Thank You to MistahBungle For This Useful Post: [ View ]
Post Reply Subscribe to Thread
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes