Attend XDA's Second Annual Developer Conference, XDA:DevCon 2014!
5,741,079 Members 50,858 Now Online
XDA Developers Android and Mobile Development Forum

Galaxy S2 won't connect to network with a specific SIM after update to ICS

Tip us?
 
coleman84
Old
#1  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2009
Location: Bucharest
Phone Galaxy S2 won't connect to network with a specific SIM after update to ICS

Hi,

I've recently upgraded my S2 i9100 to 4.0.1 (I9100XXLPQ) from 2.3.6 and my Orange SIM does not connect to network anymore (it says "emergency calls only"); manually selecting the network doesn't work either. It worked prior to update and I've tried several roms/modems without success.

Here's the tricky part: this SIM works on my other phone just fine, and other SIMs (even from Orange) work perfectly on this S2.

IMEI is same as on back of phone..

Any suggestion?

Thanks in advance!
 
Cosmic Blue
Old
#2  
Senior Member
Thanks Meter 198
Posts: 857
Join Date: Mar 2008
Location: Toronto
call orange and have them reset your account. it should reset the sim to work with the phone.
 
przemcio510
Old
#3  
przemcio510's Avatar
Senior Member
Thanks Meter 201
Posts: 908
Join Date: May 2012
Quote:
Here's the tricky part: this SIM works on my other phone just fine, and other SIMs (even from Orange) work perfectly on this S2.
Then what causes the problem?
LGE/Google Nexus 5 D821
Resurrection Remix 5.1.5 (Android 4.4.2)
Chaos Kernel 13.0
TeamWin Recovery Project 2.7.1.1
 
coleman84
Old
#4  
Junior Member - OP
Thanks Meter 0
Posts: 2
Join Date: Apr 2009
Location: Bucharest
Ok, so I went to my local Orange Shop, have them reset my account, change my SIM card, payed my bill (to exclude every possibility that it could be a network issue ). Aaaaaaaaand.. it was still not connecting to network. Went to a "pro" guy to have it reflashed. Same problem.

After thinking to smash it into a wall, turn acid on it and put it on fire, I've decided to play around with phone's settings (though it made no sense since I've reflashed it a few dozen times, each time with different rom, so settings would be reset).

So I've deactivated the PIN request on start-up. Aaaaaaaand.. it works! It connects to network, to internet, to everything. If I switch the PIN request back on, it doesn't work.

So it works without PIN request, doesn't with PIN request. What in the name of Chewbacca is happening?

Cheers!
 
sgnn7
Old
#5  
Junior Member
Thanks Meter 2
Posts: 3
Join Date: Mar 2011
Hey guys, after much pain and suffering I was able to get it working by doing the following:

*#197328640# to enter debug menu
click "6 [common]"
click "6 [nv rebuild]"
click "2 [erases three partition!]"

reboot

May not work for everyone and to be honest I'm not sure what that erases/rebuilds but it worked for me though do it at your own risk.
 
vitacheladamix
Old
#6  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: Nov 2013
Angry Samsung t989

Quote:
Originally Posted by sgnn7 View Post
Hey guys, after much pain and suffering I was able to get it working by doing the following:

*#197328640# to enter debug menu
click "6 [common]"
click "6 [nv rebuild]"
click "2 [erases three partition!]"

reboot

May not work for everyone and to be honest I'm not sure what that erases/rebuilds but it worked for me though do it at your own risk.


it work, THANK YOU FOR SHARING
 
dubdabasoduba
Old
#7  
Junior Member
Thanks Meter 0
Posts: 1
Join Date: May 2014
Default Phone starts hanging after samsung kies update

Quote:
Originally Posted by vitacheladamix View Post
it work, THANK YOU FOR SHARING
Hi guys i updated my s2 Gt-i9100 using samsung kies which brought abt this error of selecting sim cards with pin locks and also became extremly slow please help me undo this problems.

Tags
galaxy s2, ics, no network, samsung, sim
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes