FORUMS

OnePlus 2 Forums: Discuss Everything About The OP2!

Now that the OnePlus 2 has been officially unveiled and that we have had close-up … more

Intel & Micron Announce “Revolutionary” Storage Tech

Intel & Micron have announced 3D Xpoint technology—”the … more

Google Now Interfaces With Third-Party Messaging Apps

Google has announced that Ok Google voice commands can now be used to send … more

Make Your Lockscreen More Productive With Widgets

Are you running Android Lollipop? Do you miss the ability to add widgets to your lock … more

Galaxy S2 won't connect to network with a specific SIM after update to ICS

2 posts
Thanks Meter: 0
 
By coleman84, Junior Member on 15th August 2012, 10:27 PM
Post Reply Subscribe to Thread Email Thread
Hi,

I've recently upgraded my S2 i9100 to 4.0.1 (I9100XXLPQ) from 2.3.6 and my Orange SIM does not connect to network anymore (it says "emergency calls only"); manually selecting the network doesn't work either. It worked prior to update and I've tried several roms/modems without success.

Here's the tricky part: this SIM works on my other phone just fine, and other SIMs (even from Orange) work perfectly on this S2.

IMEI is same as on back of phone..

Any suggestion?

Thanks in advance!
 
 
15th August 2012, 11:26 PM |#2  
Senior Member
Toronto
Thanks Meter: 198
 
More
call orange and have them reset your account. it should reset the sim to work with the phone.
15th August 2012, 11:58 PM |#3  
przemcio510's Avatar
Senior Member
Thanks Meter: 202
 
More
Quote:

Here's the tricky part: this SIM works on my other phone just fine, and other SIMs (even from Orange) work perfectly on this S2.

Then what causes the problem?
16th August 2012, 12:40 PM |#4  
OP Junior Member
Flag Bucharest
Thanks Meter: 0
 
More
Ok, so I went to my local Orange Shop, have them reset my account, change my SIM card, payed my bill (to exclude every possibility that it could be a network issue ). Aaaaaaaaand.. it was still not connecting to network. Went to a "pro" guy to have it reflashed. Same problem.

After thinking to smash it into a wall, turn acid on it and put it on fire, I've decided to play around with phone's settings (though it made no sense since I've reflashed it a few dozen times, each time with different rom, so settings would be reset).

So I've deactivated the PIN request on start-up. Aaaaaaaand.. it works! It connects to network, to internet, to everything. If I switch the PIN request back on, it doesn't work.

So it works without PIN request, doesn't with PIN request. What in the name of Chewbacca is happening?

Cheers!
25th December 2012, 02:44 AM |#5  
Junior Member
Thanks Meter: 2
 
More
Hey guys, after much pain and suffering I was able to get it working by doing the following:

*#197328640# to enter debug menu
click "6 [common]"
click "6 [nv rebuild]"
click "2 [erases three partition!]"

reboot

May not work for everyone and to be honest I'm not sure what that erases/rebuilds but it worked for me though do it at your own risk.
18th November 2013, 10:43 PM |#6  
Junior Member
Thanks Meter: 0
 
More
Angry Samsung t989
Quote:
Originally Posted by sgnn7

Hey guys, after much pain and suffering I was able to get it working by doing the following:

*#197328640# to enter debug menu
click "6 [common]"
click "6 [nv rebuild]"
click "2 [erases three partition!]"

reboot

May not work for everyone and to be honest I'm not sure what that erases/rebuilds but it worked for me though do it at your own risk.



it work, THANK YOU FOR SHARING
14th May 2014, 01:18 PM |#7  
Junior Member
Thanks Meter: 0
 
More
Phone starts hanging after samsung kies update
Quote:
Originally Posted by vitacheladamix

it work, THANK YOU FOR SHARING

Hi guys i updated my s2 Gt-i9100 using samsung kies which brought abt this error of selecting sim cards with pin locks and also became extremly slow please help me undo this problems.
Post Reply Subscribe to Thread

Tags
galaxy s2, ics, no network, samsung, sim
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes